summaryrefslogtreecommitdiff
path: root/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild')
-rw-r--r--games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild b/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..e7b53bcc541e
--- /dev/null
+++ b/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A multi-player game of strategy and coordination"
+HOMEPAGE="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/"
+SRC_URI="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/${P}.tgz"
+
+LICENSE="xbattle"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Since this uses similar code and the same binary name as the original XBattle,
+# we want to make sure you can't install both at the same time
+RDEPEND="
+ dev-lang/tcl:0
+ dev-lang/tk:0
+ x11-libs/libX11
+ x11-libs/libXext
+ !games-strategy/xbattle"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sandbox.patch
+)
+
+src_prepare() {
+ default
+ rm -f xbcs/foo.xbc~ || die
+}
+
+src_install() {
+ DOCS="CONTRIBUTORS README README.AI TODO xbattle.dot" \
+ default
+ mv "${D}/usr/bin/"{,xb_}gauntletCampaign || die
+}