summaryrefslogtreecommitdiff
path: root/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild')
-rw-r--r--games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild29
1 files changed, 19 insertions, 10 deletions
diff --git a/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild b/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
index e7b53bcc541e..f76d66031ae2 100644
--- a/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
+++ b/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="A multi-player game of strategy and coordination"
HOMEPAGE="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/"
@@ -11,7 +12,6 @@ SRC_URI="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattle
LICENSE="xbattle"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
# Since this uses similar code and the same binary name as the original XBattle,
# we want to make sure you can't install both at the same time
@@ -20,11 +20,18 @@ RDEPEND="
dev-lang/tk:0
x11-libs/libX11
x11-libs/libXext
- !games-strategy/xbattle"
-DEPEND="${RDEPEND}
+ !games-strategy/xbattle
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
app-text/rman
x11-misc/imake
- x11-base/xorg-proto"
+"
+
+DOCS=( CONTRIBUTORS README README.AI TODO xbattle.dot )
PATCHES=(
"${FILESDIR}"/${P}-sandbox.patch
@@ -33,10 +40,12 @@ PATCHES=(
src_prepare() {
default
rm -f xbcs/foo.xbc~ || die
+ rm config.cache || die
+
+ tc-export CC
}
src_install() {
- DOCS="CONTRIBUTORS README README.AI TODO xbattle.dot" \
- default
- mv "${D}/usr/bin/"{,xb_}gauntletCampaign || die
+ default
+ mv "${ED}/usr/bin/"{,xb_}gauntletCampaign || die
}