summaryrefslogtreecommitdiff
path: root/games-strategy/widelands
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-27 07:57:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-27 07:57:53 +0000
commitf2299aed04cae8310f7fce0be5396370e346d966 (patch)
treef553199fdc256388ed59b3d74a0b3b100765e24c /games-strategy/widelands
parent2db43213e5c343995f4b9fb977726fe42ebdac67 (diff)
gentoo auto-resync : 27:01:2023 - 07:57:53
Diffstat (limited to 'games-strategy/widelands')
-rw-r--r--games-strategy/widelands/Manifest3
-rw-r--r--games-strategy/widelands/files/widelands-1.1-gcc-13.patch124
-rw-r--r--games-strategy/widelands/widelands-1.1.ebuild4
3 files changed, 130 insertions, 1 deletions
diff --git a/games-strategy/widelands/Manifest b/games-strategy/widelands/Manifest
index ad8f2364d747..f3d0a31cd3db 100644
--- a/games-strategy/widelands/Manifest
+++ b/games-strategy/widelands/Manifest
@@ -1,4 +1,5 @@
+AUX widelands-1.1-gcc-13.patch 2866 BLAKE2B 5626b8d92838d1cb542b887ff7a5c76a48689d44a16c98d5de3ed34cd7990cdc14563a099e4d1b9826329f78f35ff1ba257f31839877a8d31eb30e336ac4340e SHA512 610ee09525f79a8db2fee2a8fedd06726c149a42af82ac27b707a347ffa87c7c7f704c7dc6498d7548bd44632bcf9132368b1ab0dbf799b1f8a351cec66484ac
DIST widelands-1.1.tar.gz 416104611 BLAKE2B e217ff5a4e3ba0431b96290dd4908d7ddadaf1850e890cee135a54f88162b30d75dbf5bc5f086d6c5e8c5e4410a0a788201117c3615e15a3e2acfd00e8f01272 SHA512 29dbeae0940468c8aad6f0fa610c8467bdb6ecf2ba5fe9175683b7cdaab5f977fa86beb71de29057c829e9738568d15e10bc22fa7fc9e58132151a1a02d72d9d
-EBUILD widelands-1.1.ebuild 1307 BLAKE2B ae056341dd68ccc35c49287d1bcfcacbb1ba92c82331406a0643a2e6ecd0c3e16652a4d118179cea920fca5348cddceba6f30ec44cd1a9a5ab645f1b88c6c28b SHA512 20e773e823b9b4ef048159fd533bf0618cbcee5c03192d402bfa3832484e5392029a92d074e7e4b77d2f86234269a95f48bf5e6cc9b3dbe5b6614634bafb2412
+EBUILD widelands-1.1.ebuild 1358 BLAKE2B 93020ccaadcee1cc368d8c753828924d2a5b32f683704d79f052d649f024dc94eeb18b86bd25df7381e36bf3b66c59276d9cdde2d470a41384982b0068637c34 SHA512 d0bc5bf2b9a228d46a1d7b55ac158a6555fa3552e80b3217074b9f0c6c6b52d1afc7117ed4fcce0290c5fa59376785c59a7846879daebf9ec1ae80b705781530
EBUILD widelands-9999.ebuild 1307 BLAKE2B ae056341dd68ccc35c49287d1bcfcacbb1ba92c82331406a0643a2e6ecd0c3e16652a4d118179cea920fca5348cddceba6f30ec44cd1a9a5ab645f1b88c6c28b SHA512 20e773e823b9b4ef048159fd533bf0618cbcee5c03192d402bfa3832484e5392029a92d074e7e4b77d2f86234269a95f48bf5e6cc9b3dbe5b6614634bafb2412
MISC metadata.xml 390 BLAKE2B 139ecbaa266c6fe37441b3e0dd05692dc9eff8301339b7ed358ff32e17c6a1a14cd52b2cf22f141381bcf76d5e9dd579575d204e5a3c1c3793b49ced61b090af SHA512 ecaa9b97ffb2302a7f356e53393f185b70b83563052066d4dd70ad7b725a9963c46b582e1a438f36d517cc52e0ff56316ea8be6c92b54fcdda1726776845f46f
diff --git a/games-strategy/widelands/files/widelands-1.1-gcc-13.patch b/games-strategy/widelands/files/widelands-1.1-gcc-13.patch
new file mode 100644
index 000000000000..c2f2501dff0d
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-1.1-gcc-13.patch
@@ -0,0 +1,124 @@
+https://github.com/widelands/widelands/pull/5765
+
+From 14b9c357073126d11d719fd1a539bb7ef0154791 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Wed, 25 Jan 2023 23:42:42 +0100
+Subject: [PATCH] Fix build with gcc 13 by including <cstdint>
+
+Like other versions before, gcc 13 moved some includes around and as a
+result <cstdint> is no longer transitively included. Explicitly include
+it for uint16_t.
+--- a/src/base/md5.h
++++ b/src/base/md5.h
+@@ -21,6 +21,7 @@
+ #define WL_BASE_MD5_H
+
+ #include <cassert>
++#include <cstdint>
+ #include <cstring>
+ #include <string>
+
+--- a/src/base/random.h
++++ b/src/base/random.h
+@@ -20,6 +20,7 @@
+ #define WL_BASE_RANDOM_H
+
+ #include <cassert>
++#include <cstdint>
+ #include <string>
+
+ extern const uint32_t rng_sbox[256];
+--- a/src/base/time_string.h
++++ b/src/base/time_string.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_BASE_TIME_STRING_H
+ #define WL_BASE_TIME_STRING_H
+
++#include <cstdint>
+ #include <string>
+
+ /// Get a string representation conforming to ISO 8601 of the current time (in
+--- a/src/build_info.h
++++ b/src/build_info.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_BUILD_INFO_H
+ #define WL_BUILD_INFO_H
+
++#include <cstdint>
+ #include <string>
+
+ constexpr uint16_t kWidelandsCopyrightStart = 2002;
+--- a/src/graphic/align.h
++++ b/src/graphic/align.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_GRAPHIC_ALIGN_H
+ #define WL_GRAPHIC_ALIGN_H
+
++#include <cstdint>
+ #include <string>
+
+ #include "base/rect.h"
+--- a/src/graphic/text/textstream.h
++++ b/src/graphic/text/textstream.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_GRAPHIC_TEXT_TEXTSTREAM_H
+ #define WL_GRAPHIC_TEXT_TEXTSTREAM_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace RT {
+--- a/src/logic/generic_save_handler.h
++++ b/src/logic/generic_save_handler.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_LOGIC_GENERIC_SAVE_HANDLER_H
+ #define WL_LOGIC_GENERIC_SAVE_HANDLER_H
+
++#include <cstdint>
+ #include <functional>
+
+ #include "io/filesystem/filesystem.h"
+--- a/src/logic/map_revision.h
++++ b/src/logic/map_revision.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_LOGIC_MAP_REVISION_H
+ #define WL_LOGIC_MAP_REVISION_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace Widelands {
+--- a/src/logic/save_handler.h
++++ b/src/logic/save_handler.h
+@@ -19,6 +19,8 @@
+ #ifndef WL_LOGIC_SAVE_HANDLER_H
+ #define WL_LOGIC_SAVE_HANDLER_H
+
++#include <cstdint>
++
+ #include "io/filesystem/filesystem.h"
+
+ namespace Widelands {
+--- a/src/map_io/map_elemental_packet.h
++++ b/src/map_io/map_elemental_packet.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_MAP_IO_MAP_ELEMENTAL_PACKET_H
+ #define WL_MAP_IO_MAP_ELEMENTAL_PACKET_H
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+--- a/src/scripting/persistence.h
++++ b/src/scripting/persistence.h
+@@ -19,6 +19,8 @@
+ #ifndef WL_SCRIPTING_PERSISTENCE_H
+ #define WL_SCRIPTING_PERSISTENCE_H
+
++#include <cstdint>
++
+ #include "scripting/lua.h"
+
+ class FileRead;
+--
+2.39.1
diff --git a/games-strategy/widelands/widelands-1.1.ebuild b/games-strategy/widelands/widelands-1.1.ebuild
index 694f1e6b01d3..4d2e256576f8 100644
--- a/games-strategy/widelands/widelands-1.1.ebuild
+++ b/games-strategy/widelands/widelands-1.1.ebuild
@@ -40,6 +40,10 @@ BDEPEND="
${PYTHON_DEPS}
sys-devel/gettext"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-gcc-13.patch
+)
+
src_configure() {
CMAKE_BUILD_TYPE=Release # disables -Werror