summaryrefslogtreecommitdiff
path: root/games-strategy/widelands/widelands-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-strategy/widelands/widelands-1.0.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-strategy/widelands/widelands-1.0.ebuild')
-rw-r--r--games-strategy/widelands/widelands-1.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-strategy/widelands/widelands-1.0.ebuild b/games-strategy/widelands/widelands-1.0.ebuild
new file mode 100644
index 000000000000..180526607235
--- /dev/null
+++ b/games-strategy/widelands/widelands-1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit xdg cmake python-any-r1
+
+DESCRIPTION="Game similar to Settlers 2"
+HOMEPAGE="https://www.widelands.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/widelands/widelands.git"
+else
+ SRC_URI="https://github.com/widelands/widelands/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="|| ( Apache-2.0 GPL-3 ) BitstreamVera CC-BY-SA-3.0 GPL-2 GPL-2+ MIT OFL-1.1 ZLIB"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/icu:=
+ media-libs/glew:0=
+ media-libs/libglvnd
+ media-libs/libpng:=
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/sdl2-image[jpeg,png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-ttf
+ net-misc/curl
+ sys-libs/zlib:=
+ virtual/libintl"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.20_rc1-cxxflags.patch
+)
+
+src_configure() {
+ CMAKE_BUILD_TYPE="Release"
+
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr/bin
+ -DWL_INSTALL_BASEDIR="${EPREFIX}"/usr/share/doc/${PF}
+ -DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/${PN}
+ -DGTK_UPDATE_ICON_CACHE=OFF
+ -DOPTION_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}