summaryrefslogtreecommitdiff
path: root/games-strategy/widelands/widelands-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
commit5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (patch)
tree5c040bbee9184b24f26b05031a2448e62f6df38a /games-strategy/widelands/widelands-1.0.ebuild
parent2c4066122b66fa1eb3e37846f9a6e14529a553d8 (diff)
gentoo auto-resync : 02:12:2022 - 08:55:37
Diffstat (limited to 'games-strategy/widelands/widelands-1.0.ebuild')
-rw-r--r--games-strategy/widelands/widelands-1.0.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/games-strategy/widelands/widelands-1.0.ebuild b/games-strategy/widelands/widelands-1.0.ebuild
deleted file mode 100644
index 62799a6e424f..000000000000
--- a/games-strategy/widelands/widelands-1.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit xdg cmake python-any-r1
-
-DESCRIPTION="Game similar to Settlers 2"
-HOMEPAGE="https://www.widelands.org/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/widelands/widelands.git"
-else
- SRC_URI="https://github.com/widelands/widelands/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-fi
-
-LICENSE="|| ( Apache-2.0 GPL-3 ) BitstreamVera CC-BY-SA-3.0 GPL-2 GPL-2+ MIT OFL-1.1 ZLIB"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/icu:=
- media-libs/glew:0=
- media-libs/libglvnd
- media-libs/libpng:=
- media-libs/libsdl2[opengl,sound,video]
- media-libs/sdl2-image[jpeg,png]
- media-libs/sdl2-mixer[vorbis]
- media-libs/sdl2-ttf
- net-misc/curl
- sys-libs/zlib:=
- virtual/libintl"
-DEPEND="
- ${RDEPEND}
- dev-libs/boost"
-BDEPEND="
- ${PYTHON_DEPS}
- sys-devel/gettext"
-
-PATCHES=(
- "${FILESDIR}"/${P}-boost-1.77.patch
- "${FILESDIR}"/${P}-gcc12-werror.patch
-)
-
-src_configure() {
- CMAKE_BUILD_TYPE="Release"
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr/bin
- -DWL_INSTALL_BASEDIR="${EPREFIX}"/usr/share/doc/${PF}
- -DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/${PN}
- -DGTK_UPDATE_ICON_CACHE=OFF
- -DOPTION_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}