summaryrefslogtreecommitdiff
path: root/games-strategy/war1gus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /games-strategy/war1gus
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'games-strategy/war1gus')
-rw-r--r--games-strategy/war1gus/Manifest3
-rw-r--r--games-strategy/war1gus/metadata.xml11
-rw-r--r--games-strategy/war1gus/war1gus-2.4.3.ebuild60
3 files changed, 74 insertions, 0 deletions
diff --git a/games-strategy/war1gus/Manifest b/games-strategy/war1gus/Manifest
new file mode 100644
index 000000000000..4190fd44ebfd
--- /dev/null
+++ b/games-strategy/war1gus/Manifest
@@ -0,0 +1,3 @@
+DIST war1gus-2.4.3.tar.gz 436938 BLAKE2B 662c3e2d16d4ca3225a50ec28ff6ae11f9c309a02c1b71e26a28155012395091dec7833a4f32a0ee6c19119a9c0aa2aa96cb465b06937da8efdd54b040189778 SHA512 909dc3375a00a4ff05eb287e6a1e3414b084f51cda37fe73ab4d728eb2d13e3e0e8612700a90e000d67a9ddffb115fe41554a4ad9db9f68e0b62cdbc0d025ae0
+EBUILD war1gus-2.4.3.ebuild 1496 BLAKE2B 88682061cccc413ed62d0916738dd40eb53f2635e58bddc11b40fdc621598a40017e64e17106a48b2188076009f57db216dbfec47c85f299568906890376503f SHA512 b7126069f9e42f13618552546d5bc9c6a407acef835271d9c3bc6842670b9ef856e87b9a2988f3aa9c0d8184a336773c1adcc097d9f3c3ffc31787cd628b9419
+MISC metadata.xml 326 BLAKE2B ee56deed66d8e6505929adafa4fd6d41ec36f71f6289134bac4c7e9efdfefd4dd8243a793ee16bbceda788759cad4827f6fcb7428b80cc93838a9b5d2a063395 SHA512 f3097f181d9ffd627b29eb7fb6df021323067955dd0610d4497bf23e49812322339a0379424bc257caddeb86b13f98d9cd52ab09c36987070006892b36aa8567
diff --git a/games-strategy/war1gus/metadata.xml b/games-strategy/war1gus/metadata.xml
new file mode 100644
index 000000000000..98971eeec5c4
--- /dev/null
+++ b/games-strategy/war1gus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Wargus/war1gus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-strategy/war1gus/war1gus-2.4.3.ebuild b/games-strategy/war1gus/war1gus-2.4.3.ebuild
new file mode 100644
index 000000000000..7871af95da19
--- /dev/null
+++ b/games-strategy/war1gus/war1gus-2.4.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Warcraft: Orcs & Humans for the Stratagus game engine"
+HOMEPAGE="https://wargus.github.io/war1gus.html
+ https://github.com/Wargus/war1gus"
+SRC_URI="https://github.com/Wargus/war1gus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ =games-engines/stratagus-${PV}*[theora]
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${EPREFIX}/usr/bin"
+ -DBINDIR="${EPREFIX}/usr/bin"
+ -DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
+ -DSHAREDIR="${EPREFIX}/usr/share/stratagus/war1gus"
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "War1gus requires the data from the original game to run. The game"
+ elog "will ask you for the location of the game data and extract/convert"
+ elog "it automatically on the first run."
+
+ if ! has_version media-video/ffmpeg ||
+ ! has_version media-sound/timidity++
+ then
+ elog
+ elog "If you did not convert the game data yet, you may want to install"
+ elog "the following optional dependencies:"
+ elog
+ elog "media-video/ffmpeg -- to convert game videos"
+ elog "media-sound/timidity++ -- to convert game music"
+ fi
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}