summaryrefslogtreecommitdiff
path: root/games-strategy/tornado
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/tornado
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/tornado')
-rw-r--r--games-strategy/tornado/Manifest4
-rw-r--r--games-strategy/tornado/files/tornado-1.4-gentoo.patch26
-rw-r--r--games-strategy/tornado/metadata.xml8
-rw-r--r--games-strategy/tornado/tornado-1.4.ebuild37
4 files changed, 75 insertions, 0 deletions
diff --git a/games-strategy/tornado/Manifest b/games-strategy/tornado/Manifest
new file mode 100644
index 000000000000..830934926e91
--- /dev/null
+++ b/games-strategy/tornado/Manifest
@@ -0,0 +1,4 @@
+AUX tornado-1.4-gentoo.patch 955 BLAKE2B 923f1f8aff22a9ac20e67220c249e57fd80a028ab8f2f58106c1c7300a29cd97e2bf52cb6403150f645a8a91f565b2a853631d656ddf80d909bfc35dd508537b SHA512 16499538f588370026e05518d5f437599b9f1a291e47c681cb8f7c3c7a88ba4dd1aafb8b979bc8fc35640777be8b54bf209433c88ac9f1c667f97a39500973d9
+DIST tornado-1.4.tar.gz 54591 BLAKE2B 6a734730e987c6e0516f08e6b3a594b46285e86f3e9b967bd6ff575dc3a55c053b9e4bb7795b51914eebed87979e2a1a290a0273f68a045630b6255cc9714794 SHA512 764c18b228a24cdcaf1456af79d1bdb997f200c09bc33d8f54df28f1f995db1b1a3a328550c5561bc8ebd38d4187f472aa1c892d91889e613b9ff42b86bee322
+EBUILD tornado-1.4.ebuild 867 BLAKE2B e846e4a5ee6325cf8a175f5864bd2cc128195e101fcb87252c9f9913775e812ae56578b2f18c5311f29d33420df3e3f1b46922af176efe4c06902ba815040c37 SHA512 e260752c861452a53624b62579efdd8246c2f104a404f3197844f9c233218ac867b530b2082e145dc5a86d2d39c9abd33519fa102d5fa26a54dd8d2340a8d82b
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-strategy/tornado/files/tornado-1.4-gentoo.patch b/games-strategy/tornado/files/tornado-1.4-gentoo.patch
new file mode 100644
index 000000000000..fb8966841158
--- /dev/null
+++ b/games-strategy/tornado/files/tornado-1.4-gentoo.patch
@@ -0,0 +1,26 @@
+--- Makefile.old 2009-02-12 12:42:25.000000000 +0100
++++ Makefile 2009-02-12 12:44:52.000000000 +0100
+@@ -1,10 +1,9 @@
+-CC = gcc
+ MAKE = make
+-LDFLAGS = -lncurses
++LDLIBS = -lncurses
+ OBJFILES = main.o draw.o erwin.o network.o scores.o
+-PREFIX = /usr/local
+-LOCALEPATH = /usr/local/share/locale
+-CFLAGS = -Wall -O2 -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
++PREFIX = /usr
++LOCALEPATH = /usr/share/locale
++CFLAGS += -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
+ VERSION = `grep " VERSION" version.h | sed s/\"//g | sed s/\#define\ VERSION\ //`
+ LOCALES = de
+ MAN = doc/man
+@@ -25,7 +24,7 @@
+ $(MAKE) -C $(MAN) all
+
+ tornado: $(OBJFILES)
+- $(CC) $(LDFLAGS) $(OBJFILES) -o tornado
++ $(CC) $(LDFLAGS) $(OBJFILES) $(LDLIBS) -o tornado
+
+ debug: tornado.6 locales
+ gcc -g -ggdb -Wall -ansi -pedantic -o tornado draw.c main.c erwin.c network.c scores.c -lncurses -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
diff --git a/games-strategy/tornado/metadata.xml b/games-strategy/tornado/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-strategy/tornado/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-strategy/tornado/tornado-1.4.ebuild b/games-strategy/tornado/tornado-1.4.ebuild
new file mode 100644
index 000000000000..0c6638176e97
--- /dev/null
+++ b/games-strategy/tornado/tornado-1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Clone of a C64 game - destroy the opponent's house"
+HOMEPAGE="http://kiza.kcore.de/software/tornado/"
+SRC_URI="http://kiza.kcore.de/software/tornado/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s:PREFIX/bin:${GAMES_BINDIR}:" \
+ -e "s:PREFIX/man:/usr/man:" \
+ -e "s:/var/games:${GAMES_STATEDIR}:" \
+ -e "s:/usr/local:/usr:" \
+ doc/man/tornado.6.in \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ dogamesbin tornado
+ doman doc/man/tornado.6
+ dodoc AUTHOR CREDITS Changelog README TODO
+ insinto "${GAMES_STATEDIR}"
+ doins tornado.scores
+ prepgamesdirs
+ fperms 664 "${GAMES_STATEDIR}/tornado.scores"
+}