summaryrefslogtreecommitdiff
path: root/games-strategy/naev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/naev
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/naev')
-rw-r--r--games-strategy/naev/Manifest4
-rw-r--r--games-strategy/naev/metadata.xml17
-rw-r--r--games-strategy/naev/naev-0.6.1-r1.ebuild79
3 files changed, 100 insertions, 0 deletions
diff --git a/games-strategy/naev/Manifest b/games-strategy/naev/Manifest
new file mode 100644
index 000000000000..113e0384af04
--- /dev/null
+++ b/games-strategy/naev/Manifest
@@ -0,0 +1,4 @@
+DIST naev-0.6.1.tar.bz2 1047908 BLAKE2B 3763440c64f89c5ceb5993a3e4ee356d0cc615df8b70dba14ce0fb35d12a0a136e82958349887d9c5a719e14d9ddfc47beb524b88650ea6f7a6859a6422d6898 SHA512 4766c80b49de5a7e748948f0404ac54edbc5afa80618150d1f993d66c7462ea73bfc5220d73073cb51cd76ff5dc6ecdf935d6f843051943136ceefaea9837203
+DIST ndata-0.6.1.zip 303984255 BLAKE2B 154d8b326e2596cfe16fc646e7d482c07d7015253b6933889d12b93a2ee7e28649b1f3ffcb0c0ed2bfe9d1e3654623cab00113486d05fe6fd1262ce989bf9c25 SHA512 71c3024e1713b094b63cb0de3c70239d61c54142b715e61d5206c5eb3cb8c7a851fc1b388ecf891110dd8bb5c2b3759af71d20f39cb6e629c71b27386a57d7fe
+EBUILD naev-0.6.1-r1.ebuild 1545 BLAKE2B 44c10dd5764f76cfb8c693d5b75072d0262f91ee88e1d0769cc931508b494f710536b6c4bf922b9a97de65f04752a8c4d416ec2323e26677900321725f6a2da9 SHA512 787650821eb5ca41c6c816961fee73b30ed915c2c2ad1fc95c1b389e32230ce809f41e92d601aa662af867db361b6404ebb66f85902b1de4b178cf52268272a0
+MISC metadata.xml 480 BLAKE2B 5769dca136bfc7d26f0b5acb60ee6598d75651b7a58d9899b6da0839180a95bee9d183c229026773ec5641e07637e3dbbfbe4fe6f77b0c466fdf62dfb01fc4cc SHA512 d42e9402581393d47976730560c1850d41e0bdd5d8bf842781222b4621db4c5c55ed5b3a886106d7bc43c3830e38bfef55182478fa7eae8bc6342cd1ec293f62
diff --git a/games-strategy/naev/metadata.xml b/games-strategy/naev/metadata.xml
new file mode 100644
index 000000000000..fd273f3193a7
--- /dev/null
+++ b/games-strategy/naev/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="mixer">
+ Enables <pkg>media-libs/sdl-mixer</pkg> sound backend in addition to
+ <pkg>media-libs/openal</pkg> one.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">naev</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-strategy/naev/naev-0.6.1-r1.ebuild b/games-strategy/naev/naev-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..c7932c3eb325
--- /dev/null
+++ b/games-strategy/naev/naev-0.6.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gnome2-utils
+
+DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
+HOMEPAGE="http://blog.naev.org/"
+SRC_URI="mirror://sourceforge/naev/${P}.tar.bz2
+ mirror://sourceforge/naev/ndata-${PV}.zip"
+
+LICENSE="GPL-2 GPL-3 public-domain CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +mixer +openal"
+
+RDEPEND="
+ media-libs/libsdl2[X,sound,video]
+ dev-libs/libzip
+ dev-libs/libxml2
+ >=media-libs/freetype-2:2
+ >=media-libs/libvorbis-1.2.1
+ >=media-libs/libpng-1.2:0=
+ virtual/glu
+ virtual/opengl
+ dev-lang/lua:0
+ mixer? ( media-libs/sdl2-mixer )
+ openal? ( media-libs/openal )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --enable-lua=shared \
+ $(use_enable debug) \
+ $(use_with openal) \
+ $(use_with mixer sdlmixer)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ appicondir=/usr/share/pixmaps \
+ appdatadir=/usr/share/appdata \
+ Graphicsdir=/usr/share/applications \
+ install
+ insinto /usr/share/${PN}
+ newins "${DISTDIR}"/ndata-${PV}.zip ndata
+
+ local res
+ for res in 16 32 64 128; do
+ newicon -s ${res} extras/logos/logo${res}.png naev.png
+ done
+
+ rm -f "${D}"/usr/share/doc/${PF}/LICENSE
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}