summaryrefslogtreecommitdiff
path: root/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild')
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild b/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild
new file mode 100644
index 000000000000..b96462b4fb9e
--- /dev/null
+++ b/games-strategy/megaglest-data/megaglest-data-3.13.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+MY_PN="megaglest"
+DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
+HOMEPAGE="https://www.megaglest.org/"
+SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/megaglest-data-${PV}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DOCS=( docs/AUTHORS.data.txt docs/CHANGELOG.txt docs/README.txt )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ # See bug https://bugs.gentoo.org/709450.
+ local mycmakeargs=(
+ -DMEGAGLEST_APPDATA_INSTALL_PATH=/usr/metainfo
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS="docs/glest_factions/"
+ cmake_src_install
+}