summaryrefslogtreecommitdiff
path: root/games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild')
-rw-r--r--games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild b/games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild
new file mode 100644
index 000000000000..152c98954194
--- /dev/null
+++ b/games-strategy/megaglest-data/megaglest-data-3.11.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="megaglest"
+DESCRIPTION="Data files for the cross-platform 3D realtime strategy game MegaGlest"
+HOMEPAGE="http://www.megaglest.org/"
+SRC_URI="https://github.com/MegaGlest/megaglest-data/releases/download/${PV}/megaglest-data-${PV}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DOCS=( docs/AUTHORS.data.txt docs/CHANGELOG.txt docs/README.txt )
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ use doc && HTML_DOCS+=( docs/glest_factions/ )
+ cmake_src_install
+}