summaryrefslogtreecommitdiff
path: root/games-strategy/maxr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /games-strategy/maxr
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'games-strategy/maxr')
-rw-r--r--games-strategy/maxr/Manifest2
-rw-r--r--games-strategy/maxr/maxr-0.2.9.ebuild23
2 files changed, 12 insertions, 13 deletions
diff --git a/games-strategy/maxr/Manifest b/games-strategy/maxr/Manifest
index 8bf86d8a34b4..62543ec23ca0 100644
--- a/games-strategy/maxr/Manifest
+++ b/games-strategy/maxr/Manifest
@@ -1,3 +1,3 @@
DIST maxr-0.2.9.tar.gz 14847180 BLAKE2B eac99b06f84a2559a6ba601396a43b98014ccea2339bd5f7b8327d000d5a5ddf032c2a1fd1c0bec9e3be16e95e170acf93bc99438400d92eb637c2fa68ebcfed SHA512 8c92d85edf152b1730a8b9e1047d41687cfac816ea854e1ec0b5068a650d399cd3cfc4c47593a2eb83604fd649a05ba649763251104fd70d49bb1cb33d4f58fc
-EBUILD maxr-0.2.9.ebuild 906 BLAKE2B 8a9d82045a516ff1ff6fcce2b65e56740fed45a327e9723b910efcf262c45c6790ba932ba0d114bb8fca9dee85b2a5d90816ce6798d10b309160981eecff2617 SHA512 cb51b58e53d9286e77628ff866f63109843c6daf64592bf3c1cdbdee284d627ab3988caa566f17c6a4db7be99ef4d39cbec3f1ae5b5a2b601887cb32b7556d65
+EBUILD maxr-0.2.9.ebuild 844 BLAKE2B 7188ff05e40982b376689252104b8d7930ff13e1fd067418af88e437a3111299cfb17639c639c7a12ddda444d08f2d95606269391125679e2847f4452ac0ca8e SHA512 c31f2df6c956002d05d5a2023555498a44812db26831ab6f52590b0bf4f53b209c3028fbcd76ea4ec4e7e1bf9e1c8553315189263d81cb544f245799b00e44b4
MISC metadata.xml 259 BLAKE2B de713fcef8fdf70397a1488db3be1d10415e1177b400921c0017b69bcfb1849bb5eaef32ca00118ff25391d52d2071af70c83b6357fbf5199e4745d34e9994e1 SHA512 8516e2364a64325b483a394a14c52e32b029beccd05586623e5dba0b861970722c3709070c8fd4b80a23f0a84b74a475485b0f2b05f44fae6f27f163714aef68
diff --git a/games-strategy/maxr/maxr-0.2.9.ebuild b/games-strategy/maxr/maxr-0.2.9.ebuild
index 4e1287280ad5..ad76a5a4f645 100644
--- a/games-strategy/maxr/maxr-0.2.9.ebuild
+++ b/games-strategy/maxr/maxr-0.2.9.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils desktop gnome2-utils
+inherit cmake desktop xdg-utils
DESCRIPTION="Mechanized Assault and Exploration Reloaded"
-HOMEPAGE="https://www.maxr.org"
+HOMEPAGE="https://www.maxr.org/"
SRC_URI="https://www.maxr.org/downloads/${P}.tar.gz"
LICENSE="GPL-2 FDL-1.2+"
@@ -14,26 +14,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dedicated"
-RDEPEND="media-libs/libsdl2[video]
+RDEPEND="
+ media-libs/libsdl2[video]
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-net"
DEPEND="${RDEPEND}"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DMAXR_BUILD_DEDICATED_SERVER=$(usex dedicated)
-DCMAKE_BUILD_TYPE=Release
)
-
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doicon -s 128 data/${PN}.png
make_desktop_entry ${PN} "Mechanized Assault and Exploration Reloaded"
}
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }