summaryrefslogtreecommitdiff
path: root/games-strategy/maxr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
commit8c364c784966be1700ea39ae45028f3e9be9cae0 (patch)
treec1971211069b79e3831b71accd52a67a9fdc77a3 /games-strategy/maxr
parent6bd95d1f6320b8666a31ec949183aaa3088aa16f (diff)
gentoo resync : 27.03.2018
Diffstat (limited to 'games-strategy/maxr')
-rw-r--r--games-strategy/maxr/Manifest4
-rw-r--r--games-strategy/maxr/maxr-0.2.8.ebuild29
-rw-r--r--games-strategy/maxr/maxr-0.2.9.ebuild39
3 files changed, 41 insertions, 31 deletions
diff --git a/games-strategy/maxr/Manifest b/games-strategy/maxr/Manifest
index ee2c4cd14233..aafb56707478 100644
--- a/games-strategy/maxr/Manifest
+++ b/games-strategy/maxr/Manifest
@@ -1,3 +1,3 @@
-DIST maxr-0.2.8.tar.gz 14738324 BLAKE2B 1e0e224cf823e3f9632a28124e9a78c46d6d417894c2df8137a3876b0143c35fb5cf63d2668f947da3e65d3317863fa686c3c7b28a31f38d8bd39ae7739124fb SHA512 22fec9ca773ea68f2639f3cb034ed271a926f99b9b17547bbbdf12a3b47ee445ab311b0766b0656c71b88a258165590431e189e695ef1a86e0fb3b799d1eaa80
-EBUILD maxr-0.2.8.ebuild 673 BLAKE2B a64c446096bafa3be56b07383460749da23142233bbfb44a85d5592554f0e3343d79e24965ea4cedef33c07b1207fdd8c15ac777feb47668f9b91ce7dbd00235 SHA512 17a7421c0ea9031ced42d01e3a4c85af59caba755a96fbf5b80714a0a6b932235946bc91577827f206b49d3484bea9e53261e35ac756178b2290473677eb89c4
+DIST maxr-0.2.9.tar.gz 14847180 BLAKE2B eac99b06f84a2559a6ba601396a43b98014ccea2339bd5f7b8327d000d5a5ddf032c2a1fd1c0bec9e3be16e95e170acf93bc99438400d92eb637c2fa68ebcfed SHA512 8c92d85edf152b1730a8b9e1047d41687cfac816ea854e1ec0b5068a650d399cd3cfc4c47593a2eb83604fd649a05ba649763251104fd70d49bb1cb33d4f58fc
+EBUILD maxr-0.2.9.ebuild 905 BLAKE2B db4edad18201fac4f21235931ad0b7ed569021266c88d33c1a31950c91b6769c752dcb07d9686a6eec5e4e332ed49716d3a58cf621d07917662fc0ac3b7e3618 SHA512 ebb1b7ae8ece72014567df38551ff5e53f98ffa6dae86d1457651f55bcd45d5f8156708284f183b5a2545e88b1394e32ce252e559dec9375f6ae47d26b802c8f
MISC metadata.xml 259 BLAKE2B de713fcef8fdf70397a1488db3be1d10415e1177b400921c0017b69bcfb1849bb5eaef32ca00118ff25391d52d2071af70c83b6357fbf5199e4745d34e9994e1 SHA512 8516e2364a64325b483a394a14c52e32b029beccd05586623e5dba0b861970722c3709070c8fd4b80a23f0a84b74a475485b0f2b05f44fae6f27f163714aef68
diff --git a/games-strategy/maxr/maxr-0.2.8.ebuild b/games-strategy/maxr/maxr-0.2.8.ebuild
deleted file mode 100644
index b183ec9420f9..000000000000
--- a/games-strategy/maxr/maxr-0.2.8.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="Mechanized Assault and Exploration Reloaded"
-HOMEPAGE="http://www.maxr.org/"
-SRC_URI="http://www.maxr.org/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2 FDL-1.2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl[video]
- media-libs/sdl-mixer[vorbis]
- media-libs/sdl-net"
-RDEPEND="${DEPEND}"
-
-src_install() {
- dogamesbin src/${PN}
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r data/*
- dodoc ABOUT CHANGELOG
- doicon data/maxr.png
- make_desktop_entry maxr "Mechanized Assault and Exploration Reloaded"
- prepgamesdirs
-}
diff --git a/games-strategy/maxr/maxr-0.2.9.ebuild b/games-strategy/maxr/maxr-0.2.9.ebuild
new file mode 100644
index 000000000000..624345a06b30
--- /dev/null
+++ b/games-strategy/maxr/maxr-0.2.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop gnome2-utils
+
+DESCRIPTION="Mechanized Assault and Exploration Reloaded"
+HOMEPAGE="http://www.maxr.org/"
+SRC_URI="http://www.maxr.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+RDEPEND="media-libs/libsdl2[video]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DMAXR_BUILD_DEDICATED_SERVER=$(usex dedicated)
+ -DCMAKE_BUILD_TYPE=Release
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon -s 128 data/${PN}.png
+ make_desktop_entry ${PN} "Mechanized Assault and Exploration Reloaded"
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }