summaryrefslogtreecommitdiff
path: root/games-strategy/maxr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/maxr
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/maxr')
-rw-r--r--games-strategy/maxr/Manifest3
-rw-r--r--games-strategy/maxr/maxr-0.2.9.ebuild39
-rw-r--r--games-strategy/maxr/metadata.xml8
3 files changed, 50 insertions, 0 deletions
diff --git a/games-strategy/maxr/Manifest b/games-strategy/maxr/Manifest
new file mode 100644
index 000000000000..8bf86d8a34b4
--- /dev/null
+++ b/games-strategy/maxr/Manifest
@@ -0,0 +1,3 @@
+DIST maxr-0.2.9.tar.gz 14847180 BLAKE2B eac99b06f84a2559a6ba601396a43b98014ccea2339bd5f7b8327d000d5a5ddf032c2a1fd1c0bec9e3be16e95e170acf93bc99438400d92eb637c2fa68ebcfed SHA512 8c92d85edf152b1730a8b9e1047d41687cfac816ea854e1ec0b5068a650d399cd3cfc4c47593a2eb83604fd649a05ba649763251104fd70d49bb1cb33d4f58fc
+EBUILD maxr-0.2.9.ebuild 906 BLAKE2B 8a9d82045a516ff1ff6fcce2b65e56740fed45a327e9723b910efcf262c45c6790ba932ba0d114bb8fca9dee85b2a5d90816ce6798d10b309160981eecff2617 SHA512 cb51b58e53d9286e77628ff866f63109843c6daf64592bf3c1cdbdee284d627ab3988caa566f17c6a4db7be99ef4d39cbec3f1ae5b5a2b601887cb32b7556d65
+MISC metadata.xml 259 BLAKE2B de713fcef8fdf70397a1488db3be1d10415e1177b400921c0017b69bcfb1849bb5eaef32ca00118ff25391d52d2071af70c83b6357fbf5199e4745d34e9994e1 SHA512 8516e2364a64325b483a394a14c52e32b029beccd05586623e5dba0b861970722c3709070c8fd4b80a23f0a84b74a475485b0f2b05f44fae6f27f163714aef68
diff --git a/games-strategy/maxr/maxr-0.2.9.ebuild b/games-strategy/maxr/maxr-0.2.9.ebuild
new file mode 100644
index 000000000000..4e1287280ad5
--- /dev/null
+++ b/games-strategy/maxr/maxr-0.2.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop gnome2-utils
+
+DESCRIPTION="Mechanized Assault and Exploration Reloaded"
+HOMEPAGE="https://www.maxr.org"
+SRC_URI="https://www.maxr.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+RDEPEND="media-libs/libsdl2[video]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DMAXR_BUILD_DEDICATED_SERVER=$(usex dedicated)
+ -DCMAKE_BUILD_TYPE=Release
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon -s 128 data/${PN}.png
+ make_desktop_entry ${PN} "Mechanized Assault and Exploration Reloaded"
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/games-strategy/maxr/metadata.xml b/games-strategy/maxr/metadata.xml
new file mode 100644
index 000000000000..c040f7c7d3e0
--- /dev/null
+++ b/games-strategy/maxr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>