summaryrefslogtreecommitdiff
path: root/games-strategy/knights-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/knights-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/knights-demo')
-rw-r--r--games-strategy/knights-demo/Manifest3
-rw-r--r--games-strategy/knights-demo/knights-demo-1.32-r2.ebuild49
-rw-r--r--games-strategy/knights-demo/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/games-strategy/knights-demo/Manifest b/games-strategy/knights-demo/Manifest
new file mode 100644
index 000000000000..152c63cfe4f3
--- /dev/null
+++ b/games-strategy/knights-demo/Manifest
@@ -0,0 +1,3 @@
+DIST knights-demo-1.32.run 31667235 BLAKE2B ee9c63a261aaea93122b790ef3d4df21b30b53d8f47e2f1549c3e6aaf7a09f04b5f7985e6d26e395266176fa9135cb7257bfc5c6f5eba7524da19758ab241715 SHA512 f53cf9524811b4a83ec2531f62ea251fc5a939cb09445ab850c7bbac85301e8b8275dda12a8dc991e4412eb4358d7597d0c007bd9263fd875289b039b941ed9c
+EBUILD knights-demo-1.32-r2.ebuild 1183 BLAKE2B 7474ab747a641cb6913a5aa26d4fcaf1e0fd319b5db9e50d133ba05af9828a6caf76318f66d627ce23b19880c92fc2e2ef27e12b3511e298d57995844a4005ce SHA512 213b7a7f8fe80e919077ad35fa68ed7d7c111ef408917e55ab307afade34ea4843bf6a0f2d6ac4a01f2d10768fd57d8bd670c04f3a20389e8d6a2485a8a8b231
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-strategy/knights-demo/knights-demo-1.32-r2.ebuild b/games-strategy/knights-demo/knights-demo-1.32-r2.ebuild
new file mode 100644
index 000000000000..d314a019ee7c
--- /dev/null
+++ b/games-strategy/knights-demo/knights-demo-1.32-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils unpacker
+
+DESCRIPTION="Anglo-Saxon medieval army battles and resource management"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=knights"
+# Unversioned upstream filename
+SRC_URI="mirror://gentoo/${P}.run"
+
+LICENSE="knights-demo"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ sys-libs/glibc
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+"
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_makeself ${P}.run
+ mv -f data{,-temp}
+ unpack ./data-temp/data.tar.gz
+ rm -rf data-temp lgp_* setup*
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/${PN}{,.dynamic}
+
+ insinto "${dir}"
+ doins -r data
+ doins EULA icon.xpm README{,.licenses}
+
+ # We don't support the dynamic version, even though we install it.
+ make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Knights and Merchants (Demo)" ${PN}
+}
diff --git a/games-strategy/knights-demo/metadata.xml b/games-strategy/knights-demo/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-strategy/knights-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>