summaryrefslogtreecommitdiff
path: root/games-strategy/freesynd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/freesynd/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/freesynd/files')
-rw-r--r--games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch b/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch
new file mode 100644
index 000000000000..817cd39dcb4f
--- /dev/null
+++ b/games-strategy/freesynd/files/freesynd-0.7.1-cmake.patch
@@ -0,0 +1,28 @@
+--- freesynd-0.7.1/CMakeLists.txt
++++ freesynd-0.7.1/CMakeLists.txt
+@@ -34,6 +34,13 @@
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_C_FLAGS}")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${EXTRA_CXX_FLAGS}")
+
++option(BUILD_DEV_TOOLS "Build development tools")
++option(WITH_DEBUG "Enable debug definitions")
++
++if(WITH_DEBUG)
++ add_definitions (-D_DEBUG)
++endif()
++
+ # Set standard definitions for all platforms.
+ add_definitions (-DSYSTEM_SDL)
+ add_definitions (-DPREFIX=\"${CMAKE_INSTALL_PREFIX}\")
+@@ -59,10 +66,7 @@
+ message (FATAL_ERROR "Unable to locate PNG")
+ endif ()
+
+-if (NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE STREQUAL "debug")
+- set (BUILD_DEV_TOOLS TRUE)
+-else ()
+- set (BUILD_DEV_TOOLS FALSE)
++if (CMAKE_BUILD_TYPE AND NOT CMAKE_BUILD_TYPE STREQUAL "debug")
+ # We only define an install target if we're doing a release build.
+ # Furthermore, on Mac, the data folder is a part of the app bundle.
+ if (NOT APPLE)