summaryrefslogtreecommitdiff
path: root/games-strategy/freeorion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /games-strategy/freeorion
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'games-strategy/freeorion')
-rw-r--r--games-strategy/freeorion/Manifest2
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild22
2 files changed, 14 insertions, 10 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index c0c01140c297..c2c4553864d2 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -4,5 +4,5 @@ DIST freeorion-0.4.7.1.tar.gz 105942075 BLAKE2B f75940ac79e329fd7e03e85b1cd712ff
EBUILD freeorion-0.4.7.1-r3.ebuild 1704 BLAKE2B aeb98f2232bf05e0030efaa6041e5817afa53af6d228c9431f105e62b4004b0bb66316848114db2e42c044bdb2f8b3b40776dcd0b861457f0c09fc91a8c6fa70 SHA512 401e40826695b6aa1158f7b3a266d7d5db7ef862dfdc62bcc598c42069e9e580cc5ab23fd349bf5558bebf7562fc0d57f189f9ed7c166bc84e078f2496b74c20
EBUILD freeorion-0.4.7.1-r4.ebuild 1772 BLAKE2B 3ad940d0d84c67cdb19c1ac21a9a15e8bfd933869fdb5fb66fc55145d7dc7d1579db052020416caf565b5511968c9ff0dd377b94536ecbe9cfc4a7a0bcf6e70a SHA512 c1bea06c10cec7172b21baefcf858c4f73ce9aaccb7745d233e55a68ec862443999faf4404a945df284fb6423d265c5b0ad3acf9e725d31d6b16e89a37fa66b2
EBUILD freeorion-0.4.7.1.ebuild 1679 BLAKE2B d60e8dca3465f700cc629f8df45b4f92efbfa1814e6d4dd2c23b40c13684cc614c947c40e931810095487cf3070077dc8ba36b36a3fcf51e5b3c657f6b6f4607 SHA512 88f9d3905770f0a97a3938d58bad1c6698c5d8b651718a19cb634aaef857582023051700bc692ae59a2b8ee83b1da6841fff1a576078f7df1705e388b6faca7b
-EBUILD freeorion-9999.ebuild 1704 BLAKE2B aeb98f2232bf05e0030efaa6041e5817afa53af6d228c9431f105e62b4004b0bb66316848114db2e42c044bdb2f8b3b40776dcd0b861457f0c09fc91a8c6fa70 SHA512 401e40826695b6aa1158f7b3a266d7d5db7ef862dfdc62bcc598c42069e9e580cc5ab23fd349bf5558bebf7562fc0d57f189f9ed7c166bc84e078f2496b74c20
+EBUILD freeorion-9999.ebuild 1692 BLAKE2B 8c6b111d87af160ae503270c103e5c2de75af27d6674b2b0d61dfdd385396ae0aa9c0ab3bce9baaa7926e0f583a45fc8250576cded97cef8bb316bbc38fdf2a3 SHA512 ca81bc4ada8ecb3bfab5e80bcf6368cb9310c828977f54a2946f4df4c6c3bacb9fce136fa6b725f5f18010820cb45ad33a80249cf6d288dc7e9bbaf926a0c999
MISC metadata.xml 684 BLAKE2B 1c415c0258973d2953f7ee0a9ff5811b17cff7000a499e2568c56b09f6c7ca40aedd345c1f377822bb0d30d50638fe76eb1e12da19da0a86b76bba9919633199 SHA512 e569a1bb722ad194a47292a6c67670fef05f5f1ac390245c81140e8fcc57f2699eec4e8037e3cae31d46d7e62eac8504d69971dc7db76226f2a31f85bb531bb1
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index 8d750687b353..578e570e2ffd 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-single-r1 gnome2-utils
+inherit cmake-utils python-single-r1 xdg
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="http://www.freeorion.org"
@@ -40,7 +40,8 @@ RDEPEND="
!dev-games/gigi"
# Use bundled gigi as of freeorion-0.4.3
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig"
@@ -57,12 +58,11 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DCMAKE_BUILD_TYPEE=Release
- -DRELEASE_COMPILE_FLAGS=""
+ -DCMAKE_BUILD_TYPE=Release
-DCMAKE_SKIP_RPATH=ON
)
- append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
+ #append-cppflags -DBOOST_OPTIONAL_CONFIG_USE_OLD_IMPLEMENTATION_OF_OPTIONAL
cmake-utils_src_configure
}
@@ -74,10 +74,14 @@ src_install() {
newenvd "${FILESDIR}/${PN}.envd" 99${PN}
}
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_pkg_postinst
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_pkg_postrm
}