summaryrefslogtreecommitdiff
path: root/games-strategy/dunelegacy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/dunelegacy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/dunelegacy')
-rw-r--r--games-strategy/dunelegacy/Manifest5
-rw-r--r--games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild57
-rw-r--r--games-strategy/dunelegacy/files/dunelegacy-0.96.3-build.patch60
-rw-r--r--games-strategy/dunelegacy/metadata.xml25
4 files changed, 147 insertions, 0 deletions
diff --git a/games-strategy/dunelegacy/Manifest b/games-strategy/dunelegacy/Manifest
new file mode 100644
index 000000000000..1f0946fbc919
--- /dev/null
+++ b/games-strategy/dunelegacy/Manifest
@@ -0,0 +1,5 @@
+AUX dunelegacy-0.96.3-build.patch 1942 BLAKE2B 8a230ae20884b11b4608437c03466a856b66e49136574ee5c55c5e90de34efbbb0bab7ed4fe90e2653b44fa1f5adb94d002e7d51912732d22bc5e891e593515c SHA512 fa3ffaa26ba1d85bc65d646347ef9c725bfb4f8b7e78c3ca13429356def201bb255d31c6ec684ca99dd0928bf9a3b83af547a7cb865ba1c2475ce03401fa91bb
+DIST dunelegacy-0.96.3-no-autoreconf.patch.xz 8908 BLAKE2B eb1c0a5a155851e199ad2c1f0cbd8f7c583ac148f92e1b2829607c0960bf09a6d8bea8e34749df726f394b3cf796f0c457086d993ace2b3336ce99ed36fb77e1 SHA512 fc17c771a19611057b2990b76eda0eea08e011dcac455bdf7e26bba1f2e2aa6cec120f2dcbce488a2318553f9e58b4a2b5ea24c7e1e27ada9ec5740f2b66ca4c
+DIST dunelegacy-0.96.3-src.tar.bz2 1652302 BLAKE2B 4502300f1364027f1734a0738a648a9ac473a142e8091d08f5c44996fa41a26e91ab030f90d3f961b95b44e7e2bcb72a376915dc014aafee5e3d0dc4f6c8915b SHA512 c84281b44bdac4eec360d90e2f23aa75468cf08c6edd6a5002c539e609312fd39e3284518ef5498201f2b0433d11cf2478cd13a2159af7c6bbef326e680fa241
+EBUILD dunelegacy-0.96.3.ebuild 1392 BLAKE2B 38f15a59aa1cbded27c61a6f5250e494228c2c1591cebe3abfaab5b27ea024d92ed6d9f7b5c0f0f82e71af305a4455cb99cbf35a6b60fa8538b74f81d77e5e32 SHA512 29ec490705192497ca8e4d27a491d70afb56af253e3e73f230a37255dc0f263de3e3acf75b3836931ae96da73f0fa3e061a9d545c6fa9d6851abc0563cbfc240
+MISC metadata.xml 1103 BLAKE2B 0c07587dff0530955a552cf5dee9835ab0c8b3478e994c0b75524ceb6914a4714e02ad13ab52fba10b401a98a068aae9990ea936333014e8c7226c07aef8983c SHA512 de8920f2cb074e969cb3b8310bf2fb111c52c90a2675833fdefc895cafac79091cee0696b52a40065cd81289d80796cb0b0e40bd8db0e349ba92ec180091edcb
diff --git a/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild b/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild
new file mode 100644
index 000000000000..ee94d40caa60
--- /dev/null
+++ b/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# do not use autotools related stuff in stable ebuilds
+# unless you like random breakage: 469796, 469798, 424041
+
+EAPI=5
+inherit eutils gnome2-utils games # STABLE ARCH
+#inherit autotools eutils gnome2-utils games # UNSTABLE ARCH
+
+DESCRIPTION="Updated clone of Westood Studios' Dune2"
+HOMEPAGE="http://dunelegacy.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+SRC_URI="${SRC_URI} https://dev.gentoo.org/~hasufell/distfiles/${P}-no-autoreconf.patch.xz" # STABLE ARCH
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+alsa pulseaudio"
+
+RDEPEND="media-libs/libsdl[X,alsa?,sound,pulseaudio?,video]
+ media-libs/sdl-mixer[midi,mp3,vorbis]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# exits on start without libsdl[alsa] or libsdl[pulseaudio]
+REQUIRED_USE="|| ( alsa pulseaudio )"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}-no-autoreconf.patch.xz # STABLE ARCH
+# epatch "${FILESDIR}"/${P}-build.patch # UNSTABLE ARCH
+# eautoreconf # UNSTABLE ARCH
+}
+
+src_install() {
+ default
+
+ doicon -s scalable ${PN}.svg
+ doicon -s 48 ${PN}.png
+ make_desktop_entry ${PN} "Dune Legacy"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/dunelegacy/files/dunelegacy-0.96.3-build.patch b/games-strategy/dunelegacy/files/dunelegacy-0.96.3-build.patch
new file mode 100644
index 000000000000..93dd907738bc
--- /dev/null
+++ b/games-strategy/dunelegacy/files/dunelegacy-0.96.3-build.patch
@@ -0,0 +1,60 @@
+Author: hasufell <hasufell@gentoo.org>
+Date: Thu Aug 9 18:57:40 2012 +0200
+
+ respect flags
+ use pkg-config
+ use LDADD instead of LDFLAGS for libs
+
+--- configure.ac
++++ configure.ac
+@@ -16,14 +16,6 @@
+
+ AC_SUBST(dunelegacydatadir)
+
+-dnl Some flags for gcc
+-CXXFLAGS="-O3 -pipe -pedantic -Wall -Wextra -Wno-unused-parameter -DNDEBUG"
+-dnl Additional flags: -Wconversion -Wno-sign-conversion
+-
+-dnl Some flags for clang
+-dnl CXXFLAGS="-O3 -pipe -pedantic -Weverything -Wno-sign-conversion -Wno-conversion -Wno-shadow -Wno-missing-noreturn -Wno-padded -Wno-packed -Wno-weak-vtables -Wno-c++11-narrowing -Wno-cast-align -Wno-unreachable-code -Wno-missing-prototypes -Wno-float-equal -Wno-global-constructors -Wno-exit-time-destructors -Wno-format-nonliteral -Wno-unused-macros -Wextra -Wno-unused-parameter"
+-
+-
+ dnl test for -ffp-contract=off (gcc >= 4.6) and use -mno-fused-madd instead
+ oldCFLAGS="$CFLAGS"
+ CFLAGS="-ffp-contract=off"
+@@ -33,34 +25,14 @@
+ )
+ CFLAGS="$oldCFLAGS"
+
+-case "$target_cpu" in
+-i*86) CXXFLAGS="$CXXFLAGS -mfpmath=sse -msse";;
+-esac
+-
+-AC_ARG_ENABLE([debug],
+- [AS_HELP_STRING([--enable-debug],
+- [compile with debug information @<:@default=disabled@:>@])],
+- [],
+- [])
+-
+-if test "$enable_debug" = "yes" ; then
+- CXXFLAGS="$CXXFLAGS -g"
+-fi
+
+ dnl Check for SDL library
+ SDL_VERSION=1.2.0
+-AM_PATH_SDL($SDL_VERSION, : , AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!]))
++PKG_CHECK_MODULES([SDL], [sdl >= $SDL_VERSION SDL_mixer])
+ CFLAGS="$CFLAGS $SDL_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
+ LIBS="$LIBS $SDL_LIBS"
+
+-dnl Check for SDL_mixer library.
+-AC_CHECK_LIB(SDL_mixer,
+- Mix_OpenAudio,
+- LIBS="$LIBS -lSDL_mixer",
+- AC_MSG_ERROR([*** SDL_mixer library not found!])
+-)
+-
+ dnl enet defines
+ AC_CHECK_FUNC(gethostbyaddr_r, [AC_DEFINE(HAS_GETHOSTBYADDR_R)])
+ AC_CHECK_FUNC(gethostbyname_r, [AC_DEFINE(HAS_GETHOSTBYNAME_R)])
diff --git a/games-strategy/dunelegacy/metadata.xml b/games-strategy/dunelegacy/metadata.xml
new file mode 100644
index 000000000000..4dc56b2c71f1
--- /dev/null
+++ b/games-strategy/dunelegacy/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://sourceforge.net/apps/mediawiki/dunelegacy/index.php?title=Development/Reporting_Bugs</bugs-to>
+ <remote-id type="sourceforge">dunelegacy</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Dune Legacy is an effort by a handful of developers to revitalize
+ the first-ever real-time strategy game. The original game was the
+ basis for the hugely successful Command and Conquer series, and the
+ gameplay has been replicated an extended to a wide variety of
+ storylines and series.
+
+ Lead one of three interplanetary houses, Atreides, Harkonnen or
+ Ordos, in an attempt to harvest the largest amount of spice from
+ the sand dunes. Exchange your spice stockpiles for credits through
+ refinement and build an army capable of thwarting attempts of the
+ other houses to stop your harvesting!
+ </longdescription>
+</pkgmetadata>