summaryrefslogtreecommitdiff
path: root/games-strategy/dunelegacy/dunelegacy-0.96.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /games-strategy/dunelegacy/dunelegacy-0.96.4.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'games-strategy/dunelegacy/dunelegacy-0.96.4.ebuild')
-rw-r--r--games-strategy/dunelegacy/dunelegacy-0.96.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-strategy/dunelegacy/dunelegacy-0.96.4.ebuild b/games-strategy/dunelegacy/dunelegacy-0.96.4.ebuild
new file mode 100644
index 000000000000..5270312de457
--- /dev/null
+++ b/games-strategy/dunelegacy/dunelegacy-0.96.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="Updated clone of Westood Studios' Dune II"
+HOMEPAGE="http://dunelegacy.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="media-libs/libsdl2[sound,threads,video]
+ media-libs/sdl2-mixer[midi]"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-init-mid.patch
+)
+
+src_prepare() {
+ default
+
+ # Prepend upstream flags.
+ sed -i -r 's/^(C.*FLAGS)=[^$]+$/\0" ${\1}"/' configure || die
+}
+
+src_install() {
+ default
+
+ doicon -s scalable ${PN}.svg
+ doicon -s 48 ${PN}.png
+ newicon -s 128 ${PN}-128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Dune Legacy"
+}