summaryrefslogtreecommitdiff
path: root/games-strategy/defcon-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/defcon-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/defcon-demo')
-rw-r--r--games-strategy/defcon-demo/Manifest5
-rw-r--r--games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild96
-rw-r--r--games-strategy/defcon-demo/files/defcon15
-rw-r--r--games-strategy/defcon-demo/metadata.xml11
4 files changed, 127 insertions, 0 deletions
diff --git a/games-strategy/defcon-demo/Manifest b/games-strategy/defcon-demo/Manifest
new file mode 100644
index 000000000000..9390dbfad4c6
--- /dev/null
+++ b/games-strategy/defcon-demo/Manifest
@@ -0,0 +1,5 @@
+AUX defcon 400 BLAKE2B 1258e4b6db8262ecd08cf481799a6a296bb7043af3a03a320a10d17ecb4672e990031ef3d2a8e1e2be915fb8f47696fb755fa4502fc194b0cdb3ca590b031857 SHA512 d417fcf9560a3b3a7232e3c86b4315f0de6ed86ce8263348520910ff6bc1d14e649f31d500f52c70c2be655836261219ca9dce4f8df9a32d5ca2b00421667058
+DIST defcon_1.6-1_amd64.deb 62377900 BLAKE2B ad6047a5f57492facf17da50a9d3003181d4352eebaa08e7185a676b3dcfb8a2c3d1001c96c09ae417d482b3a97894032084ede22f841516b9f67ed014861743 SHA512 b71aacc3cd94eec8f1ea19ee03d8098fcdd96191c12d614f55076826ef0bb44c8ada66dfd3df7d94d042b33bdd8fa5f0f58e69fc980d6213c320ab4ce2d682a9
+DIST defcon_1.6-1_i386.deb 62311684 BLAKE2B 3dddd5495410dc875d4ac9ecaea26cbbf2cb258ccdf0ffe0ddb7234009b7986c1ebcb17bdef93a579db8b41eeefaeecea9ebb09bcdb049bee14c0b6af6df26c7 SHA512 0e60e8fbca2f3046228b656990e3adb471de4f64a99d435c96b1e5a8cc49b1250c48ceeb19a4bcb58354e750398de2559256d26a38b20286dec3c0ce7f97ebb8
+EBUILD defcon-demo-1.60-r1.ebuild 2178 BLAKE2B ac3629eede6f8f96dc1dbd2e0f821682b8e73835b9110ce8259cdc38fb212fd5a5712b7755ea6302a9376ae13abd643930313ba45b81885f9bc47339910e9b5e SHA512 76deacb77ad8d5959a750bc74e71cd30d16b70394065879ea34ad7c0eb39204e7326e5efc777928b9544ad68e50534bb76ddcf605c2263b137dfea9c345f7dae
+MISC metadata.xml 390 BLAKE2B a7ff9a2ca8c3de7f31c7acea1ca630c3d0aa39fa108d6bc515c68d2801402051a863a4f1ff260ed56249cf5eef72d0638d86b746293f0b54c85642f4f569b3bb SHA512 afc01361f043a0267f09fc1a83571ade9a3cb3633744ff18e5b5c5f14ac061b5e9d6876c0b3805664a8321a6572bb6c2c3c1f3f0d9f0762d306b80a1b517ea5b
diff --git a/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild b/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
new file mode 100644
index 000000000000..486a654236bb
--- /dev/null
+++ b/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs gnome2-utils
+
+MY_PN=defcon
+MY_PV=${PV:0:3}
+MY_PVR=1
+MY_P=defcon_${MY_PV}-${MY_PVR}
+
+DESCRIPTION="Global thermonuclear war simulation with multiplayer support"
+HOMEPAGE="http://www.introversion.co.uk/defcon/"
+SRC_URI="x86? ( http://www.introversion.co.uk/defcon/downloads/${MY_P}_i386.deb )
+ amd64? ( http://www.introversion.co.uk/defcon/downloads/${MY_P}_amd64.deb )"
+
+LICENSE="Introversion"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+system-libs"
+RESTRICT="mirror strip"
+
+# glibc discussion:
+# http://forums.introversion.co.uk/defcon/viewtopic.php?t=4016
+RDEPEND="
+ media-libs/libogg
+ media-libs/libvorbis
+ >=sys-libs/glibc-2.3
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ system-libs? ( media-libs/libsdl[sound,video] )"
+DEPEND=""
+
+QA_PREBUILT="/opt/${PN}/lib/${MY_PN}.bin.x86"
+
+S="${WORKDIR}/usr/local/games/${MY_PN}"
+
+src_unpack() {
+ default
+ unpack ./data.tar.gz
+
+ cd "${S}" || die
+ # maintain compatibility with old installation/script
+ [[ -e lib64 ]] && { mv lib64 lib || die ;}
+ [[ -e ${MY_PN}.bin.x86_64 ]] && { mv ${MY_PN}.bin.x86_64 ${MY_PN}.bin.x86 || die ;}
+}
+
+src_prepare() {
+ default
+
+ # FindPath scripts are ugly and unnecessary
+ if use system-libs ; then
+ rm -f lib/lib*
+ fi
+ sed \
+ -e "s:GAMEDIR:/opt/${PN}:g" \
+ "${FILESDIR}"/${MY_PN} > "${T}"/${MY_PN} || die
+ echo "int chdir(const char *d) { return 0; }" > chdir.c || die
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c || die
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}/lib"
+ doins *.dat
+
+ exeinto "${dir}"/lib
+ doexe lib/*.so
+ doexe ${MY_PN}.bin.x86
+
+ doicon -s 128 ${MY_PN}.png
+
+ # Can be upgraded to full version, so is not installed as "demo"
+ dobin "${T}"/${MY_PN}
+ make_desktop_entry ${MY_PN} "Defcon"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ elog "Screenshots will appear in ~/.${MY_PN}/lib"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/defcon-demo/files/defcon b/games-strategy/defcon-demo/files/defcon
new file mode 100644
index 000000000000..6e9dd3b5307c
--- /dev/null
+++ b/games-strategy/defcon-demo/files/defcon
@@ -0,0 +1,15 @@
+#!/bin/sh
+if [ -n "GAMEDIR/lib" ] ; then
+ if [ "${LD_LIBRARY_PATH+set}" = "set" ] ; then
+ export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:GAMEDIR/lib"
+ else
+ export LD_LIBRARY_PATH="GAMEDIR/lib"
+ fi
+fi
+if [[ ! -e ~/.defcon/lib ]] ; then
+ mkdir -p ~/.defcon/lib \
+ && cd ~/.defcon/lib \
+ && ln -s "GAMEDIR"/lib/* .
+fi
+cd ~/.defcon/lib
+LD_PRELOAD="GAMEDIR/lib/chdir.so" exec ./defcon.bin.x86 "$@"
diff --git a/games-strategy/defcon-demo/metadata.xml b/games-strategy/defcon-demo/metadata.xml
new file mode 100644
index 000000000000..6e48df8a7f4f
--- /dev/null
+++ b/games-strategy/defcon-demo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="system-libs">Use system libraries instead of the ones included in the upstream distribution.</flag>
+ </use>
+</pkgmetadata>