summaryrefslogtreecommitdiff
path: root/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild')
-rw-r--r--games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild b/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
index 4d2f1544bc82..123c3f6c0bef 100644
--- a/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
+++ b/games-strategy/defcon-demo/defcon-demo-1.60-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils toolchain-funcs gnome2-utils
+
+inherit desktop toolchain-funcs gnome2-utils
MY_PN=defcon
MY_PV=${PV:0:3}
@@ -31,7 +32,6 @@ RDEPEND="
x11-libs/libXdmcp
x11-libs/libXext
system-libs? ( media-libs/libsdl[sound,video] )"
-DEPEND=""
QA_PREBUILT="/opt/${PN}/lib/${MY_PN}.bin.x86"
@@ -61,17 +61,17 @@ src_prepare() {
}
src_compile() {
- echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c"
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c || die
+ echo "$(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c"
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -fPIC -shared -o lib/chdir.so chdir.c || die
}
src_install() {
- local dir="/opt/${PN}"
+ local dir=/opt/${PN}
- insinto "${dir}/lib"
+ insinto ${dir}/lib
doins *.dat
- exeinto "${dir}"/lib
+ exeinto ${dir}/lib
doexe lib/*.so
doexe ${MY_PN}.bin.x86