summaryrefslogtreecommitdiff
path: root/games-strategy/colobot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-strategy/colobot
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/colobot')
-rw-r--r--games-strategy/colobot/Manifest4
-rw-r--r--games-strategy/colobot/colobot-0.1.11.ebuild58
-rw-r--r--games-strategy/colobot/colobot-9999.ebuild58
-rw-r--r--games-strategy/colobot/metadata.xml19
4 files changed, 0 insertions, 139 deletions
diff --git a/games-strategy/colobot/Manifest b/games-strategy/colobot/Manifest
deleted file mode 100644
index 24574f7a7939..000000000000
--- a/games-strategy/colobot/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST colobot-0.1.11.tar.gz 1430595 BLAKE2B 6e4a23f17631031a6f502b045637949d99bfcf8aa723f11c406c8cdb9b201b9a2771de8b8c92829bc890848a19eb182bc30a45a51e6d281ce64370f6c7a0d8a5 SHA512 fe32bc56b6fae9435c74a73b694b7d2b93667e5d15b1c57a7558e492613f0a5d4cab72ff341ab4c921150137282cc71292a1e31eb1ed06c752de33c50120f20e
-EBUILD colobot-0.1.11.ebuild 1372 BLAKE2B b40e81306d7fc183e9d523db5d60cd19a88880e010584bc4ccb762734ad34fe7ffc1ff50660cdd80e38edca4edfb915c047d4da93caafb82d1fec0c5779879e3 SHA512 19012df06321273072c51cd9408c80f487f53e979c0eaf31edf1fab574d3a41d4a37582a05888f4486891ae057e5341905f28dd686a8e94552d9fb38062cd0cd
-EBUILD colobot-9999.ebuild 1372 BLAKE2B b40e81306d7fc183e9d523db5d60cd19a88880e010584bc4ccb762734ad34fe7ffc1ff50660cdd80e38edca4edfb915c047d4da93caafb82d1fec0c5779879e3 SHA512 19012df06321273072c51cd9408c80f487f53e979c0eaf31edf1fab574d3a41d4a37582a05888f4486891ae057e5341905f28dd686a8e94552d9fb38062cd0cd
-MISC metadata.xml 528 BLAKE2B 55374b7caad73e5a5a2a7ecd705dd8631158642fcd6444417d422b1b433d36f92d741ae3fd097748d0cdd80651834bd63281179aece38a8ab6a92bed6fed968b SHA512 112e65009d79a3cee912908358f763c294d2662cd1c8119506c678a9763940f7c323f99bf1cdb8880aecd7fb6df81be9d1ddfb5802a1a87e4a0edc841217e98f
diff --git a/games-strategy/colobot/colobot-0.1.11.ebuild b/games-strategy/colobot/colobot-0.1.11.ebuild
deleted file mode 100644
index 02e4757ef02e..000000000000
--- a/games-strategy/colobot/colobot-0.1.11.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils desktop
-
-DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
-HOMEPAGE="https://colobot.info/"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/colobot/colobot"
- EGIT_SUBMODULES=()
- inherit git-r3
-else
- SRC_URI="https://github.com/colobot/colobot/archive/${PN}-gold-${PV}-alpha.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${PN}-gold-${PV}-alpha"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="devbuild test tools doc +openal"
-
-DEPEND="
- dev-games/physfs
- dev-libs/boost:=
- media-libs/glew:0
- media-libs/libogg
- media-libs/libpng:0=
- media-libs/libsdl2:=
- media-libs/libsndfile:=
- media-libs/libvorbis:=
- media-libs/sdl2-image
- media-libs/sdl2-ttf
- media-sound/vorbis-tools
- sys-devel/gettext
- openal? ( media-libs/openal )"
-RDEPEND="${DEPEND}
- games-strategy/colobot-data"
-
-src_configure() {
- local mycmakeargs=(
- -DDEV_BUILD=$(usex devbuild)
- -DTESTS=$(usex test)
- -DTOOLS=$(usex tools)
- -DINSTALL_DOCS=$(usex doc)
- -DOPENAL_SOUND=$(usex openal)
- -DCOLOBOT_INSTALL_BIN_DIR="${EPREFIX}"/usr/bin
- -DCOLOBOT_INSTALL_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- doicon -s 256 desktop/colobot.ico
-}
diff --git a/games-strategy/colobot/colobot-9999.ebuild b/games-strategy/colobot/colobot-9999.ebuild
deleted file mode 100644
index 02e4757ef02e..000000000000
--- a/games-strategy/colobot/colobot-9999.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils desktop
-
-DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
-HOMEPAGE="https://colobot.info/"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/colobot/colobot"
- EGIT_SUBMODULES=()
- inherit git-r3
-else
- SRC_URI="https://github.com/colobot/colobot/archive/${PN}-gold-${PV}-alpha.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${PN}-gold-${PV}-alpha"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="devbuild test tools doc +openal"
-
-DEPEND="
- dev-games/physfs
- dev-libs/boost:=
- media-libs/glew:0
- media-libs/libogg
- media-libs/libpng:0=
- media-libs/libsdl2:=
- media-libs/libsndfile:=
- media-libs/libvorbis:=
- media-libs/sdl2-image
- media-libs/sdl2-ttf
- media-sound/vorbis-tools
- sys-devel/gettext
- openal? ( media-libs/openal )"
-RDEPEND="${DEPEND}
- games-strategy/colobot-data"
-
-src_configure() {
- local mycmakeargs=(
- -DDEV_BUILD=$(usex devbuild)
- -DTESTS=$(usex test)
- -DTOOLS=$(usex tools)
- -DINSTALL_DOCS=$(usex doc)
- -DOPENAL_SOUND=$(usex openal)
- -DCOLOBOT_INSTALL_BIN_DIR="${EPREFIX}"/usr/bin
- -DCOLOBOT_INSTALL_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- doicon -s 256 desktop/colobot.ico
-}
diff --git a/games-strategy/colobot/metadata.xml b/games-strategy/colobot/metadata.xml
deleted file mode 100644
index 3816bd533efb..000000000000
--- a/games-strategy/colobot/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>fdsfgs@krutt.org</email>
- <name>soredake</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <upstream>
- <remote-id type="github">colobot/colobot</remote-id>
- </upstream>
- <use>
- <flag name="devbuild">TODO</flag>
- <flag name="tools">Build tools</flag>
- </use>
-</pkgmetadata>