summaryrefslogtreecommitdiff
path: root/games-strategy/colobot/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-19 11:57:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-19 11:57:35 +0100
commit6031cee8b35a5f0d7a1fee157d2cefcc05649608 (patch)
tree5c0c42caeec5e4a3c894667d689aad19aaf7ba1f /games-strategy/colobot/files
parent59f8187afe529efeffdc2f967c451b159da44d5c (diff)
gentoo auto-resync : 19:04:2023 - 11:57:35
Diffstat (limited to 'games-strategy/colobot/files')
-rw-r--r--games-strategy/colobot/files/colobot-0.2.0_alpha-gcc13.patch26
-rw-r--r--games-strategy/colobot/files/colobot-0.2.0_alpha-werror.patch20
2 files changed, 46 insertions, 0 deletions
diff --git a/games-strategy/colobot/files/colobot-0.2.0_alpha-gcc13.patch b/games-strategy/colobot/files/colobot-0.2.0_alpha-gcc13.patch
new file mode 100644
index 000000000000..f74dcb56db25
--- /dev/null
+++ b/games-strategy/colobot/files/colobot-0.2.0_alpha-gcc13.patch
@@ -0,0 +1,26 @@
+https://github.com/colobot/colobot/pull/1576
+
+From 96d32db288ccd5ab13afdb2a063ad9e03170c4ee Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 19 Apr 2023 05:18:06 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/899034
+--- a/src/CBot/CBotFileUtils.h
++++ b/src/CBot/CBotFileUtils.h
+@@ -19,6 +19,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <iostream>
+ #include <string>
+
+--
+2.40.0
+
diff --git a/games-strategy/colobot/files/colobot-0.2.0_alpha-werror.patch b/games-strategy/colobot/files/colobot-0.2.0_alpha-werror.patch
new file mode 100644
index 000000000000..b326a0c0f7af
--- /dev/null
+++ b/games-strategy/colobot/files/colobot-0.2.0_alpha-werror.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -155,7 +155,7 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU")
+
+ message(STATUS "Detected GCC version 4.7+")
+
+- set(NORMAL_CXX_FLAGS "-std=gnu++11 -Wall -Werror -Wold-style-cast -pedantic-errors -Wmissing-declarations")
++ set(NORMAL_CXX_FLAGS "-std=gnu++11 -Wall -Wold-style-cast -pedantic-errors -Wmissing-declarations")
+ set(NORMAL_CXX_FLAGS "${NORMAL_CXX_FLAGS} -Wno-error=deprecated-declarations") # updated version of physfs is not available on some platforms so we keep using deprecated functions, see #958
+
+ if(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0)
+@@ -177,7 +177,7 @@ elseif(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -fuse-ld=bfd")
+ endif()
+
+- set(NORMAL_CXX_FLAGS "-std=c++11 -Wall -Werror -Wold-style-cast -pedantic-errors -Wmissing-prototypes")
++ set(NORMAL_CXX_FLAGS "-std=c++11 -Wall -Wold-style-cast -pedantic-errors -Wmissing-prototypes")
+ set(NORMAL_CXX_FLAGS "${NORMAL_CXX_FLAGS} -Wno-error=deprecated-declarations") # updated version of physfs is not available on some platforms so we keep using deprecated functions, see #958
+ set(RELEASE_CXX_FLAGS "-O2")
+ set(DEBUG_CXX_FLAGS "-g -O0")