summaryrefslogtreecommitdiff
path: root/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-14 22:34:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-14 22:34:48 +0000
commitcc83ac38154440239f732731b8df86ce322c615e (patch)
tree18fc63c9dac77b03150b94ffd85b724863187af3 /games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
parentdfd7c8230bca447ee0b09dc11150181b0b3148e2 (diff)
gentoo auto-resync : 14:11:2023 - 22:34:48
Diffstat (limited to 'games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild')
-rw-r--r--games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild b/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
deleted file mode 100644
index f0825a21b49e..000000000000
--- a/games-strategy/colobot-data/colobot-data-0.2.0_alpha.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake python-any-r1
-
-MY_PV=${PV/_/-}
-MY_P=colobot-gold-${MY_PV}
-MUSIC_P=colobot-music_ogg_${MY_PV}
-
-DESCRIPTION="Data package for colobot (Colonize with Bots)"
-HOMEPAGE="https://colobot.info/"
-SRC_URI="
- https://github.com/colobot/colobot-data/archive/${MY_P}.tar.gz -> ${MY_P}.data.tar.gz
- music? (
- https://colobot.info/files/music/${MUSIC_P}.tar.gz )"
-S=${WORKDIR}/${PN}-${MY_P}
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="+music"
-
-BDEPEND=${PYTHON_DEPS}
-
-src_unpack() {
- unpack "${MY_P}.data.tar.gz"
- if use music; then
- tar -x -f "${DISTDIR}/${MUSIC_P}.tar.gz" -C "${S}/music" || die "Failed to unpack music"
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-
- if use music; then
- sed -i -e '/find_program(WGET wget)/d' -e '/if(NOT WGET)/,+2 d' music/CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DMUSIC=$(usex music)
- -DMUSIC_FLAC=OFF
- )
- cmake_src_configure
-}