summaryrefslogtreecommitdiff
path: root/games-strategy/0ad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/0ad
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/0ad')
-rw-r--r--games-strategy/0ad/0ad-0.0.22_alpha.ebuild146
-rw-r--r--games-strategy/0ad/0ad-0.0.23_alpha.ebuild147
-rw-r--r--games-strategy/0ad/Manifest6
-rw-r--r--games-strategy/0ad/files/0ad-0.0.21_alpha-gentoo.patch88
-rw-r--r--games-strategy/0ad/metadata.xml19
5 files changed, 406 insertions, 0 deletions
diff --git a/games-strategy/0ad/0ad-0.0.22_alpha.ebuild b/games-strategy/0ad/0ad-0.0.22_alpha.ebuild
new file mode 100644
index 000000000000..1cb088436b4b
--- /dev/null
+++ b/games-strategy/0ad/0ad-0.0.22_alpha.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,ssl"
+
+inherit eutils wxwidgets toolchain-funcs gnome2-utils python-any-r1
+
+MY_P=0ad-${PV/_/-}
+DESCRIPTION="A free, real-time strategy game"
+HOMEPAGE="https://play0ad.com/"
+SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="editor +lobby nvtt pch test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/icu:=
+ dev-libs/libxml2
+ dev-libs/nspr
+ ~games-strategy/0ad-data-${PV}
+ media-libs/libpng:0
+ media-libs/libsdl2[X,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ net-libs/enet:1.3
+ net-libs/miniupnpc:=
+ net-misc/curl
+ sys-libs/zlib
+ virtual/jpeg:0
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
+ lobby? ( >=net-libs/gloox-1.0.20 )
+ nvtt? ( media-gfx/nvidia-texture-tools )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ test? ( dev-lang/perl )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ use editor && setup-wxwidgets
+}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.21_alpha-gentoo.patch
+)
+
+src_configure() {
+ local myconf=(
+ --with-system-nvtt
+ --with-system-miniupnpc
+ --minimal-flags
+ $(usex nvtt "" "--without-nvtt")
+ $(usex pch "" "--without-pch")
+ $(usex test "" "--without-tests")
+ $(usex editor "--atlas" "")
+ $(usex lobby "" "--without-lobby")
+ --collada
+ --bindir="/usr/bin"
+ --libdir="/usr/$(get_libdir)"/${PN}
+ --datadir="/usr/share/${PN}"
+ )
+
+ # stock premake4 does not work, use the shipped one
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+ # regenerate scripts.c so our patch applies
+ cd "${S}"/build/premake/premake4 || die
+ "${S}"/build/premake/premake4/bin/release/premake4 embed || die
+
+ # rebuild premake again... this is the most stupid build system
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+ # run premake to create build scripts
+ cd "${S}"/build/premake || die
+ "${S}"/build/premake/premake4/bin/release/premake4 \
+ --file="premake4.lua" \
+ --outpath="../workspaces/gcc/" \
+ --platform=$(usex amd64 "x64" "x32") \
+ --os=linux \
+ "${myconf[@]}" \
+ gmake || die "Premake failed"
+}
+
+src_compile() {
+ tc-export AR
+
+ # build bundled and patched spidermonkey
+ cd libraries/source/spidermonkey || die
+ JOBS="${MAKEOPTS}" ./build.sh || die
+ cd "${S}" || die
+
+ # build 3rd party fcollada
+ emake -C libraries/source/fcollada/src
+
+ # build 0ad
+ emake -C build/workspaces/gcc verbose=1
+}
+
+src_test() {
+ cd binaries/system || die
+ ./test -libdir "${S}/binaries/system" || die "test phase failed"
+}
+
+src_install() {
+ newbin binaries/system/pyrogenesis 0ad
+ use editor && newbin binaries/system/ActorEditor 0ad-ActorEditor
+
+ insinto /usr/share/${PN}
+ doins -r binaries/data/l10n
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe binaries/system/libCollada.so
+ doexe libraries/source/spidermonkey/lib/*.so
+ use editor && doexe binaries/system/libAtlasUI.so
+
+ dodoc binaries/system/readme.txt
+ doicon -s 128 build/resources/${PN}.png
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/0ad/0ad-0.0.23_alpha.ebuild b/games-strategy/0ad/0ad-0.0.23_alpha.ebuild
new file mode 100644
index 000000000000..0e44c4e36fb1
--- /dev/null
+++ b/games-strategy/0ad/0ad-0.0.23_alpha.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,ssl"
+
+inherit eutils wxwidgets toolchain-funcs gnome2-utils python-any-r1
+
+MY_P=0ad-${PV/_/-}
+DESCRIPTION="A free, real-time strategy game"
+HOMEPAGE="https://play0ad.com/"
+SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="editor +lobby nvtt pch test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/icu:=
+ dev-libs/libsodium
+ dev-libs/libxml2
+ dev-libs/nspr
+ ~games-strategy/0ad-data-${PV}
+ media-libs/libpng:0
+ media-libs/libsdl2[X,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ net-libs/enet:1.3
+ net-libs/miniupnpc:=
+ net-misc/curl
+ sys-libs/zlib
+ virtual/jpeg:0
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
+ lobby? ( >=net-libs/gloox-1.0.20 )
+ nvtt? ( media-gfx/nvidia-texture-tools )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ test? ( dev-lang/perl )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ use editor && setup-wxwidgets
+}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.21_alpha-gentoo.patch
+)
+
+src_configure() {
+ local myconf=(
+ --with-system-nvtt
+ --with-system-miniupnpc
+ --minimal-flags
+ $(usex nvtt "" "--without-nvtt")
+ $(usex pch "" "--without-pch")
+ $(usex test "" "--without-tests")
+ $(usex editor "--atlas" "")
+ $(usex lobby "" "--without-lobby")
+ --collada
+ --bindir="/usr/bin"
+ --libdir="/usr/$(get_libdir)"/${PN}
+ --datadir="/usr/share/${PN}"
+ )
+
+ # stock premake4 does not work, use the shipped one
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+ # regenerate scripts.c so our patch applies
+ cd "${S}"/build/premake/premake4 || die
+ "${S}"/build/premake/premake4/bin/release/premake4 embed || die
+
+ # rebuild premake again... this is the most stupid build system
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+ # run premake to create build scripts
+ cd "${S}"/build/premake || die
+ "${S}"/build/premake/premake4/bin/release/premake4 \
+ --file="premake4.lua" \
+ --outpath="../workspaces/gcc/" \
+ --platform=$(usex amd64 "x64" "x32") \
+ --os=linux \
+ "${myconf[@]}" \
+ gmake || die "Premake failed"
+}
+
+src_compile() {
+ tc-export AR
+
+ # build bundled and patched spidermonkey
+ cd libraries/source/spidermonkey || die
+ JOBS="${MAKEOPTS}" ./build.sh || die
+ cd "${S}" || die
+
+ # build 3rd party fcollada
+ emake -C libraries/source/fcollada/src
+
+ # build 0ad
+ emake -C build/workspaces/gcc verbose=1
+}
+
+src_test() {
+ cd binaries/system || die
+ ./test -libdir "${S}/binaries/system" || die "test phase failed"
+}
+
+src_install() {
+ newbin binaries/system/pyrogenesis 0ad
+ use editor && newbin binaries/system/ActorEditor 0ad-ActorEditor
+
+ insinto /usr/share/${PN}
+ doins -r binaries/data/l10n
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe binaries/system/libCollada.so
+ doexe libraries/source/spidermonkey/lib/*.so
+ use editor && doexe binaries/system/libAtlasUI.so
+
+ dodoc binaries/system/readme.txt
+ doicon -s 128 build/resources/${PN}.png
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
new file mode 100644
index 000000000000..0ec270713ead
--- /dev/null
+++ b/games-strategy/0ad/Manifest
@@ -0,0 +1,6 @@
+AUX 0ad-0.0.21_alpha-gentoo.patch 3905 BLAKE2B 265020af1e1df234d0932c6294e0cda9c0f48bc1b311d6770c8347431c17e5e99c68f4c52cf6e1277ffb2e57431a6c237d2dc4f452e563eb343b06f62ab1eede SHA512 592e9fdff6ef6d88efc9c4a5c856e41240845187cc4a4b3d9d6b5c616eb1f664fdf702b7b0a30cdfeedd6d87ac0fab913df477567b84d42e13d2cf2761cfdec8
+DIST 0ad-0.0.22-alpha-unix-build.tar.xz 29199308 BLAKE2B a9204949e4dd669228b2a0e2c2dc5d2ccd4f18767e32c4f772714c61314ca0fb283d41201cb9f0547588a6dbdc20fd9d7d14ff153bc3087003c27f4ec2f6fef9 SHA512 3f917e77c6cc1d3fb585c98950db6eab3f5895ba3db41a8737f8172c769b5582689b436cab31eeafecce0e9639ee456afc7b78ebb03435b06512eb9fe7393771
+DIST 0ad-0.0.23-alpha-unix-build.tar.xz 31907988 BLAKE2B 567b9e1b5cd653206194e042f4f0859cd4f9afe75d52d3f480a328b76fdcdd746254502fbf284f790b4932c912ff31453bbc8c986c879ad76baa3d2a5db802c9 SHA512 4a1c86b19e0d8ec7d9b8bf75428df0255f95e7f991f419734f9b6ddc288a537405a34c5d7081f1a97475155c49013af85dee5c0265c35c7dbc003b46637a03d7
+EBUILD 0ad-0.0.22_alpha.ebuild 3388 BLAKE2B 527f19ac8a3dd38ee3f2d6005223ea45b76a01739640bae7456427c6687518a7a5fe60dd7cc77a13861c0bfd381e59fad8d81084a6245b84566dffa459035e2f SHA512 c7d221e6ee1c8e68686e82c245ba90878acb9a7fe64b1916fefdbba381e479f98419bbe06b0f4f7d3c8308d515ab0f88c97f5d29a299eadbd0d734511e6c1b34
+EBUILD 0ad-0.0.23_alpha.ebuild 3408 BLAKE2B bb6fbd77a2e9a0b27f086b33bb347ac5c5a8c76277b967359dfd8b4c7b6ea4b3f296aa150bacc3b3dd9a1460e5ebda436ad1429c5c1eaefe826a64403417ac1c SHA512 99db5ad39c1e0fe4ec9762df7c27e5ae12a1234007cd5d6e229110471affa705373015bb6e42e23b1f8ace93c5a3bae4afc204d966c5940f810415cd255186bc
+MISC metadata.xml 668 BLAKE2B 9bfa86da2d6e1631217082f88905d8d8be7a2c91248839b9a0f5da9d0c214552b11f4af861eb04072e4645b47505d83d0b93c1313f7a3857b1006f94a699b3b2 SHA512 7aab21c31587f1cce5b4635ace0fbbb5bcdc2a6d811df68494ac1fb251fbfc75911cfa3a9e1a60c28f684f64a919164c6e3504fd3fbba3b0ec05afe8278ae343
diff --git a/games-strategy/0ad/files/0ad-0.0.21_alpha-gentoo.patch b/games-strategy/0ad/files/0ad-0.0.21_alpha-gentoo.patch
new file mode 100644
index 000000000000..79549d193683
--- /dev/null
+++ b/games-strategy/0ad/files/0ad-0.0.21_alpha-gentoo.patch
@@ -0,0 +1,88 @@
+--- 0ad-0.0.21-alpha/build/premake/premake4/build/gmake.unix/Premake4.make
++++ 0ad-0.0.21-alpha/build/premake/premake4/build/gmake.unix/Premake4.make
+@@ -26,9 +26,9 @@
+ DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+ INCLUDES += -I../../src/host/lua-5.1.4/src
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+- CFLAGS += $(CPPFLAGS) -Wall -Os
+- CXXFLAGS += $(CPPFLAGS) -Wall -Os
+- LDFLAGS += -s -rdynamic
++ CFLAGS += $(CPPFLAGS) -Wall
++ CXXFLAGS += $(CPPFLAGS) -Wall
++ LDFLAGS += -rdynamic
+ LIBS += -lm -ldl
+ RESFLAGS += $(DEFINES) $(INCLUDES)
+ LDDEPS +=
+@@ -48,8 +48,8 @@
+ DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+ INCLUDES += -I../../src/host/lua-5.1.4/src
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+- CFLAGS += $(CPPFLAGS) -Wall -g
+- CXXFLAGS += $(CPPFLAGS) -Wall -g
++ CFLAGS += $(CFLAGS) $(CPPFLAGS) -Wall
++ CXXFLAGS += $(CXXFLAGS) $(CPPFLAGS) -Wall
+ LDFLAGS += -rdynamic
+ LIBS += -lm -ldl
+ RESFLAGS += $(DEFINES) $(INCLUDES)
+--- 0ad-0.0.21-alpha/build/premake/premake4/src/tools/gcc.lua
++++ 0ad-0.0.21-alpha/build/premake/premake4/src/tools/gcc.lua
+@@ -136,8 +136,6 @@
+ if not cfg.flags.Symbols then
+ if cfg.system == "macosx" then
+ table.insert(result, "-Wl,-x")
+- else
+- table.insert(result, "-s")
+ end
+ end
+
+--- 0ad-0.0.21-alpha/libraries/source/fcollada/src/Makefile
++++ 0ad-0.0.21-alpha/libraries/source/fcollada/src/Makefile
+@@ -9,9 +9,9 @@
+
+ CXX ?= g++
+ CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
+-CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
+-CXXFLAGS_RELEASE := -O2 -DNDEBUG -DRETAIL
+-CXXFLAGS_TEST := -O0 -g -D_DEBUG
++CXXFLAGS_DEBUG := -D_DEBUG -DRETAIL
++CXXFLAGS_RELEASE := -DNDEBUG -DRETAIL
++CXXFLAGS_TEST := -D_DEBUG
+ LIBS += `pkg-config libxml-2.0 --libs`
+ INCLUDES += -IFCollada `pkg-config libxml-2.0 --cflags`
+ INCLUDES_TEST := -IFCollada/FColladaTest $(INCLUDES)
+--- 0ad-0.0.21-alpha/libraries/source/spidermonkey/build.sh
++++ 0ad-0.0.21-alpha/libraries/source/spidermonkey/build.sh
+@@ -93,20 +93,8 @@
+ cd js/src
+
+ # Clean up data generated by previous builds that could cause problems
+-rm -rf build-debug
+ rm -rf build-release
+
+-# We want separate debug/release versions of the library, so we have to change
+-# the LIBRARY_NAME for each build.
+-# (We use perl instead of sed so that it works with MozillaBuild on Windows,
+-# which has an ancient sed.)
+-perl -i.bak -pe 's/(SHARED_LIBRARY_NAME\s+=).*/$1 '\''mozjs38-ps-debug'\''/' moz.build
+-mkdir -p build-debug
+-cd build-debug
+-CXXFLAGS="${CXXFLAGS} ${TLCXXFLAGS}" ../configure ${CONF_OPTS} --with-nspr-libs="$NSPR_LIBS" --with-nspr-cflags="$NSPR_INCLUDES" --enable-debug --disable-optimize --enable-js-diagnostics --enable-gczeal
+-${MAKE} ${MAKE_OPTS}
+-cd ..
+-
+ perl -i.bak -pe 's/(SHARED_LIBRARY_NAME\s+=).*/$1 '\''mozjs38-ps-release'\''/' moz.build
+ mkdir -p build-release
+ cd build-release
+@@ -161,12 +149,9 @@
+ mkdir -p ${INCLUDE_DIR_DEBUG}
+ mkdir -p ${INCLUDE_DIR_RELEASE}
+ cp -R -L ${FOLDER}/js/src/build-release/dist/include/* ${INCLUDE_DIR_RELEASE}/
+-cp -R -L ${FOLDER}/js/src/build-debug/dist/include/* ${INCLUDE_DIR_DEBUG}/
+
+ mkdir -p lib/
+-cp -L ${FOLDER}/js/src/build-debug/dist/lib/${LIB_PREFIX}mozjs38-ps-debug${LIB_SRC_SUFFIX} lib/${LIB_PREFIX}mozjs38-ps-debug${LIB_DST_SUFFIX}
+ cp -L ${FOLDER}/js/src/build-release/dist/lib/${LIB_PREFIX}mozjs38-ps-release${LIB_SRC_SUFFIX} lib/${LIB_PREFIX}mozjs38-ps-release${LIB_DST_SUFFIX}
+-cp -L ${FOLDER}/js/src/build-debug/dist/bin/${LIB_PREFIX}mozjs38-ps-debug${DLL_SRC_SUFFIX} ../../../binaries/system/${LIB_PREFIX}mozjs38-ps-debug${DLL_DST_SUFFIX}
+ cp -L ${FOLDER}/js/src/build-release/dist/bin/${LIB_PREFIX}mozjs38-ps-release${DLL_SRC_SUFFIX} ../../../binaries/system/${LIB_PREFIX}mozjs38-ps-release${DLL_DST_SUFFIX}
+
+ # On Windows, also copy debugging symbols files
diff --git a/games-strategy/0ad/metadata.xml b/games-strategy/0ad/metadata.xml
new file mode 100644
index 000000000000..11542ae7c10a
--- /dev/null
+++ b/games-strategy/0ad/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="editor">Include Atlas scenario editor projects</flag>
+ <flag name="lobby">Enable the use of <pkg>net-libs/gloox</pkg>
+ and the multiplayer lobby</flag>
+ <flag name="nvtt">Support for some uncompressed data formats
+ via <pkg>media-gfx/nvidia-texture-tools</pkg>
+ (might be needed for some mods)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">zero-ad</remote-id>
+ </upstream>
+</pkgmetadata>