summaryrefslogtreecommitdiff
path: root/games-sports/xmoto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-sports/xmoto
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-sports/xmoto')
-rw-r--r--games-sports/xmoto/Manifest5
-rw-r--r--games-sports/xmoto/metadata.xml12
-rw-r--r--games-sports/xmoto/xmoto-0.5.11-r2.ebuild96
3 files changed, 113 insertions, 0 deletions
diff --git a/games-sports/xmoto/Manifest b/games-sports/xmoto/Manifest
new file mode 100644
index 000000000000..0f92b75b1172
--- /dev/null
+++ b/games-sports/xmoto/Manifest
@@ -0,0 +1,5 @@
+DIST inksmoto-0.7.0.tar.gz 2628941 BLAKE2B b8469739e6368f7b36b9a5b766522c295de43c001fba00975fb3c761ba6df34bf97e684ddf51aa83a6a41a1b800d64d6d6fe77358cf1244f193d3aad4746c6b5 SHA512 af0ae49ea160a2274f6835abd82ccaa00dc9ff81875b7d4ea29789388c131b519cb77e6da42efeaf51d52b97090c67320af38145204a1d5418781c99cb23a704
+DIST xmoto-0.5.11-src.tar.gz 40785573 BLAKE2B a1c19656ec5b206417ebdf5ac80e134ce7f29258d8a76f47bad4084ce4d2cdaeeecde1cf6cef1254a0832f21c50a49049947c1896681fe2dd8f3531ba22e7627 SHA512 7046745e8f7a045fa2ce1deb3fd75b73b233dc1092f5ecd6dd4e42938f70269a93a3a623a39a1f0520c90643a42dc1ce93c43ad07bf225ff6c50741cc02511f6
+DIST xmoto_0.5.11+dfsg-7.debian.tar.xz 25708 BLAKE2B e4029d9c66b176c6eebbf68c973cb726ef7b2522c6245ce626c7a61c13492f2e599c5a7deff4f2c853bc58d21afb4e53072a0ddc25a4e7bdb8b89b93fd44159a SHA512 d430fa37fdde90ac68e8ff4b7d2707ea5fc73fa8fab241f7a97b27e803a88321f0ea01b094a5f77ac7e43b2202113842b4f69a745e9212eead7ce4a0a5cd220c
+EBUILD xmoto-0.5.11-r2.ebuild 2539 BLAKE2B 2934f3ebb257ef84288d5dd6393c17bf7129b19bdb24302d545208f269e91977febe06ae14d22d3e9a154a80efa67d5442aca6741d1a121a528c1fa425a40414 SHA512 369d36e52803e3a2566710ec863e11cb02c1c8c254300d07690fee90a3deeab89185023ff450b2b2f43f28b805c7200cce356d74017d29ee3e19264ab5dfe70d
+MISC metadata.xml 460 BLAKE2B 785042b620610aec6eebea61013723069e30dc1fd29cd64a74a59c721c55d6590131fd2c99094768b36917bded227c63f7560518e40367e0b295bb4c563956db SHA512 fa39571c69e439d293450292417de087a4f7da52a291b0d105e6c08af0c380b5d0bce20ac29851f837716d92152e77155c41fae58c38d31b941b0700ad0df2f8
diff --git a/games-sports/xmoto/metadata.xml b/games-sports/xmoto/metadata.xml
new file mode 100644
index 000000000000..5b72e0102ede
--- /dev/null
+++ b/games-sports/xmoto/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="double-precision">more precise calculations at the expense of speed</flag>
+ <flag name="editor">Depend on inkscape, scripts to convert svg to level (svg2lvl)</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-sports/xmoto/xmoto-0.5.11-r2.ebuild b/games-sports/xmoto/xmoto-0.5.11-r2.ebuild
new file mode 100644
index 000000000000..4b906f8726a4
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.5.11-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+LVL_PV="0.7.0" #they unfortunately don't release both at the same time, why ~ as separator :(
+LVL="inksmoto-${LVL_PV}"
+DEB_PV=7
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/xmoto/xmoto/${PV}/${P}-src.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV}+dfsg-${DEB_PV}.debian.tar.xz
+ editor? ( http://download.tuxfamily.org/xmoto/svg2lvl/${LVL_PV}/${LVL}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="double-precision editor nls"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ dev-games/ode[double-precision=]
+ dev-lang/lua:0[deprecated]
+ dev-libs/libxdg-basedir
+ dev-libs/libxml2
+ media-fonts/dejavu
+ media-libs/libpng:0
+ media-libs/libsdl[joystick,opengl]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ net-misc/curl
+ virtual/jpeg:0
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+RDEPEND="${RDEPEND}
+ editor? ( media-gfx/inkscape )"
+
+src_prepare() {
+ default
+
+ EPATCH_SOURCE="${WORKDIR}/debian/patches" \
+ epatch $(cat ${WORKDIR}/debian/patches/series)
+ use editor && rm -vf "${WORKDIR}"/extensions/{bezmisc,inkex}.py
+ sed -i \
+ -e '/^gettextsrcdir/s:=.*:= @localedir@/gettext/po:' \
+ po/Makefile.in.in || die
+ mv configure.{in,ac} || die
+ eautoreconf
+
+ rm -r "${S}"/src/ode || die
+}
+
+src_configure() {
+ # bug 653404
+ # due to ICU 59 requiring C++11 now
+ append-cxxflags -std=c++11
+
+ econf \
+ --enable-threads=posix \
+ $(use_enable nls) \
+ --localedir=/usr/share/locale \
+ --with-localesdir=/usr/share/locale \
+ --with-renderer-sdlGfx=0 \
+ --with-renderer-openGl=1
+}
+
+src_install() {
+ default
+
+ rm -f "${D}/usr/share/xmoto"/Textures/Fonts/DejaVu*.ttf
+ dosym ../../../fonts/dejavu/DejaVuSans.ttf /usr/share/xmoto/Textures/Fonts/DejaVuSans.ttf
+ dosym ../../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/xmoto/Textures/Fonts/DejaVuSansMono.ttf
+ doicon extra/xmoto.xpm
+ make_desktop_entry xmoto Xmoto
+
+ if use editor; then
+ insinto /usr/share/inkscape/
+ doins -r "${WORKDIR}"/extensions/
+ fi
+}
+
+pkg_postinst() {
+ if use editor; then
+ elog "If you want to know how to create Xmoto levels"
+ elog "have a look at this Tutorial:"
+ elog " http://wiki.xmoto.tuxfamily.org/index.php?title=Inksmoto-${LVL_PV}"
+ elog "You can share your levels on the Xmoto homepage."
+ fi
+}