summaryrefslogtreecommitdiff
path: root/games-sports/torcs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-sports/torcs/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-sports/torcs/files')
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-as-needed.patch96
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-flags.patch14
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-format.patch34
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-gcc6.patch11
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-gcc7.patch11
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-no-automake.patch21
-rw-r--r--games-sports/torcs/files/torcs-1.3.6-noXmuXt.patch15
7 files changed, 202 insertions, 0 deletions
diff --git a/games-sports/torcs/files/torcs-1.3.6-as-needed.patch b/games-sports/torcs/files/torcs-1.3.6-as-needed.patch
new file mode 100644
index 000000000000..d848538c07ea
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-as-needed.patch
@@ -0,0 +1,96 @@
+--- torcs-1.3.6.orig/Make-default.mk
++++ torcs-1.3.6/Make-default.mk
+@@ -402,7 +402,7 @@
+ ifdef PROGRAM
+
+ ${PROGRAM}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${SOLIBS} ${EXT_LIBS} -o $@
++ ${CXX} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installprogram: ${PROGRAM}
+ @ createdir="${INSTLIBBASE}" ; \
+@@ -420,14 +420,14 @@
+ ifdef LOCALTOOLS
+
+ ${LOCALTOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ endif
+
+ ifdef TOOLS
+
+ ${TOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installtools: ${TOOLS}
+ @createdir="${INSTBINBASE}/${TOOLSDIR}" ; \
+@@ -478,7 +478,7 @@
+ ifdef SOLIBRARY
+
+ ${SOLIBRARY}: ${OBJECTS}
+- ${CXX} -shared -o ${SOLIBRARY} ${OBJECTS} ${SOLIBS} ${LDFLAGS} ${LIBSPATH} ${LIBS} ${DEBUG_LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${SOLIBRARY} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/lib" ; \
+ $(mkinstalldirs) $$createdir ; \
+@@ -509,7 +509,7 @@
+ ifdef MODULE
+
+ ${MODULE}: ${OBJECTS}
+- ${CXX} -shared -o ${MODULE} ${OBJECTS} ${LDFLAGS} ${LIBSPATH} ${LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${MODULE} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/${MODULEDIR}" ; \
+ $(mkinstalldirs) $$createdir ; \
+--- torcs-1.3.6.orig/configure.in
++++ torcs-1.3.6/configure.in
+@@ -123,11 +123,11 @@
+ AC_CHECK_LIB(Xxf86vm, XF86VidModeSetViewPort,,AC_MSG_ERROR([Can't find libXxf86vm. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrender, XRenderSetSubpixelOrder,,AC_MSG_ERROR([Can't find libXrender. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrandr, XRRQueryVersion,,AC_MSG_ERROR([Can't find libXrandr. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+-AC_CHECK_LIB(openal, alEnable, LDFLAGS="$LDFLAGS -lopenal", AC_MSG_ERROR([Can't find AL/al.h. OpenAL can be found on http://www.openal.org/]))
++AC_CHECK_LIB(openal, alEnable, LIBS="$LIBS -lopenal", AC_MSG_ERROR([Can't find AL/al.h. OpenAL can be found on http://www.openal.org/]))
+ AC_CHECK_LIB(alut, alutLoadWAVFile,
+- LDFLAGS="$LDFLAGS -lalut",
+- LDFLAGS="$LDFLAGS")
+-AC_CHECK_LIB(vorbisfile, ov_fopen, LDFLAGS="$LDFLAGS -lvorbisfile", AC_MSG_ERROR([Can't find libvorbis.]))
++ LIBS="$LIBS -lalut", )
++AC_CHECK_LIB(vorbisfile, ov_fopen, LIBS="$LIBS -lvorbisfile", AC_MSG_ERROR([Can't find libvorbis.]))
++
+
+ AC_CHECK_LIB(dl, dlopen)
+ AC_CHECK_FUNC(dlopen,,AC_MSG_ERROR([Can't find dlopen function. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+--- torcs-1.3.6.orig/src/libs/Makefile
++++ torcs-1.3.6/src/libs/Makefile
+@@ -23,7 +23,7 @@
+
+ TOOLSUBDIRS = txml
+
+-SUBDIRS = confscreens racescreens robottools txml tgf tgfclient client raceengineclient learning \
++SUBDIRS = confscreens racescreens robottools txml tgf tgfclient raceengineclient client learning \
+ portability math musicplayer
+
+ PKGSUBDIRS = $(SUBDIRS)
+--- torcs-1.3.6.orig/src/libs/client/Makefile
++++ torcs-1.3.6/src/libs/client/Makefile
+@@ -23,6 +23,8 @@
+ SOURCES = entry.cpp mainmenu.cpp splash.cpp exitmenu.cpp \
+ optionmenu.cpp
+
++SOLIBS = -lconfscreens -lraceengine
++
+ LIBS = -lplibssg -lplibsg -lplibul
+
+ EXPDIR = include
+--- torcs-1.3.6.orig/src/libs/tgf/Makefile
++++ torcs-1.3.6/src/libs/tgf/Makefile
+@@ -29,6 +29,7 @@
+ profiler.cpp \
+ hash.cpp
+
++SOLIBS = -ltxml
+
+ EXPDIR = include
+
diff --git a/games-sports/torcs/files/torcs-1.3.6-flags.patch b/games-sports/torcs/files/torcs-1.3.6-flags.patch
new file mode 100644
index 000000000000..5f11fd270ef1
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-flags.patch
@@ -0,0 +1,14 @@
+respect cflags
+
+--- torcs-1.3.6/configure.in
++++ torcs-1.3.6/configure.in
+@@ -50,8 +50,7 @@
+ ADDCFLAGS="-Wall -fPIC -fno-strict-aliasing"
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug set the debug mode],
+- ADDCFLAGS="$ADDCFLAGS -g -DDEBUG -DDEBUG_OUT",
+- ADDCFLAGS="$ADDCFLAGS -O2")
++ ADDCFLAGS="$ADDCFLAGS -g -DDEBUG -DDEBUG_OUT")
+
+ AC_ARG_ENABLE(xrandr,
+ [ --disable-xrandr reset the XRANDR mode],
diff --git a/games-sports/torcs/files/torcs-1.3.6-format.patch b/games-sports/torcs/files/torcs-1.3.6-format.patch
new file mode 100644
index 000000000000..da59c4da4fa0
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-format.patch
@@ -0,0 +1,34 @@
+--- a/src/tools/texmapper/maintexmapper.cpp 2015-12-23 20:55:24.874102363 +0100
++++ b/src/tools/texmapper/maintexmapper.cpp 2015-12-23 20:55:55.071553325 +0100
+@@ -103,7 +103,7 @@
+ {
+ int i, j;
+
+- printf(title);
++ printf("%s", title);
+ for (j = 0; j < 4; j ++){
+ for (i = 0; i < 4; i ++) {
+ printf("%.6f ", m[i][j]);
+--- a/src/tools/trackgen/objects.cpp 2015-12-23 20:59:49.671287196 +0100
++++ b/src/tools/trackgen/objects.cpp 2015-12-23 21:02:21.639523189 +0100
+@@ -234,9 +234,9 @@
+
+ ssgLeaf *vt = (ssgLeaf *)ent;
+ if (vt->getCullFace() == TRUE) {
+- surf = "SURF 0x10\n";
++ surf = "0x10";
+ } else {
+- surf = "SURF 0x30\n";
++ surf = "0x30";
+ }
+
+ int num_verts = vt->getNumVertices();
+@@ -304,7 +304,7 @@
+ fprintf (save_fd, "numsurf %d\n", num_tris);
+
+ for (i = 0; i < num_tris; i++) {
+- fprintf (save_fd, surf);
++ fprintf (save_fd, "SURF %s\n", surf);
+ fprintf (save_fd, "mat 0\n");
+ fprintf (save_fd, "refs 3\n");
+ fprintf (save_fd, "%d %g %g\n",
diff --git a/games-sports/torcs/files/torcs-1.3.6-gcc6.patch b/games-sports/torcs/files/torcs-1.3.6-gcc6.patch
new file mode 100644
index 000000000000..6daf22a81b11
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-gcc6.patch
@@ -0,0 +1,11 @@
+--- a/src/drivers/olethros/geometry.cpp
++++ b/src/drivers/olethros/geometry.cpp
+@@ -27,6 +27,8 @@
+ #ifdef WIN32
+ #include <float.h>
+ #define isnan _isnan
++#elif __cplusplus >= 201103L
++using std::isnan;
+ #endif
+
+
diff --git a/games-sports/torcs/files/torcs-1.3.6-gcc7.patch b/games-sports/torcs/files/torcs-1.3.6-gcc7.patch
new file mode 100644
index 000000000000..af139ad509de
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-gcc7.patch
@@ -0,0 +1,11 @@
+--- a/src/libs/musicplayer/OpenALMusicPlayer.cpp
++++ b/src/libs/musicplayer/OpenALMusicPlayer.cpp
+@@ -161,7 +161,7 @@
+ {
+ char pcm[BUFFERSIZE];
+ int size = 0;
+- const char* error = '\0';
++ const char* error = "";
+
+ if (!stream->read(pcm, BUFFERSIZE, &size, &error)) {
+ GfError("OpenALMusicPlayer: Stream read error: %s\n", error);
diff --git a/games-sports/torcs/files/torcs-1.3.6-no-automake.patch b/games-sports/torcs/files/torcs-1.3.6-no-automake.patch
new file mode 100644
index 000000000000..9b47bfb9a64c
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-no-automake.patch
@@ -0,0 +1,21 @@
+torcs doesn't use automake, so it shouldn't be calling the macro
+
+http://bugs.gentoo.org/408473
+
+--- torcs-1.3.6.orig/configure.in
++++ torcs-1.3.6/configure.in
+@@ -15,9 +15,12 @@
+ #
+ ##############################################################################
+
+-AC_INIT(Make-config.in)
++AC_INIT(torcs, 1.3.6)
+ AC_CONFIG_HEADERS(config.h)
+-AM_INIT_AUTOMAKE(torcs, 1.3.6)
++dnl Workaround code using old VERSION instead of new PACKAGE_VERSION
++VERSION=$PACKAGE_VERSION
++AC_DEFINE_UNQUOTED([VERSION], "$VERSION", [old VERSION workaround])
++AC_SUBST(VERSION)
+
+ dnl Checks for programs.
+ AC_PROG_CC
diff --git a/games-sports/torcs/files/torcs-1.3.6-noXmuXt.patch b/games-sports/torcs/files/torcs-1.3.6-noXmuXt.patch
new file mode 100644
index 000000000000..f87fb750d199
--- /dev/null
+++ b/games-sports/torcs/files/torcs-1.3.6-noXmuXt.patch
@@ -0,0 +1,15 @@
+--- a/configure.in
++++ b/configure.in
+@@ -116,12 +116,8 @@
+ AC_CHECK_LIB(ICE, IceSetIOErrorHandler,,AC_MSG_ERROR([Can't find libICE. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ dnl Replace `main' with a function in -lSM:
+ AC_CHECK_LIB(SM, SmsSetErrorHandler,,AC_MSG_ERROR([Can't find libSM. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+-dnl Replace `main' with a function in -lXt:
+-AC_CHECK_LIB(Xt, XtDisplay,,AC_MSG_ERROR([Can't find libXt. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ dnl Replace `main' with a function in -lXi:
+ AC_CHECK_LIB(Xi, XOpenDevice,,AC_MSG_ERROR([Can't find libXi. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+-dnl Replace `main' with a function in -lXmu:
+-AC_CHECK_LIB(Xmu, XmuSimpleErrorHandler,,AC_MSG_ERROR([Can't find libXmu. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xxf86vm, XF86VidModeSetViewPort,,AC_MSG_ERROR([Can't find libXxf86vm. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrender, XRenderSetSubpixelOrder,,AC_MSG_ERROR([Can't find libXrender. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))
+ AC_CHECK_LIB(Xrandr, XRRQueryVersion,,AC_MSG_ERROR([Can't find libXrandr. Please check config.log and if you can't solve the problem send the file to torcs-users@lists.sourceforge.net with the subject \"torcs compilation problem\"]))