summaryrefslogtreecommitdiff
path: root/games-sports/ski/ski-6.9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-sports/ski/ski-6.9-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-sports/ski/ski-6.9-r1.ebuild')
-rw-r--r--games-sports/ski/ski-6.9-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-sports/ski/ski-6.9-r1.ebuild b/games-sports/ski/ski-6.9-r1.ebuild
new file mode 100644
index 000000000000..e817d5cc3607
--- /dev/null
+++ b/games-sports/ski/ski-6.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="A simple text-mode skiing game"
+HOMEPAGE="http://www.catb.org/~esr/ski/"
+SRC_URI="http://www.catb.org/~esr/ski/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ski
+ dodoc NEWS README
+ doman ski.6
+ domenu ski.desktop
+ doicon ski.png
+ python_fix_shebang "${ED}/usr/bin"
+}