summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /games-simulation
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/Manifest.gzbin3235 -> 3404 bytes
-rw-r--r--games-simulation/train-valley/Manifest3
-rw-r--r--games-simulation/train-valley/metadata.xml11
-rw-r--r--games-simulation/train-valley/train-valley-1.3.31403.ebuild61
4 files changed, 75 insertions, 0 deletions
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index 1e6a1245edeb..46ea90dc4cc2 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ
diff --git a/games-simulation/train-valley/Manifest b/games-simulation/train-valley/Manifest
new file mode 100644
index 000000000000..c62f3904951d
--- /dev/null
+++ b/games-simulation/train-valley/Manifest
@@ -0,0 +1,3 @@
+DIST train_valley_1_3_31403.sh 196066169 BLAKE2B fe9e6ae5b0ef76794823dc86ed100fdac355d3929d85a9a12096f79cf9e6f946e2c85b5b737ebcab813ceef29094734f74546fff06124fe4bf07ef224d5842ff SHA512 16fd627f8ca6399579b17d7a4ce29caba554fbfb0dc72b40827f1c3a061d8c238a7faeb1b5171917362d381642e8cb066cdad5556fb71f4d27225bf227d735cd
+EBUILD train-valley-1.3.31403.ebuild 1334 BLAKE2B 65f41fa2f8576858de21554fec9160bbed27ebe5ed1c73953b170721602f5ca890ad22f14e848809f44a0fbb82e281319698b4842ec9b57e6743e6985a783a2c SHA512 55c3acd1498800f3e78e78e220a3328eb93c1b0c48d60e5ab38e7128f1f7906d5277b970ac16e7e2e5919b0bff711acccb8b299a1d2c0f95ec66b5933a2c5676
+MISC metadata.xml 354 BLAKE2B 620415356736dd403be27ef2547bd0d23a3812b3c16b7976125c582118af837336c258d7c0657dbe70b254ee773041f7e169939a34cc616870a5f54ad8429c31 SHA512 6ae66494681059ab163da720d574906da7db8facc7c383db8b8dd0d5ea78f41deb5f19389b1fd8fc2848cfb7ae5c11bd3ba2750a90799b382f0bfe8f70d48637
diff --git a/games-simulation/train-valley/metadata.xml b/games-simulation/train-valley/metadata.xml
new file mode 100644
index 000000000000..1dbebd848c81
--- /dev/null
+++ b/games-simulation/train-valley/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="gui">Install the GUI for configuring screen resolution and input</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-simulation/train-valley/train-valley-1.3.31403.ebuild b/games-simulation/train-valley/train-valley-1.3.31403.ebuild
new file mode 100644
index 000000000000..eeda5d017b72
--- /dev/null
+++ b/games-simulation/train-valley/train-valley-1.3.31403.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop unpacker xdg-utils
+
+DESCRIPTION="Build railroads in order to connect cities, tunnels, and bridges"
+HOMEPAGE="http://train-valley.com/tv1.html"
+SRC_URI="${P//[-.]/_}.sh"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+gui"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXrandr
+ gui? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+"
+
+S="${WORKDIR}/data/noarch/game"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.gog.com/game/${PN//-/_}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe ${PN}.$(usex amd64 x86_64 x86) ${PN}
+ make_wrapper ${PN} "${DIR}"/${PN}
+
+ insinto "${DIR}"
+ doins -r ${PN}_Data/
+ rm -r "${ED}/${DIR}"/${PN}_Data/*/$(usex amd64 x86 x86_64) || die
+
+ if ! use gui; then
+ rm "${ED}/${DIR}"/${PN}_Data/Plugins/*/ScreenSelector.so || die
+ fi
+
+ newicon -s 128 ${PN}_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN} "Train Valley"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }