summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /games-simulation
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/Manifest.gzbin3936 -> 3937 bytes
-rw-r--r--games-simulation/openttd/Manifest2
-rw-r--r--games-simulation/openttd/openttd-13.0.ebuild131
3 files changed, 133 insertions, 0 deletions
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index 2dbc1b31ebbc..e3baea169efa 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index 8ac7b71b733a..6d0e0c82b744 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -2,5 +2,7 @@ AUX openttd-1.11.2_dont_compress_man.patch 999 BLAKE2B 5a2e9d91cb0f60723ef198723
AUX openttd.confd-r1 376 BLAKE2B 9208c9da8c90d74d36204c2c78f14b28fa3bf5ec730e2f56b6ae163b474b2169b003fb4d869810a2404cc0ad2e0e5bf9c78417057a762e965787b955431db629 SHA512 a3ca192781b0bf4a1105f13890bc34b3d68a365637adb2254b7b048fa5a1fde80b95415711010b8144135465c2a9cd1a8822cc3bbd2e0161a728c16acb1d0509
AUX openttd.initd-r3 1052 BLAKE2B b4f57691ef749e8aae4be2fb3cf1826b00fa609afbd1f0d863fb6177fe70e4b6254831ea5c89aa74bac9e2dfddf050656dc43790a412870add8baefeb57d9500 SHA512 5064fb633aea2d2720f189a3a5a9f07541394d7760274465bd9837ec4a04009597b984821424f234941972958754db33bc5cc174b7b075c8915fb2231dd3e6f8
DIST openttd-12.2-source.tar.xz 7377496 BLAKE2B a2c0192a2d4ed149f7c6584032b46483eb74d2d7d2ced16f1d0d3e638c4acef184cd8b013b855a01750dbb570d37bb6ed95f04d16c1580e4b3777ea3b90cfee1 SHA512 577792faee1d5e0c19fbfe31501dab3359f8e1327caa87e6378bb3e616ab6b2c64d02044c6ac99f7c40397df7bc6847a6b432852a5318a2db574203ddebfaef6
+DIST openttd-13.0-source.tar.xz 7422316 BLAKE2B 8aa384847681a61c74e1d56c86600fe7ba273d4721bf2b290dcbdced830e7b6872ae458d02d986877c92d5027bbfe8e9eccbcc74b791b3e9332c142fbc078953 SHA512 a2436eb8aae6967e1e3bcf5f67c2346a8f80af723509d668157e785424c2245086b10077783857acf8840068a37a0e9094f04fda36887ef7e799f360075a8e8a
EBUILD openttd-12.2-r1.ebuild 3377 BLAKE2B 9868c0b4cdc818b63cdf4e4fc89ce706287fc5537346006ccaca2d094a5ced579b9a880fbed8b8ef92a5ea02e1ec545767054eee7a3d1a7a7abeaa5c020be12b SHA512 1706e2ad60bd31d70e1a553025048acb34ff638679959c779c660b7c26a97ee83c6f05576cf474aefc4961c572f3e161a5544d63f00cdd4996b7cf85b229e799
+EBUILD openttd-13.0.ebuild 3667 BLAKE2B 0614a19402473bff873779d828df265be0a017a7b97ea34c1c80e9f7071a7351c781356581c3d68e2150820d4c2301ff4a2a5e058cf06a25e86e68c3bcf64299 SHA512 5e3f315c26d01f4c0034a102de0476899bcd7895e91ab6605ef060c2165d4021ab397be9bde27f68a4396bfa3dda9cee2598707a0b9a863a56955784c1067b76
MISC metadata.xml 857 BLAKE2B e65bf683a6d5beb3c99ae8d83771e5312e00cf40dbbd2dbf9545d7f7134b5df25d58057f23f5afd101a9f2e13396c57bfda59b427896455205ed6e272574f643 SHA512 fa13b5059202687ded428b6670b6a84f1187e767da4a51ef4fca435e8b0c10f900cc60ba7207d690888e442cbc27b03f8ea142e93138fa1b4da4411c13d1b6bf
diff --git a/games-simulation/openttd/openttd-13.0.ebuild b/games-simulation/openttd/openttd-13.0.ebuild
new file mode 100644
index 000000000000..abf0f06f0a0e
--- /dev/null
+++ b/games-simulation/openttd/openttd-13.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="A clone of Transport Tycoon Deluxe"
+HOMEPAGE="https://www.openttd.org/"
+SRC_URI="https://cdn.openttd.org/openttd-releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="allegro cpu_flags_x86_sse debug dedicated +fluidsynth icu +lzma lzo +openmedia +png +sdl timidity +truetype +zlib"
+REQUIRED_USE="!dedicated? ( || ( allegro sdl ) )"
+
+RDEPEND="
+ dedicated? (
+ acct-group/openttd
+ acct-user/openttd
+ app-misc/dtach
+ )
+ !dedicated? (
+ allegro? ( media-libs/allegro:5 )
+ fluidsynth? ( media-sound/fluidsynth )
+ icu? (
+ dev-libs/icu-layoutex:=
+ dev-libs/icu-le-hb
+ >=dev-libs/icu-58.1:=
+ )
+ sdl? ( media-libs/libsdl2[sound,video] )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ sys-libs/zlib:=
+ )
+ )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo:2 )
+ png? ( media-libs/libpng:= )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=games-util/grfcodec-6.0.6_p20210310
+ virtual/pkgconfig
+"
+PDEPEND="
+ !dedicated? (
+ openmedia? (
+ >=games-misc/openmsx-0.4.0
+ >=games-misc/opensfx-1.0.1
+ )
+ )
+ openmedia? ( >=games-misc/opengfx-0.6.1 )
+ timidity? ( media-sound/timidity++ )
+"
+
+DOCS=( docs/directory_structure.md )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.11.2_dont_compress_man.patch"
+)
+
+src_prepare() {
+ # Drop automagic LTO usage
+ sed -i -e '/check_ipo_supported(RESULT IPO_FOUND)/d' CMakeLists.txt || die
+
+ # Don't force _FORTIFY_SOURCE via CMake
+ # (we already set it in the toolchain by default with a minimum level
+ # of _FORTIFY_SOURCE=2)
+ sed -i -e '/-D_FORTIFY_SOURCE/d' cmake/CompileFlags.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_BINDIR=bin
+ -DCMAKE_INSTALL_DATADIR=share
+ -DOPTION_DEDICATED=$(usex dedicated)
+ -DOPTION_USE_ASSERTS=$(usex debug)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Allegro=$(usex !allegro)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Freetype=$(usex !truetype)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Fontconfig=$(usex !truetype)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Fluidsynth=$(usex !fluidsynth)
+ -DCMAKE_DISABLE_FIND_PACKAGE_ICU=$(usex !icu)
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibLZMA=$(usex !lzma)
+ -DCMAKE_DISABLE_FIND_PACKAGE_LZO=$(usex !lzo)
+ -DCMAKE_DISABLE_FIND_PACKAGE_PNG=$(usex !png)
+ # N.B. regarding #807364 and #828984: CMAKE_DISABLE_FIND_PACKAGE_SDL is used only
+ # with USE="allegro -sdl" combination flags. There no other way to
+ # completely disable SDL1 support.
+ -DCMAKE_DISABLE_FIND_PACKAGE_SDL=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_SDL2=$(usex !sdl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_SSE=$(usex !cpu_flags_x86_sse)
+ -DCMAKE_DISABLE_FIND_PACKAGE_ZLIB=$(usex !zlib)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use dedicated ; then
+ newconfd "${FILESDIR}"/openttd.confd-r1 openttd
+ newinitd "${FILESDIR}"/openttd.initd-r3 openttd
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if ! use openmedia ; then
+ elog
+ elog "OpenTTD was compiled without the 'openmedia' USE flag."
+ elog
+ elog "In order to play, you must at least install"
+ elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
+ elog "following 6 files from a version of Transport Tycoon Deluxe"
+ elog "(Windows or DOS) to shared or personal location."
+ elog "See ${EROOT}/usr/share/doc/${PF}/directory_structure.md for more info."
+ elog
+ elog "From the Windows version you need: "
+ elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ elog "OR from the DOS version you need: "
+ elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+ fi
+}