summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /games-simulation
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/Manifest.gzbin3580 -> 3750 bytes
-rw-r--r--games-simulation/sky-rogue/Manifest3
-rw-r--r--games-simulation/sky-rogue/metadata.xml8
-rw-r--r--games-simulation/sky-rogue/sky-rogue-1.3.ebuild51
4 files changed, 62 insertions, 0 deletions
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index d6ac02b296cd..bf4f85b65250 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ
diff --git a/games-simulation/sky-rogue/Manifest b/games-simulation/sky-rogue/Manifest
new file mode 100644
index 000000000000..013be070755e
--- /dev/null
+++ b/games-simulation/sky-rogue/Manifest
@@ -0,0 +1,3 @@
+DIST sky-rogue-linux.zip 153094990 BLAKE2B 2129f624a7b56ec0ddbf6869a75f94468d4efe9efade4d47549b2ae1eebfb4b6e4939190d97acd820c2f46a1a9b2d52614e5a1c7ace717071d482db21b1bd1e1 SHA512 f25dfed7d78355fdbd5a643ec11f948020256fce38e80f9bb8084b875203b26490af6b0164684c187493697a132c7fdc9b40af6b793fd50c9a176285c508d8df
+EBUILD sky-rogue-1.3.ebuild 1162 BLAKE2B 006b02940ce404a8b80f917e2fa535769628156564bfa4c00cfbdb808833045e8b50eb377122581c02baff0716e739dc97ddf6592f4dd1c864d821132da77e82 SHA512 50f17aa1d2fe604f71a02813eb0b43d30a007042181e964419e4087deca9feaa08b000f74794caf80f904c7e03bda01ad67540dfa88b9c570f1bea87ba36f9e0
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/games-simulation/sky-rogue/metadata.xml b/games-simulation/sky-rogue/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-simulation/sky-rogue/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-simulation/sky-rogue/sky-rogue-1.3.ebuild b/games-simulation/sky-rogue/sky-rogue-1.3.ebuild
new file mode 100644
index 000000000000..d5ad8217583b
--- /dev/null
+++ b/games-simulation/sky-rogue/sky-rogue-1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg
+
+MY_PN="${PN//-}"
+DESCRIPTION="A fwooshy rogue-lite action flight simulator"
+HOMEPAGE="https://skyroguegame.com/"
+SRC_URI="${PN}-linux.zip"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/opengl
+"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+S="${WORKDIR}"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://fractal-phase.itch.io/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe ${MY_PN}.$(usex amd64 x86_64 x86) ${MY_PN}
+ make_wrapper ${PN} "${DIR}"/${MY_PN}
+
+ insinto "${DIR}"
+ doins -r ${MY_PN}_Data/
+ rm -r "${ED}/${DIR}"/${MY_PN}_Data/*/$(usex amd64 x86 x86_64) || die
+
+ # Some Unity games have a GUI launcher but this one doesn't use it.
+ rm "${ED}/${DIR}"/${MY_PN}_Data/Plugins/*/ScreenSelector.so || die
+
+ newicon -s 128 ${MY_PN}_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN} "Sky Rogue"
+}