summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 07:14:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 07:14:19 +0000
commit66520d3148e31806a52cf7df5b8d91d5cd431670 (patch)
tree15d0c80d9ee1b1e2a454a9930a03e3d3b7c6cc61 /games-simulation
parent0e82736d0df44565875b055019ded1be0ac5c319 (diff)
gentoo auto-resync : 17:01:2023 - 07:14:19
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/Manifest.gzbin3931 -> 3931 bytes
-rw-r--r--games-simulation/singularity/Manifest2
-rw-r--r--games-simulation/singularity/singularity-1.00-r2.ebuild (renamed from games-simulation/singularity/singularity-1.00-r1.ebuild)14
3 files changed, 10 insertions, 6 deletions
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index 8c7af8f04994..ce6df214e3dd 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ
diff --git a/games-simulation/singularity/Manifest b/games-simulation/singularity/Manifest
index 4ccd974aaf7a..8d761e008901 100644
--- a/games-simulation/singularity/Manifest
+++ b/games-simulation/singularity/Manifest
@@ -1,4 +1,4 @@
DIST endgame-singularity-music-007.zip 51774799 BLAKE2B 78595b16e422d2312be860686aca9401f6f1eed35fe40dbbc3a3999b1feb5e32aa6d51a66d94c9241aca2b6606bb7135491298b94c8033a1437c2cd7b23f9120 SHA512 ab46e77c833085f0c5b1b46fef72ab807e79ca422ad043ef67a4bf4384cb0177319f21b4bd01496e6c3fc6fe9a2f36ec256e19f0e829ad7bf9f0c5bd38bf0fe5
DIST singularity-1.00.tar.gz 1944972 BLAKE2B 1ca2b120311a19f175014835930610583e8f605dbda3ca3ca96d7e0da86bddeb4b0a264f50a003aa51e05b86ce971255ffda5f498598dde6be370b9a953eb1d0 SHA512 f3581048c5a535fdbd28d2af1ac596f5396fd712b716931f17de75f8b170f0e226deb2c113023357e21e7de1294e4a632515962df9ee43768baf0fb4bbaa08da
-EBUILD singularity-1.00-r1.ebuild 1278 BLAKE2B b6126734ae48583db4020345644e24aec6d3ca1ad6a1eef0393b7e6e488bc1d861d609ea20987b6667dc1378d9b5290cc4da062475f2190a804ca9ff3d9c4031 SHA512 877e42e4759d08b78e626321aab23583af7ab7545c4db7b63d56d9e342607fb678652c6cb2a10179e2fd56d6a61ee5a43821993a3d2fad01b1fee4f620180636
+EBUILD singularity-1.00-r2.ebuild 1343 BLAKE2B c9dc70e173aeae9249c702a76dd10e7d555ff5bde57d2f2f3641c87b4ec224fa6b180d1d347b4814ed65610368fce77ad4d65ac9b32644696144ad99ef30373f SHA512 507a019ebad53d6b81f1085e3c84bcd344c1f640cea2726b91551928af0d20e61edf22abdbbb86a4cfd5e2d99db73a870f9b9e8707e97348bc5fcbb7b608dc30
MISC metadata.xml 342 BLAKE2B d77c98787a52fc093da68df48ae20c3879730d87a7aaf32dd92a0feebbbe8992654c44b9935801fe2febbc9c0513065d2092993da1b7342ff7e1cdd2fb543d27 SHA512 0fc614003a37a2ef3986056f9f3587dc9d97a6d6af9bc4708489d9ec2260cd023d03c1d9e777879d9ff65574aab0d1c6c305a76ab743131d802f99f614b02e77
diff --git a/games-simulation/singularity/singularity-1.00-r1.ebuild b/games-simulation/singularity/singularity-1.00-r2.ebuild
index d1dcbba13215..faf2e9b246f6 100644
--- a/games-simulation/singularity/singularity-1.00-r1.ebuild
+++ b/games-simulation/singularity/singularity-1.00-r2.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit desktop distutils-r1
SINGULARITY_MUSIC="endgame-${PN}-music-007"
@@ -35,12 +36,15 @@ BDEPEND="app-arch/unzip"
distutils_enable_sphinx docs
distutils_enable_tests pytest
-src_install() {
- local DOCS=( AUTHORS.txt Changelog.txt README.txt TODO )
- distutils-r1_src_install
+python_install() {
+ distutils-r1_python_install
python_moduleinto ${PN}/music
- python_domodule ../${SINGULARITY_MUSIC}/.
+ python_domodule "${WORKDIR}"/${SINGULARITY_MUSIC}/.
+}
+
+python_install_all() {
+ dodoc AUTHORS.txt Changelog.txt README.txt TODO
newicon ${PN}/data/themes/default/images/icon.png ${PN}.png
domenu ${PN}.desktop