summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /games-simulation
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/Manifest.gzbin3064 -> 3233 bytes
-rw-r--r--games-simulation/corsix-th/Manifest3
-rw-r--r--games-simulation/corsix-th/corsix-th-0.62.ebuild56
-rw-r--r--games-simulation/corsix-th/metadata.xml20
4 files changed, 79 insertions, 0 deletions
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index 2a15556c3c9c..89a1581c0c05 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
new file mode 100644
index 000000000000..9cbf0db2e4d0
--- /dev/null
+++ b/games-simulation/corsix-th/Manifest
@@ -0,0 +1,3 @@
+DIST corsix-th-0.62.tar.gz 3461932 BLAKE2B 5497cc944e51d80216f2b159249268a056193ef48837aa887d9ab8e7fd2e3134ae6f9517a6b2bd9293a97543dcc91dd76d5ce22e212f13dd7c02a79318c7ede6 SHA512 64fe4a6124cbf2e76934f2c081641119ded7292ce89124dee26c99c1d99f1979f9c520e73a403f0de751072bfd049a809773d6a919b7240b8a6e6b7aa1361bf0
+EBUILD corsix-th-0.62.ebuild 1348 BLAKE2B 5ea0041e98db5b41e2690b749ed5ee09cf77f84985efe7f2b6bad91dac0d4876c1c5b4a4d4ff9589e77c858f0884b972afd9f21538cb62121e02ad08eb8391cd SHA512 bf3985f4c11ef9f788bd55bb082e573c481da244ab6711940fd649c32dea330a37b304cce66054eb7befa1e7a1691065fdf31843268c4c75630ec338f5f1c459
+MISC metadata.xml 716 BLAKE2B 16fe66f9f3fce58b6b17df3906fdcf4e9b7a9a49be872ba69cd5deeb47bffca495ff3a8b8c89fc71cbe8b3960954a462aff8c10c6afd34c18acef95931c382f8 SHA512 643ef59451c07fd3e61b22fb9891cc2478dff78c1e2a50ed455b15bf1c01e49d384af177c687e48b2bd6590278ac121458a94760a25bdc064ce309ff5ab3b868
diff --git a/games-simulation/corsix-th/corsix-th-0.62.ebuild b/games-simulation/corsix-th/corsix-th-0.62.ebuild
new file mode 100644
index 000000000000..dd775153d21a
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.62.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop eapi7-ver gnome2-utils
+
+MY_PN="CorsixTH"
+MY_PV="$(ver_rs 2 -)"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="http://corsixth.com"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libav +midi +sound +truetype +videos"
+
+RDEPEND=">=dev-lang/lua-5.1:0
+ >=dev-lua/luafilesystem-1.5
+ >=dev-lua/lpeg-0.9
+ >=dev-lua/luasocket-3.0_rc1-r4
+ media-libs/libsdl2[opengl,video]
+ sound? ( media-libs/sdl2-mixer[midi?] )
+ truetype? ( >=media-libs/freetype-2.5.3:2 )
+ videos? (
+ !libav? ( >=media-video/ffmpeg-2.2.3:0= )
+ libav? ( >=media-video/libav-11.1:0= )
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIO="$(usex sound)"
+ -DWITH_FREETYPE2="$(usex truetype)"
+ -DWITH_LIBAV="$(usex libav)"
+ -DWITH_MOVIES="$(usex videos)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc {changelog,CONTRIBUTING}.txt
+
+ newicon -s scalable CorsixTH/Original_Logo.svg ${PN}.svg
+ make_desktop_entry ${PN} "${MY_PN}"
+}
+
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/games-simulation/corsix-th/metadata.xml b/games-simulation/corsix-th/metadata.xml
new file mode 100644
index 000000000000..0f9511952389
--- /dev/null
+++ b/games-simulation/corsix-th/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A reimplementation of the 1997 Bullfrog business sim Theme
+ Hospital. As well as faithfully recreating the original,
+ CorsixTH adds support for modern operating systems (Windows,
+ Mac OSX and Linux), high resolutions and much more.
+ </longdescription>
+ <use>
+ <flag name="midi">Adds support for background MIDI music via SDL_mixer</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">CorsixTH/CorsixTH</remote-id>
+ </upstream>
+</pkgmetadata>