summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /games-simulation
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/Manifest.gzbin3751 -> 3751 bytes
-rw-r--r--games-simulation/pmars-sdl/Manifest2
-rw-r--r--games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild80
3 files changed, 46 insertions, 36 deletions
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index c413dca1ce9d..b84b054631ae 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ
diff --git a/games-simulation/pmars-sdl/Manifest b/games-simulation/pmars-sdl/Manifest
index b862a6dd6cc8..c81f3172759c 100644
--- a/games-simulation/pmars-sdl/Manifest
+++ b/games-simulation/pmars-sdl/Manifest
@@ -1,4 +1,4 @@
AUX pmars-sdl-0.9.2e-format.patch 1988 BLAKE2B 57e96f71c6dfb6cea7286421acaa2a576ca26d9e5068a0c840b2d00dabd3ea87b2b482fe28253ef0d1b6c667bb13a2b9b8ad53f59cbb54a98f7d4da6ab1f66bf SHA512 1736220e86c762392e7074674d506fe161308a09c682a7c3cccfa7e58be880f6d44738854eae2c2c6dfc22d819c04c8fb5e9a5db632d00c35de09f4b44347014
DIST pmars-0.9.2-5.tar.gz 200966 BLAKE2B 398323191290a9e3d57cb371c2070585cf78f845ca4cbadfa09f03045abc80f7b3fb71a58c18bbfdf503a3239d25bd0734b10e784d6570766e6b5c0ec606aadf SHA512 197d1967507199ed5eb075fb232a2f15d9bdf4bec03fc6b1d6df5d6259d6627eb40338c5787852ea10d96858029144348128b08e86c7079d96f10fd09dafc315
-EBUILD pmars-sdl-0.9.2e-r1.ebuild 1803 BLAKE2B 2103fdfa2973a4dcc32220c21a150d30e66bea95837ed4610922436a49997d13e5352cd975643458e9c078b527075a905c1c8dbaa846951d75243ee6f22783b5 SHA512 fed873ec026158b1f509b785cea1cde44e551a7e18ad3418e3eabba958ee14cbc48b9e57e68064b9b6f46d5a84293e20f2d5008c8322551ede206b1d39495fab
+EBUILD pmars-sdl-0.9.2e-r1.ebuild 1954 BLAKE2B 26a0987844eec75b756079acd705da8971fae09c74ba13d729f9149be6f3ebf0a74c2fff52bd3d077705cb8fce126b004ea76f44aa605f8679be38d2604c729f SHA512 d1e2c3e2b97a6713d6624b6589204fd82901373e88a70796e9181378ddb8d1eaa6a8fd6735351f324177a6e6537d3cb36221159513dcf00b02eba50e1487564b
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild
index 6e25ce586a28..df1ca5fb51ee 100644
--- a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild
+++ b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit readme.gentoo-r1 toolchain-funcs
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs readme.gentoo-r1
MY_PN="${PN/-sdl/}"
MY_PV="${PV/e/-5}"
@@ -11,6 +12,7 @@ MY_P="${MY_PN}-${MY_PV}"
DESCRIPTION="Portable redcode simulator's sdl port for core war"
HOMEPAGE="https://corewar.co.uk/pihlaja/pmars-sdl/"
SRC_URI="https://corewar.co.uk/pihlaja/pmars-sdl/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD GPL-2"
SLOT="0"
@@ -23,10 +25,11 @@ RDEPEND="
!sdl? ( !X? ( sys-libs/ncurses:0= ) )
"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${P}-format.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+)
DOC_CONTENTS="
There are some macros in /usr/share/pmars/macros
@@ -35,41 +38,48 @@ DOC_CONTENTS="
"
src_compile() {
- CFLAGS="${CFLAGS} -DEXT94 -DPERMUTATE"
- LFLAGS="-x"
+ local LIB=""
+ export LFLAGS="-x"
+
+ append-cppflags -DEXT94 -DPERMUTATE
if use sdl ; then
- CFLAGS="${CFLAGS} -DSDLGRAPHX `sdl-config --cflags`"
- LIB=`sdl-config --libs`
+ append-cflags $(sdl-config --cflags)
+ append-cppflags -DSDLGRAPHX
+
+ LIB="$(sdl-config --libs)"
elif use X ; then
- CFLAGS="${CFLAGS} -DXWINGRAPHX"
- LIB="-L/usr/X11R6/lib -lX11"
+ append-cppflags -DXWINGRAPHX
+
+ LIB="$($(tc-getPKG_CONFIG) --libs x11)"
else
- CFLAGS="${CFLAGS} -DCURSESGRAPHX"
- LIB="-lcurses -ltinfo"
+ append-cppflags -DCURSESGRAPHX
+
+ LIB="$($(tc-getPKG_CONFIG) --libs ncurses)"
fi
- cd src
-
- SRC="asm.c
- cdb.c
- clparse.c
- disasm.c
- eval.c
- global.c
- pmars.c
- sim.c
- pos.c
- str_eng.c
- token.c"
-
- for x in ${SRC}; do
- einfo "compiling ${x}"
- $(tc-getCC) ${CFLAGS} ${x} -c || die
+ cd src || die
+
+ local programs=(
+ asm.c
+ cdb.c
+ clparse.c
+ disasm.c
+ eval.c
+ global.c
+ pmars.c
+ sim.c
+ pos.c
+ str_eng.c
+ token.c
+ )
+
+ for program in "${programs[@]}" ; do
+ einfo "Compiling ${program}"
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${program} -c || die
done
- echo
- einfo "linking with LIB: ${LIB}"
+ einfo "Linking with LIB: ${LIB}"
$(tc-getCC) ${LDFLAGS} *.o ${LIB} -o ${MY_PN} || die
}
@@ -80,10 +90,10 @@ src_install() {
dodoc AUTHORS CONTRIB ChangeLog README doc/redcode.ref
readme.gentoo_create_doc
- insinto "/usr/share/${MY_PN}/warriors"
+ insinto /usr/share/${MY_PN}/warriors
doins warriors/*
- insinto "/usr/share/${MY_PN}/macros"
+ insinto /usr/share/${MY_PN}/macros
doins config/*.mac
}