summaryrefslogtreecommitdiff
path: root/games-simulation/singularity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /games-simulation/singularity
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'games-simulation/singularity')
-rw-r--r--games-simulation/singularity/Manifest4
-rw-r--r--games-simulation/singularity/singularity-1.00.ebuild49
-rw-r--r--games-simulation/singularity/singularity-1.0_alpha1-r2.ebuild (renamed from games-simulation/singularity/singularity-1.0_alpha1-r1.ebuild)13
3 files changed, 62 insertions, 4 deletions
diff --git a/games-simulation/singularity/Manifest b/games-simulation/singularity/Manifest
index f0b225ac89dc..bec0532bbecb 100644
--- a/games-simulation/singularity/Manifest
+++ b/games-simulation/singularity/Manifest
@@ -1,4 +1,6 @@
DIST endgame-singularity-music-007.zip 51774799 BLAKE2B 78595b16e422d2312be860686aca9401f6f1eed35fe40dbbc3a3999b1feb5e32aa6d51a66d94c9241aca2b6606bb7135491298b94c8033a1437c2cd7b23f9120 SHA512 ab46e77c833085f0c5b1b46fef72ab807e79ca422ad043ef67a4bf4384cb0177319f21b4bd01496e6c3fc6fe9a2f36ec256e19f0e829ad7bf9f0c5bd38bf0fe5
+DIST singularity-1.00.tar.gz 1944972 BLAKE2B 1ca2b120311a19f175014835930610583e8f605dbda3ca3ca96d7e0da86bddeb4b0a264f50a003aa51e05b86ce971255ffda5f498598dde6be370b9a953eb1d0 SHA512 f3581048c5a535fdbd28d2af1ac596f5396fd712b716931f17de75f8b170f0e226deb2c113023357e21e7de1294e4a632515962df9ee43768baf0fb4bbaa08da
DIST singularity-1.0a1.tar.gz 1927083 BLAKE2B aeed099dd33c135f5b2e21f5e907646f32aaa0879a1b2e1f09c19045499ae52b004a8f52fee72bfe0977805899e4c7cdff6abf36e9fd3604f73cba7e395c265e SHA512 8ce624a50819e0abc04fd81a1d7658eab64ea8325de0a5790ec2a92e5fa6b62cfef8fe705fe8b209194c05927e3cf5adfc6f48934e0a70edf8b251c24084fc25
-EBUILD singularity-1.0_alpha1-r1.ebuild 1292 BLAKE2B c5ea671b32ffd02f8e5b2ef25ff95445c84e0f1bf794de5ad572bdf7a3233ea50ac1cfd520ee765324b998d61a09ca447c88d91c9c864f1f93c470ed0c90a9b3 SHA512 b5a174d35fca6d9fe173f8fb189e355274fe2852e26500b173846038ed2b784291920c6433bdb43bc463dc7fc5730e7f5dde33b3ebefa1f935b3c5c036558f86
+EBUILD singularity-1.00.ebuild 1250 BLAKE2B 8be42e500a5fda8f637e735e05f855810aa01bdfade0dce55c31ce1a58f7b25491b3eb95a1cd62a4ee575bfb0f5a5fcd7bea80726c2b948fefb2b2241bd3e9d1 SHA512 eea697f55a9212793dd044cb73475a9910cc27cf6bdc7eb20359e5212c909994c4d33c8730a14b2b37caab1d8ab36d993e593a640dcdaf6729bf5eb19bc17674
+EBUILD singularity-1.0_alpha1-r2.ebuild 1418 BLAKE2B 6a423edfa115554d268432d43384d6252640a11e233a7eda735e95814224b44ab897e915706dabe092c984ca3a477b6b77e0929dee232a6abc3e4c0bd3d9f2ce SHA512 ecd2e07da45e4372e3a0f5d7ae075eb1ececb93aff5280717978a88b046a64be4f6caafc6d6dd88b9984d58fa1f7809de43f9ce60dd7fdf12cf09cdbdef62d16
MISC metadata.xml 342 BLAKE2B 599486446074178c42f941d12e8babc285e015798d4c925f93d52040278ebba1d538223639d0d03d387901fbf216d0adb5c514f2a49318da3571509e03b52ec5 SHA512 558b706d3e1ac877859ef93f34cebbca1e477a8dc92ef7448b288c8794fc8ae9e5a62b54e9ec8f553637db7a6b051c3908c036bf704bcbd4d44a030aa7fde983
diff --git a/games-simulation/singularity/singularity-1.00.ebuild b/games-simulation/singularity/singularity-1.00.ebuild
new file mode 100644
index 000000000000..02d8aec65fc7
--- /dev/null
+++ b/games-simulation/singularity/singularity-1.00.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit desktop distutils-r1
+
+MUSIC="endgame-${PN}-music-007"
+DESCRIPTION="Simulation of a true AI. Go from computer to computer, chased by the whole world"
+HOMEPAGE="http://www.emhsoft.com/singularity/ https://github.com/singularity/singularity"
+SRC_URI="https://github.com/singularity/singularity/releases/download/v${PV}/${P/_alpha/a}.tar.gz"
+SRC_URI+=" https://emhsoft.com/singularity/${MUSIC}.zip"
+S="${WORKDIR}/${P/_alpha/a}"
+
+LICENSE="GPL-2 CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="app-arch/unzip"
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/polib[${PYTHON_USEDEP}]
+ ')
+"
+# sdl-mixer is used at runtime (through pygame)
+# bug #731702
+RDEPEND="
+ ${DEPEND}
+ media-libs/sdl-mixer[vorbis,wav]
+ !sys-cluster/singularity
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/${PN}/${PN}/music
+ doins "${WORKDIR}"/${MUSIC}/*
+
+ dodoc README.txt TODO
+
+ domenu ${PN}.desktop
+ newicon ${PN}/data/themes/default/images/icon.png ${PN}.png
+}
diff --git a/games-simulation/singularity/singularity-1.0_alpha1-r1.ebuild b/games-simulation/singularity/singularity-1.0_alpha1-r2.ebuild
index eaa127e077a6..15b223751af5 100644
--- a/games-simulation/singularity/singularity-1.0_alpha1-r1.ebuild
+++ b/games-simulation/singularity/singularity-1.0_alpha1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,14 +17,21 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+DEPEND="
+ ${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/numpy[${PYTHON_MULTI_USEDEP}]
dev-python/pygame[${PYTHON_MULTI_USEDEP}]
dev-python/polib[${PYTHON_MULTI_USEDEP}]
')
"
-DEPEND="${RDEPEND}"
+# sdl-mixer is used at runtime (through pygame)
+# bug #731702
+RDEPEND="
+ ${DEPEND}
+ media-libs/sdl-mixer[vorbis,wav]
+ !sys-cluster/singularity
+"
BDEPEND="app-arch/unzip"
S="${WORKDIR}/${P/_alpha/a}"