summaryrefslogtreecommitdiff
path: root/games-simulation/searchandrescue
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-simulation/searchandrescue
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-simulation/searchandrescue')
-rw-r--r--games-simulation/searchandrescue/Manifest5
-rw-r--r--games-simulation/searchandrescue/files/searchandrescue-1.5.0-build.patch66
-rw-r--r--games-simulation/searchandrescue/metadata.xml11
-rw-r--r--games-simulation/searchandrescue/searchandrescue-1.5.0-r1.ebuild77
4 files changed, 159 insertions, 0 deletions
diff --git a/games-simulation/searchandrescue/Manifest b/games-simulation/searchandrescue/Manifest
new file mode 100644
index 000000000000..42a2f5363352
--- /dev/null
+++ b/games-simulation/searchandrescue/Manifest
@@ -0,0 +1,5 @@
+AUX searchandrescue-1.5.0-build.patch 2110 BLAKE2B ce57c8702e1d9eeb44ace585c977a07d058b73eb109c0f22f85669199b5070d6339ae6248a54b8229735094ec8705c195a66e8c272292a738d0f8cd7f30866bd SHA512 9162d53482d1a364ff8991a318aa19322399c939e657b568e8e9d621d8ab9e462db7c14c0f350e03e6f8a6d5059d11f038485a91b92869bb7800aa77640954f8
+DIST SearchAndRescue-1.5.0.tar.gz 1473765 BLAKE2B cf7dcbb4d250a124a5450115e4fa6f016e83ba16a5ba12cbc53a3c3725643f0a0d306853a3239471ae87d4fc5bef16f2fe903601daf24e2c7a8e3dc71b1a1c2f SHA512 72a8e5c375bb2f5d11d1346bb3c81ea4678a9c58c36f53c048e9a16d32a926ff93c3ec9756867f0869aa2a8da5fb0bfe7764f704c4e79519ee0834d225513657
+DIST SearchAndRescue-data-1.3.0.tar.gz 52152370 BLAKE2B e6f19b03f45d971c43cfeb72e3202fbf99c1e3d276acc8e133e6c345b08f19cfdc1ae997fdb3d90e173fe5a6bd46685ac3903b1e1da3eda7fa105fc8d9547c7f SHA512 5419376aeecb0f05570a8d2a0a6f830f3b22ce9d1d34a5e490485767546c6d0d1d2a2a3f37e5dfcef69e271a94a9c7dfc6b592e3c0dd62a8a6c38e4bf7d25ccd
+EBUILD searchandrescue-1.5.0-r1.ebuild 1789 BLAKE2B c7a9c6a252c4e66d774d725d08eade45c683638a5d70b8c0cb4975773b76e79f15413dc96cd6988685afbcae359ba4e7d01d9988cb3d80aa520752e538082944 SHA512 46811d91f1e3de45c3ab17369e636346270c9795944e0e4badea6851b8ee138cae181e95d9ac124e276a5a57816c41f4d1b715797236371f44117cc5700c03d3
+MISC metadata.xml 338 BLAKE2B 75bbcfd013fbf4ea2aea09b64bb19a03e1e3f1490d77f4ed7f07af069ccc9c0643e5e1d0368d4dab289c709a49306645befbb28a087c59779415ab0bee0f6ab6 SHA512 434ce984794eb43c0e4083cefe03dff01118cc3b9aa64d43c7bfbfccaae20212baa111dce95ac79a9b9e94f9fc405e30bd09bd7fc845bba749e5659ae26ce388
diff --git a/games-simulation/searchandrescue/files/searchandrescue-1.5.0-build.patch b/games-simulation/searchandrescue/files/searchandrescue-1.5.0-build.patch
new file mode 100644
index 000000000000..40428bade2d7
--- /dev/null
+++ b/games-simulation/searchandrescue/files/searchandrescue-1.5.0-build.patch
@@ -0,0 +1,66 @@
+--- searchandrescue_1.3.0.orig/sar/makefile_append.ini
++++ searchandrescue_1.3.0/sar/makefile_append.ini
+@@ -3,7 +3,7 @@
+
+
+ # C++ flags:
+-CPPFLAGS = -D__cplusplus -Dc_plusplus
++CPPFLAGS += -D__cplusplus -Dc_plusplus
+
+
+ # Source files list:
+@@ -16,14 +16,12 @@
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+ @echo "Compiling module $*.o"
+- @$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+ @echo "Compiling module $*.o"
+- @$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CPPFLAGS)
+
+ # Programs
+-LS = ls
+-LSFLAGS = -s -h -c --color=auto
+ RM = rm
+ RMFLAGS = -f
+
+@@ -32,9 +30,8 @@
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+ @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
++ $(CPP) $(OBJ_C) $(OBJ_CPP) $(LDFLAGS) -o $(BIN) $(LIBS) $(LIB_DIRS)
+ @echo -n " "
+- @-$(LS) $(LSFLAGS) $(BIN)
+
+ prebuild:
+ @echo "Building program \"$(BIN)\"..."
+@@ -54,5 +51,5 @@
+ clean:
+ @echo "Cleaning program \"$(BIN)\"..."
+ @echo "Deleting all intermediate files..."
+- @$(RM) $(RMFLAGS) a.out core *.o $(BIN)
++ $(RM) $(RMFLAGS) a.out core *.o $(BIN)
+ @echo "Clean done."
+--- searchandrescue_1.3.0.orig/sar/platforms.ini
++++ searchandrescue_1.3.0/sar/platforms.ini
+@@ -102,7 +102,7 @@
+ FeatureDepend = xf86vidmode-lib
+ DependType = Library
+ MustExist = Yes
+- DependPath = libXxf86vm.a
++ DependPath = libXxf86vm.so
+ DependGrepString = XF86VidModeQueryExtension
+ FeatureDepend = xf86vidmode-devel
+ DependType = Header
+@@ -223,7 +223,7 @@
+ FeatureDepend = xf86vidmode-lib
+ DependType = Library
+ MustExist = Yes
+- DependPath = libXxf86vm.a
++ DependPath = libXxf86vm.so
+ DependGrepString = XF86VidModeQueryExtension
+ FeatureDepend = xf86vidmode-devel
+ DependType = Header
diff --git a/games-simulation/searchandrescue/metadata.xml b/games-simulation/searchandrescue/metadata.xml
new file mode 100644
index 000000000000..2ddbf0d5866c
--- /dev/null
+++ b/games-simulation/searchandrescue/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">searchandrescue</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-simulation/searchandrescue/searchandrescue-1.5.0-r1.ebuild b/games-simulation/searchandrescue/searchandrescue-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..9213c1144606
--- /dev/null
+++ b/games-simulation/searchandrescue/searchandrescue-1.5.0-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_DATA_PV=1.3.0
+MY_PN=SearchAndRescue
+DESCRIPTION="Helicopter based air rescue flight simulator"
+HOMEPAGE="http://searchandrescue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/searchandrescue/${MY_PN}-${PV}.tar.gz
+ mirror://sourceforge/searchandrescue/${MY_PN}-data-${MY_DATA_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXxf86vm
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${PN}_${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_unpack() {
+ unpack ${MY_PN}-${PV}.tar.gz
+ mkdir data && cd data && \
+ unpack ${MY_PN}-data-${MY_DATA_PV}.tar.gz
+ bunzip2 "${S}"/sar/man/${MY_PN}.6.bz2 || die
+}
+
+src_prepare() {
+ default
+
+ rm pconf/pconf || die
+ sed -i -e '/Wall/s/$/ $(CFLAGS)/' pconf/Makefile || die
+}
+
+src_configure() {
+ emake CC=$(tc-getCC) -C pconf pconf # Needed for the configure script
+
+ append-cppflags -DNEW_GRAPHICS -DHAVE_SDL_MIXER
+ export CPP="$(tc-getCXX)"
+ export CPPFLAGS="${CXXFLAGS}"
+ # NOTE: not an autoconf script
+ ./configure Linux --prefix="/usr" || die
+ sed -i -e 's/@\$/$/' sar/Makefile || die
+}
+
+src_compile() {
+ emake -C sar
+}
+
+src_install() {
+ dobin sar/${MY_PN}
+ doman sar/man/${MY_PN}.6
+ dodoc AUTHORS HACKING README
+ doicon sar/icons/SearchAndRescue.xpm
+ newicon sar/icons/SearchAndRescue.xpm ${PN}.xpm
+ dodir /usr/share/games/${PN}
+ cp -r "${WORKDIR}"/data/* "${D}/usr/share/games/${PN}/" || die
+ make_desktop_entry SearchAndRescue "SearchAndRescue" /usr/share/pixmaps/${PN}.xpm
+}