summaryrefslogtreecommitdiff
path: root/games-simulation/openrct2/openrct2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /games-simulation/openrct2/openrct2-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'games-simulation/openrct2/openrct2-9999.ebuild')
-rw-r--r--games-simulation/openrct2/openrct2-9999.ebuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/games-simulation/openrct2/openrct2-9999.ebuild b/games-simulation/openrct2/openrct2-9999.ebuild
index a54869ba1345..f0a1d342c950 100644
--- a/games-simulation/openrct2/openrct2-9999.ebuild
+++ b/games-simulation/openrct2/openrct2-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils git-r3 readme.gentoo-r1 xdg-utils
+inherit cmake git-r3 readme.gentoo-r1 xdg-utils
EGIT_REPO_URI="https://github.com/OpenRCT2/OpenRCT2.git"
EGIT_BRANCH="develop"
@@ -12,8 +12,8 @@ MY_PN="OpenRCT2"
MY_PN_OBJ="objects"
MY_PN_RPL="replays"
MY_PN_TS="title-sequences"
-MY_PV_OBJ="1.0.14"
-MY_PV_RPL="0.0.12"
+MY_PV_OBJ="1.0.16"
+MY_PV_RPL="0.0.17"
MY_PV_TS="0.1.2c"
DESCRIPTION="An open source re-implementation of Chris Sawyer's RollerCoaster Tycoon 2"
@@ -27,25 +27,23 @@ SRC_URI="
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="dedicated libressl +lightfx +opengl test +truetype twitch"
+IUSE="dedicated libressl +lightfx +opengl scripting test +truetype"
COMMON_DEPEND="
- dev-lang/duktape
dev-libs/icu:=
dev-libs/jansson
dev-libs/libzip:=
media-libs/libpng:0=
+ net-misc/curl[ssl]
sys-libs/zlib
!dedicated? (
media-libs/libsdl2
media-libs/speexdsp
opengl? ( virtual/opengl )
- twitch? (
- net-misc/curl[ssl]
- )
)
libressl? ( dev-libs/libressl:0= )
!libressl? ( dev-libs/openssl:0= )
+ scripting? ( dev-lang/duktape )
truetype? (
media-libs/fontconfig:1.0
media-libs/freetype:2
@@ -74,13 +72,14 @@ RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}/${PN}-0.2.4-include-additional-paths.patch"
+ "${FILESDIR}/${PN}-0.2.6-gtest-1.10.patch"
)
src_unpack() {
git-r3_src_unpack
- mkdir -p "${S}"/data/title || die
- cd "${S}"/data/title || die
+ mkdir -p "${S}"/data/sequence || die
+ cd "${S}"/data/sequence || die
unpack "${PN}-${MY_PN_TS}-${MY_PV_TS}".zip
mkdir -p "${S}"/data/object || die
@@ -95,7 +94,7 @@ src_unpack() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Don't treat warnings as errors.
sed -e 's/-Werror//' -i CMakeLists.txt || die
@@ -108,7 +107,7 @@ src_configure() {
-DDISABLE_DISCORD_RPC=ON
-DDISABLE_GOOGLE_BENCHMARK=ON
-DDISABLE_GUI=$(usex dedicated)
- -DDISABLE_HTTP_TWITCH=$(usex !twitch)
+ -DDISABLE_HTTP=OFF
-DDISABLE_NETWORK=OFF
$(usex !dedicated "-DDISABLE_OPENGL=$(usex !opengl)" "")
-DDISABLE_TTF=$(usex !truetype)
@@ -116,6 +115,8 @@ src_configure() {
-DDOWNLOAD_REPLAYS=OFF
-DDOWNLOAD_TITLE_SEQUENCES=OFF
-DENABLE_LIGHTFX=$(usex lightfx)
+ -DENABLE_SCRIPTING=$(usex scripting)
+ -DOPENRCT2_USE_CCACHE=OFF
-DPORTABLE=OFF
-DSTATIC=OFF
$(usex test "-DSYSTEM_GTEST=ON" "")
@@ -123,7 +124,7 @@ src_configure() {
-DUSE_MMAP=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -134,11 +135,13 @@ src_test() {
# See: https://github.com/OpenRCT2/OpenRCT2/issues/6473
ln -s "${S}"/data "${BUILD_DIR}" || die
- cmake-utils_src_test
+ cmake_src_test
}
src_install() {
- cmake-utils_src_install
+ use scripting && DOCS+=( "distribution/scripting.md" "distribution/openrct2.d.ts" )
+
+ cmake_src_install
if use dedicated; then
newinitd "${FILESDIR}"/openrct2.initd openrct2