summaryrefslogtreecommitdiff
path: root/games-simulation/flightgear/flightgear-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /games-simulation/flightgear/flightgear-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'games-simulation/flightgear/flightgear-9999.ebuild')
-rw-r--r--games-simulation/flightgear/flightgear-9999.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/games-simulation/flightgear/flightgear-9999.ebuild b/games-simulation/flightgear/flightgear-9999.ebuild
index ce6c889aeb77..85e77a5fdaa6 100644
--- a/games-simulation/flightgear/flightgear-9999.ebuild
+++ b/games-simulation/flightgear/flightgear-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils bash-completion-r1 toolchain-funcs git-r3
+inherit cmake bash-completion-r1 toolchain-funcs git-r3
DESCRIPTION="Open Source Flight Simulator"
HOMEPAGE="https://www.flightgear.org/"
@@ -65,7 +65,9 @@ RDEPEND="${COMMON_DEPEND}
~games-simulation/${PN}-data-${PV}
"
-PATCHES=("${FILESDIR}/${PN}-2018.3.2-cmake.patch")
+PATCHES=(
+ "${FILESDIR}/${PN}-2020.1.2-cmake.patch"
+)
DOCS=(AUTHORS ChangeLog NEWS README Thanks)
@@ -75,6 +77,7 @@ pkg_pretend() {
src_configure() {
local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
-DENABLE_AUTOTESTING=OFF
-DENABLE_COMPOSITOR=OFF
-DENABLE_FGCOM=$(usex utils)
@@ -96,6 +99,7 @@ src_configure() {
-DENABLE_SIMD=OFF # see CPU_FLAGS
-DENABLE_SIMD_CODE=$(usex cpu_flags_x86_sse2)
-DENABLE_STGMERGE=ON
+ -DENABLE_SWIFT=OFF # swift pilot client not packaged yet
-DENABLE_TERRASYNC=$(usex utils)
-DENABLE_TRAFFIC=$(usex utils)
-DENABLE_UIUC_MODEL=ON
@@ -130,11 +134,11 @@ src_configure() {
mycmakeargs+=(-DENABLE_FGQCANVAS=OFF)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# Install bash completion (TODO zsh)
# Uncomment below when scripts stops writing files...
@@ -144,12 +148,13 @@ src_install() {
# Install examples and other misc files
if use examples; then
- insinto /usr/share/doc/"${PF}"/examples
- doins -r scripts/java scripts/perl scripts/python
- insinto /usr/share/doc/"${PF}"/examples/c++
- doins -r scripts/example/*
- insinto /usr/share/doc/"${PF}"/tools
- doins -r scripts/atis scripts/tools/*
+ docompress -x /usr/share/doc/"${PF}"/{examples,tools}
+ docinto examples
+ dodoc -r scripts/java scripts/perl scripts/python
+ docinto examples/c++
+ dodoc -r scripts/example/*
+ docinto tools
+ dodoc -r scripts/atis scripts/tools/*
fi
# Install nasal script syntax