summaryrefslogtreecommitdiff
path: root/games-simulation/flightgear/flightgear-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /games-simulation/flightgear/flightgear-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'games-simulation/flightgear/flightgear-9999.ebuild')
-rw-r--r--games-simulation/flightgear/flightgear-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/games-simulation/flightgear/flightgear-9999.ebuild b/games-simulation/flightgear/flightgear-9999.ebuild
index f48409f1c9d4..19115fd74b49 100644
--- a/games-simulation/flightgear/flightgear-9999.ebuild
+++ b/games-simulation/flightgear/flightgear-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -54,8 +54,7 @@ COMMON_DEPEND="
"
# libXi and libXmu are build-only-deps according to FindGLUT.cmake
DEPEND="${COMMON_DEPEND}
- >=dev-libs/boost-1.44
- qt5? ( >=dev-qt/linguist-tools-5.7.1:5 )
+ dev-libs/boost
utils? (
x11-libs/libXi
x11-libs/libXmu
@@ -64,6 +63,7 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
~games-simulation/${PN}-data-${PV}
"
+BDEPEND="qt5? ( >=dev-qt/linguist-tools-5.7.1:5 )"
PATCHES=(
"${FILESDIR}/${PN}-2020.3.5-cmake.patch"
@@ -72,7 +72,11 @@ PATCHES=(
DOCS=(AUTHORS ChangeLog NEWS README Thanks)
pkg_pretend() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_configure() {