summaryrefslogtreecommitdiff
path: root/games-simulation/crrcsim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-simulation/crrcsim
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-simulation/crrcsim')
-rw-r--r--games-simulation/crrcsim/Manifest6
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13.ebuild62
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch62
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-gcc6.patch14
-rw-r--r--games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch11
-rw-r--r--games-simulation/crrcsim/metadata.xml15
6 files changed, 170 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/Manifest b/games-simulation/crrcsim/Manifest
new file mode 100644
index 000000000000..dedc0191769e
--- /dev/null
+++ b/games-simulation/crrcsim/Manifest
@@ -0,0 +1,6 @@
+AUX crrcsim-0.9.13-buildsystem.patch 2183 BLAKE2B 2f1fb768f93e7d3db1fbd7a2a30c8244c14f6a2701d8a8e80679723aeac11882d7801aaba3f4433036fa078c3f199d7c4fc01a6e8ce2363db37519cb205386aa SHA512 9b28fe63ea4bd3d21559306bd110eaa2c518dc933a572a93dc21182464ee4f95bf7d8bc3f21ebe78addbcc2e432fcd2992587925f97d633270ce9d47ff2e228b
+AUX crrcsim-0.9.13-gcc6.patch 461 BLAKE2B 7e2016db5781e0158e27d999fb1d88d07dc6294740466c736a2e42eb46547fdb35ac112b6c8e93a5571103d28d6037a6acdb2be752bfb2650cc349538e72c3f4 SHA512 34bda65c0791622adb8436d08b60e6a877c2a3bbb12f93379686c39c2c572364c0fa265011bbc788229fa2ddaa3bfa3be8397d2ff98ea967f423fa3cd48465e9
+AUX crrcsim-cgal_gmp.patch 352 BLAKE2B 1a9cf7250753c1a0099dd07b5020b7c5af89dffa8387d68f71c51e21a7803ecb2395144de65915ce84cf077b522fecc5790d26190abf9673fef687d1e16f0d6b SHA512 1b8302f71e220df54b73819988f866a7e35ec6b11d271a6a57ad886372fba4eb1a02367ab9942030baf04fbeb5fa093d23e38de2614c39c2c75e76795ec69274
+DIST crrcsim-0.9.13.tar.gz 8337392 BLAKE2B ccaaf3a4255b2082fc52712d49302c7de1347b87e9489c6d859662365f1cd5af538fe76cee232aed61b0c1b68138c47a2e34e128071c3e098e20f1d51c1c409c SHA512 b687837e07abc07606404d920288984abe7e304afb69158fd840d83bcfe1e9acc4afd8462c0c759df67d50a15ca3753eaf48c4526b201e64a2d641fa3aa8c1ab
+EBUILD crrcsim-0.9.13.ebuild 1232 BLAKE2B ccf89f098cff67e93ee091af11464fd63878c32b052218acb944c0b22934fc27be1d89c45fbcecdb2c616d4fc30c8c4cc460c6085a41868104bd28dc1dbcc5d4 SHA512 ab16d675e3135e65b649ab7cc9a912c84e4d90881042531b89a06e9ce25cfa44fd5e23f525a6b41396c2b907c25db867e7329e96f0f015bc8c0b1c85098c5adb
+MISC metadata.xml 434 BLAKE2B fee01c09cd762a25d96338cf574d37a09240069d6c4eac694fdcb84bf819310a55c89790902b97f9bb7b58e199106bbfd1e5a89ce2a061e0af91285419d461f6 SHA512 bb752783e5e310b3a0f321dda5ffb813df1b54c9dbd4b062f3a42ab41466751d4029f02bd56eb70d025b6087487782eee4e2b0aedd683d13e99336b512b2cbec
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13.ebuild
new file mode 100644
index 000000000000..ef5b5ce752df
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.13.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WANT_AUTOMAKE="1.10"
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="model-airplane flight simulation program"
+HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="media-libs/libsdl[X,sound,joystick,opengl,video]
+ media-libs/plib
+ sci-mathematics/cgal
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buildsystem.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+src_prepare() {
+ default
+
+ if has_version "sci-mathematics/cgal[gmp(+)]" ; then
+ eapply "${FILESDIR}"/${PN}-cgal_gmp.patch
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir="/usr/share" \
+ --datarootdir="${EPREFIX%/}/usr/share" \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with portaudio)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS HISTORY NEWS README
+ doicon -s 32 packages/icons/${PN}.png
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch
new file mode 100644
index 000000000000..396fd573ec90
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch
@@ -0,0 +1,62 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -79,8 +79,12 @@
+ dnl Default is: no portaudio present
+ portaudio=0
+
++AC_ARG_WITH([portaudio], AS_HELP_STRING([--without-portaudio], [Build without portaudio library (default: test)]))
++
++AS_IF([test "x$with_portaudio" != "xno"], [
+ dnl Check for the Portaudio header file
+ AC_CHECK_HEADER([portaudio.h])
++])
+
+ if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
+ dnl Check for Portaudio 18
+--- crrcsim-0.9.13/src/mod_misc/filesystools.cpp
++++ crrcsim-0.9.13/src/mod_misc/filesystools.cpp
+@@ -113,8 +113,8 @@
+ // $USERPROFILE/.crrcsim (WIN32)
+ // $HOME/.crrcsim (LINUX)
+ // CRRC_DATA_PATH (LINUX)
+- // /usr/local/share/games/crrcsim (LINUX)
+- // /usr/share/games/crrcsim (LINUX)
++ // /usr/local/share/crrcsim (LINUX)
++ // /usr/share/crrcsim (LINUX)
+
+ // cwd
+ if (dirname != "")
+@@ -154,13 +154,13 @@
+ s.append(dirname);
+ pathlist.push_back(s);
+ #endif
+- s = "/usr/local/share/games/" + appname + "/";
++ s = "/usr/local/share/" + appname + "/";
+ if (s != data_path) // avoid adding this path twice
+ {
+ s.append(dirname);
+ pathlist.push_back(s);
+ }
+- s = "/usr/share/games/" + appname + "/";
++ s = "/usr/share/" + appname + "/";
+ if (s != data_path) // avoid adding this path twice
+ {
+ s.append(dirname);
+@@ -172,13 +172,13 @@
+ #ifdef CRRC_DATA_PATH
+ pathlist.push_back(data_path);
+ #endif
+- if (data_path != "/usr/local/share/games/" + appname) // avoid adding this path twice
++ if (data_path != "/usr/local/share/" + appname) // avoid adding this path twice
+ {
+- pathlist.push_back("/usr/local/share/games/" + appname);
++ pathlist.push_back("/usr/local/share/" + appname);
+ }
+- if (data_path != "/usr/share/games/" + appname) // avoid adding this path twice
++ if (data_path != "/usr/share/" + appname) // avoid adding this path twice
+ {
+- pathlist.push_back("/usr/share/games/" + appname);
++ pathlist.push_back("/usr/share/" + appname);
+ }
+ }
+ #endif
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-gcc6.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-gcc6.patch
new file mode 100644
index 000000000000..b11550f3dff6
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-0.9.13-gcc6.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/610560
+Upstream commit: https://sourceforge.net/p/crrcsim/code/ci/28ed9ba57011371cab8b637550acc716b973c47d
+
+--- a/src/mod_video/crrc_animation.cpp
++++ b/src/mod_video/crrc_animation.cpp
+@@ -84,7 +84,7 @@
+ else
+ {
+ std::cerr << "createAnimation: unknown animation type \'"
+- << type << "\'" << std::cerr;
++ << type << "\'" << std::endl;
+ }
+
+ if (anim != NULL)
diff --git a/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
new file mode 100644
index 000000000000..10d6bff6b769
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
@@ -0,0 +1,11 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -229,7 +229,7 @@
+ has_CGAL="yes (found CGAL v3)"
+ fi
+ CGAL_CFLAGS=-frounding-math
+- CGAL_LIBS=-lCGAL
++ CGAL_LIBS="-lCGAL -lgmp"
+ AC_DEFINE([WINDDATA3D], [1], [Import code for wind data, needs CGAL, 0 to disable])
+ else
+ has_CGAL="no (CGAL not found)"
diff --git a/games-simulation/crrcsim/metadata.xml b/games-simulation/crrcsim/metadata.xml
new file mode 100644
index 000000000000..9bc28cff4765
--- /dev/null
+++ b/games-simulation/crrcsim/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">crrcsim</remote-id>
+ </upstream>
+</pkgmetadata>