summaryrefslogtreecommitdiff
path: root/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild')
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
new file mode 100644
index 000000000000..f32c81a4c523
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.13-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Model-airplane flight simulation program"
+HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="
+ dev-libs/gmp:=
+ media-libs/libsdl[X,sound,joystick,opengl,video]
+ media-libs/plib
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+ portaudio? ( media-libs/portaudio )"
+DEPEND="
+ ${RDEPEND}
+ sci-mathematics/cgal"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+DOCS=( AUTHORS HISTORY )
+
+src_configure() {
+ econf ac_cv_header_portaudio_h=$(usex portaudio)
+}
+
+src_compile() {
+ emake CGAL_LIBS=
+}
+
+src_install() {
+ default
+
+ doicon packages/icons/${PN}.png
+ make_desktop_entry ${PN} CRRCSim
+}