summaryrefslogtreecommitdiff
path: root/games-simulation/corsix-th
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /games-simulation/corsix-th
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'games-simulation/corsix-th')
-rw-r--r--games-simulation/corsix-th/Manifest3
-rw-r--r--games-simulation/corsix-th/corsix-th-0.62.ebuild4
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch10
3 files changed, 15 insertions, 2 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
index 9cbf0db2e4d0..102a85cb261f 100644
--- a/games-simulation/corsix-th/Manifest
+++ b/games-simulation/corsix-th/Manifest
@@ -1,3 +1,4 @@
+AUX corsix-th-0.62-gcc-10.patch 241 BLAKE2B 78ab7aebd36fe16b63e111f459f324f3165a3df99f29771584c074fbd7fa29849e9e9d66b55592340b6292a48006ab003f2f09a767a58e5f40fe9630eae25075 SHA512 a85c8613ab94903db4b42f74c326620f81c6f9212a78b42e656b57e00c455fba7c457469e07c7ab9a144032e7d3aa244fdc269c3aa520fdbd9bf4c373fd766ed
DIST corsix-th-0.62.tar.gz 3461932 BLAKE2B 5497cc944e51d80216f2b159249268a056193ef48837aa887d9ab8e7fd2e3134ae6f9517a6b2bd9293a97543dcc91dd76d5ce22e212f13dd7c02a79318c7ede6 SHA512 64fe4a6124cbf2e76934f2c081641119ded7292ce89124dee26c99c1d99f1979f9c520e73a403f0de751072bfd049a809773d6a919b7240b8a6e6b7aa1361bf0
-EBUILD corsix-th-0.62.ebuild 1348 BLAKE2B 5ea0041e98db5b41e2690b749ed5ee09cf77f84985efe7f2b6bad91dac0d4876c1c5b4a4d4ff9589e77c858f0884b972afd9f21538cb62121e02ad08eb8391cd SHA512 bf3985f4c11ef9f788bd55bb082e573c481da244ab6711940fd649c32dea330a37b304cce66054eb7befa1e7a1691065fdf31843268c4c75630ec338f5f1c459
+EBUILD corsix-th-0.62.ebuild 1388 BLAKE2B b01733a208e1265abbd648f69a27f97abccaee6a5bb9ed964fabb5c66ec88a21b557e88e179437a001c52e7ed6b347927fa7bf93938c8fc8cc9089681e7806c7 SHA512 c186b2de9eced05e70b7278c2050ccabd675a481b4d6a2b49aba91a661d66274ce62f91f0609bdd92750c3c2c102364b939b76f45a2c4ef48d7c26b6e8c73246
MISC metadata.xml 716 BLAKE2B 16fe66f9f3fce58b6b17df3906fdcf4e9b7a9a49be872ba69cd5deeb47bffca495ff3a8b8c89fc71cbe8b3960954a462aff8c10c6afd34c18acef95931c382f8 SHA512 643ef59451c07fd3e61b22fb9891cc2478dff78c1e2a50ed455b15bf1c01e49d384af177c687e48b2bd6590278ac121458a94760a25bdc064ce309ff5ab3b868
diff --git a/games-simulation/corsix-th/corsix-th-0.62.ebuild b/games-simulation/corsix-th/corsix-th-0.62.ebuild
index dd775153d21a..b7772ebb3381 100644
--- a/games-simulation/corsix-th/corsix-th-0.62.ebuild
+++ b/games-simulation/corsix-th/corsix-th-0.62.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,6 +34,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_PN}-${MY_PV}"
+PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
+
src_configure() {
local mycmakeargs=(
-DWITH_AUDIO="$(usex sound)"
diff --git a/games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch b/games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch
new file mode 100644
index 000000000000..ff820f44946b
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-0.62-gcc-10.patch
@@ -0,0 +1,10 @@
+--- a/CorsixTH/Src/th_lua_map.cpp
++++ b/CorsixTH/Src/th_lua_map.cpp
+@@ -26,6 +26,7 @@ SOFTWARE.
+ #include <cstring>
+ #include <string>
+ #include <exception>
++#include <stdexcept> /* std::out_of_range */
+
+ static const int player_max = 4;
+