summaryrefslogtreecommitdiff
path: root/games-simulation/corsix-th
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /games-simulation/corsix-th
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'games-simulation/corsix-th')
-rw-r--r--games-simulation/corsix-th/Manifest3
-rw-r--r--games-simulation/corsix-th/corsix-th-0.66-r1.ebuild79
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch13
3 files changed, 95 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
index 7dae4f82ef2c..f1ad38e07cf1 100644
--- a/games-simulation/corsix-th/Manifest
+++ b/games-simulation/corsix-th/Manifest
@@ -1,4 +1,7 @@
AUX corsix-th-0.64-cmake_lua_detection.patch 288 BLAKE2B 90673498871c16f48c752c5581dfec0a290966ef0ec79c977b69575b26a22843829679a7c0225caabe2b570b9b6a38e025115f3a2cf0597b0dad9dc78f01f36d SHA512 52dc61c7aa8c170da225801f2eb06140e9dc28c4d55853eac99b573475a21fb03b945de676898719927abd517b34ecce2aa5c4998ac6e6fcc673cf2aaf7cdb9e
+AUX corsix-th-0.66-cmake_lua_detection.patch 499 BLAKE2B 939992cced1c18dc5a6c53b892e8d2adbe084e9bf028c4c858e3c809a4bc5df0b304aae020994d8b94052bcda60486affb080096c688eb6120950ea626f5db9b SHA512 bcdbbe851610afb863b6c58700ab03f3c426cd6f9a9795d853a819bde3e9ac0d89a1d99eb04f2559f9ac80344c03aa1fc8c99cbc80c7b81e4e3739af6db6bdf4
DIST corsix-th-0.65.1.tar.gz 4163922 BLAKE2B c1d9255e41521876716b377579642ed46b9fc54823816dc431f7b56ffa532af7091ae0b1e291bb1c4fb74165ca07786e0991a990c90bc3a13e234ba31c6fa706 SHA512 b7e964c22517b94cb1dafb0529368c87a2e58cf1f784062b9f2f72749ba69523b63d4f846ebd582c71cf5ca7e7c437a34717ca3877ad3737139ba2fd6a316577
+DIST corsix-th-0.66.tar.gz 4117046 BLAKE2B 7bceb0d5893849ba906ccd9516ecd52f0a1c54f3a91bff932c0db053f66e71a3d38dfdb55979cb9bb2047c7338b3badbb32defa216a9867fb7166f4ca14bfa75 SHA512 a5cea74e7754132a7edbe188c63c08eb40ba8a8bbef6dc7441e41c5f46e96cacaa077d00bead4f8b3af3b8e07eadb4cfd08b1fb147e1397e2f9aa02642d29105
EBUILD corsix-th-0.65.1.ebuild 1930 BLAKE2B 03c8ea8fe8c05ce95ac543412c70e2d63ceb1bfebd3369f94ff566ea723466f744a485436adf31d270c40172f49a37dff1f1bcc407f3b730e0486cbc1173f39a SHA512 0c901db2b7f5bcfc5c846fea06654d0580357137e06ff27b3140db4b7b41c13303d72361980b0792a29d140cefe4b36600e3a6bac247fc481a38d31961d6983f
+EBUILD corsix-th-0.66-r1.ebuild 1894 BLAKE2B 4793011e203c1411b577993d48e9dfb0cb90c552d040e6d5b27cec5ddaee0bbea850af09d506c1921ccd81b326c92c9ccdd7fee2a09ce91663a6158da84b4844 SHA512 282855b488d10685b98ed9fb13c87e2b57220fd5b16517ce4129a4e7b0e66c5143b39e87632cdd503bb6a596b2a79883048c52da088c6325559ebd67c1dca635
MISC metadata.xml 717 BLAKE2B c32582188f6a89239fbec43977d4d126075de2d599c8496ebf01e0a7d919550739913d0290afb24544cc8ea4ff2177a89bbcdaa14ba5e4654d8a7f7db07be294 SHA512 3b3387491e7c51efcc777675e9b996c5648b8e0f5fc7319345a500e60aad08c2a5ca5a9fc0d46928fc60346151232daaf719e7a5ed5fb8a1bc03c40313652ca5
diff --git a/games-simulation/corsix-th/corsix-th-0.66-r1.ebuild b/games-simulation/corsix-th/corsix-th-0.66-r1.ebuild
new file mode 100644
index 000000000000..37a6785596eb
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.66-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit cmake lua-single xdg
+
+MY_PN="CorsixTH"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="https://corsixth.com"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc +midi +sound +truetype +videos"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ >=dev-lua/luafilesystem-1.5[${LUA_USEDEP}]
+ >=dev-lua/lpeg-0.9[${LUA_USEDEP}]
+ >=dev-lua/luasocket-3.0_rc1-r4[${LUA_USEDEP}]
+ ')
+ media-libs/libsdl2[opengl,video]
+ sound? ( media-libs/sdl2-mixer[midi?] )
+ truetype? ( >=media-libs/freetype-2.5.3:2 )
+ videos? ( >=media-video/ffmpeg-2.2.3:0= )
+"
+
+DEPEND="${RDEPEND}"
+
+# Technically, build-time generation of documentation could use any version
+# of Lua (or to be precise: if in src_configure cmake has been told to use
+# LuaJIT documentation generation looks for LuaJIT, otherwise any
+# dev-lang/lua slot will do; see the first few lines of the bundled file
+# CMake/GenerateDoc.cmake for details) - but since dev-lang/lua conflicts
+# with the other slots of same, try to keep the deptree sane until we get
+# rid of unslotted Lua.
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ ${LUA_DEPS}
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.66-cmake_lua_detection.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLUA_VERSION=$(lua_get_version)
+ -DWITH_AUDIO=$(usex sound)
+ -DWITH_FREETYPE2=$(usex truetype)
+ -DWITH_MOVIES=$(usex videos)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ dodoc changelog.txt CONTRIBUTING.md
+
+ docinto html
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}
diff --git a/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch b/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch
new file mode 100644
index 000000000000..f85d1bfb0b89
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch
@@ -0,0 +1,13 @@
+diff --git a/CorsixTH/CMakeLists.txt b/CorsixTH/CMakeLists.txt
+index 1544810..05ed3b0 100644
+--- a/CorsixTH/CMakeLists.txt
++++ b/CorsixTH/CMakeLists.txt
+@@ -133,7 +133,7 @@ if(MSVC AND USE_VCPKG_DEPS)
+ target_link_libraries(CorsixTH_lib lua)
+ target_link_libraries(CorsixTH lua)
+ else()
+- find_package(Lua REQUIRED)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ if(Lua_FOUND OR LUA_FOUND)
+ target_link_libraries(CorsixTH ${LUA_LIBRARY})
+ include_directories(${LUA_INCLUDE_DIR})