summaryrefslogtreecommitdiff
path: root/games-simulation/corsix-th/corsix-th-0.63.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /games-simulation/corsix-th/corsix-th-0.63.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'games-simulation/corsix-th/corsix-th-0.63.ebuild')
-rw-r--r--games-simulation/corsix-th/corsix-th-0.63.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/corsix-th-0.63.ebuild b/games-simulation/corsix-th/corsix-th-0.63.ebuild
new file mode 100644
index 000000000000..5364f218f86d
--- /dev/null
+++ b/games-simulation/corsix-th/corsix-th-0.63.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg
+
+MY_PN="CorsixTH"
+MY_PV="$(ver_rs 2 -)"
+
+DESCRIPTION="Open source clone of Theme Hospital"
+HOMEPAGE="http://corsixth.com"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc libav +midi +sound +truetype +videos"
+
+RDEPEND="
+ >=dev-lang/lua-5.1:0
+ >=dev-lua/luafilesystem-1.5
+ >=dev-lua/lpeg-0.9
+ >=dev-lua/luasocket-3.0_rc1-r4
+ media-libs/libsdl2[opengl,video]
+ sound? ( media-libs/sdl2-mixer[midi?] )
+ truetype? ( >=media-libs/freetype-2.5.3:2 )
+ videos? (
+ !libav? ( >=media-video/ffmpeg-2.2.3:0= )
+ libav? ( >=media-video/libav-11.1:0= )
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ >=dev-lang/lua-5.1:0
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.62-gcc-10.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AUDIO=$(usex sound)
+ -DWITH_FREETYPE2=$(usex truetype)
+ -DWITH_LIBAV=$(usex libav)
+ -DWITH_MOVIES=$(usex videos)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ dodoc {changelog,CONTRIBUTING}.txt
+
+ docinto html
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}