summaryrefslogtreecommitdiff
path: root/games-simulation/EmptyEpsilon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-20 11:59:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-20 11:59:50 +0100
commitb92d3efc1e8f2a9c4b5a674b333eea5e6ad2c181 (patch)
tree4c6b5c3dd56bc0c408fde62803ac84e253bc865a /games-simulation/EmptyEpsilon
parentdcf9ac80d0667a18496506842a8903ba5dab2fc7 (diff)
gentoo auto-resync : 20:04:2023 - 11:59:50
Diffstat (limited to 'games-simulation/EmptyEpsilon')
-rw-r--r--games-simulation/EmptyEpsilon/EmptyEpsilon-2022.03.16.ebuild92
-rw-r--r--games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild12
-rw-r--r--games-simulation/EmptyEpsilon/Manifest8
3 files changed, 16 insertions, 96 deletions
diff --git a/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.03.16.ebuild b/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.03.16.ebuild
deleted file mode 100644
index ccb890d0ff82..000000000000
--- a/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.03.16.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-# basics_universal version
-MY_BU_VER="1_15_update2"
-# meshoptimizer version
-MY_MO_VER="0.16"
-
-DESCRIPTION="A spaceship bridge simulator game"
-HOMEPAGE="https://daid.github.io/EmptyEpsilon/"
-# This bundles SeriousProton as the build system does not support using
-# a separate SeriousProton instance (and currently EmptyEpsilon seems to
-# be the only consumer).
-SRC_URI="
- https://github.com/daid/EmptyEpsilon/archive/EE-${PV}.tar.gz -> EmptyEpsilon-${PV}.tar.gz
- https://github.com/daid/SeriousProton/archive/EE-${PV}.tar.gz -> SeriousProton-${PV}.tar.gz
- https://github.com/BinomialLLC/basis_universal/archive/refs/tags/v${MY_BU_VER}.tar.gz -> basis_universal_${MY_BU_VER}.tar.gz
- https://github.com/zeux/meshoptimizer/archive/refs/tags/v${MY_MO_VER}.tar.gz -> meshoptimizer-${MY_MO_VER}.tar.gz
-"
-
-# EmptyEpsilon is mostly licensed under GPL, however the art ressources
-# use Creative Commons and the bundled SeriousProton is MIT-licensed.
-LICENSE="Apache-2.0 GPL-2 CC-BY-SA-3.0 MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-RDEPEND="
- dev-cpp/nlohmann_json
- media-libs/freetype
- media-libs/libsdl2
- >=media-libs/glm-0.9.9.8
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/EmptyEpsilon-EE-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-cmake-meshoptimizer.patch"
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} == "binary" ]] && return
-
- if tc-is-gcc; then
- if [[ $(gcc-major-version) -lt 11 ]]; then
- # ld: /usr/lib64/libsfml-audio.so: undefined reference to `std::__throw_bad_array_new_length()@GLIBCXX_3.a4.29'
- eerror "${PN} requires GCC >= 11. Run gcc-config to switch your default compiler."
- die "Need at least GCC >= 11"
- fi
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-
- local -A externals=()
- externals["${BUILD_DIR}/SeriousProton/externals/basis"]="${WORKDIR}/basis_universal-${MY_BU_VER}"
- externals["${BUILD_DIR}/externals/meshoptimizer"]="${WORKDIR}/meshoptimizer-${MY_MO_VER}"
- local link
- for link in "${!externals[@]}"; do
- local external_dir=$(dirname "${link}")
- if [[ ! -d "${external_dir}" ]]; then
- mkdir -p "${external_dir}" || die
- fi
- local target="${externals[${link}]}"
- ln -rs "${target}" "${link}" || die
- done
-
- local serious_proton_patches=(
- "${FILESDIR}/SeriousProton-cmake.patch"
- "${FILESDIR}/SeriousProton-Add-missing-include-memory-to-websocket.h.patch"
- )
- eapply --directory="${WORKDIR}/SeriousProton-EE-${PV}" \
- "${serious_proton_patches[@]}"
-}
-
-src_configure() {
- local version=( $(ver_rs 1- ' ') )
- local mycmakeargs=(
- -DSERIOUS_PROTON_DIR="${WORKDIR}/SeriousProton-EE-${PV}/"
- -DCPACK_PACKAGE_VERSION="${PV}"
- -DCPACK_PACKAGE_VERSION_MAJOR="${version[0]}"
- -DCPACK_PACKAGE_VERSION_MINOR="${version[1]}"
- -DCPACK_PACKAGE_VERSION_PATCH="${version[2]}"
- )
-
- cmake_src_configure
-}
diff --git a/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild b/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild
index 712b44d5d70d..11108d01222d 100644
--- a/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild
+++ b/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild
@@ -20,6 +20,12 @@ SRC_URI="
https://github.com/daid/SeriousProton/archive/EE-${PV}.tar.gz -> SeriousProton-${PV}.tar.gz
https://github.com/BinomialLLC/basis_universal/archive/refs/tags/v${MY_BU_VER}.tar.gz -> basis_universal_${MY_BU_VER}.tar.gz
https://github.com/zeux/meshoptimizer/archive/refs/tags/v${MY_MO_VER}.tar.gz -> meshoptimizer-${MY_MO_VER}.tar.gz
+ https://github.com/Flowdalic/SeriousProton/commit/dc9dccf6c802b9c55ac4eccad424d2b1af9f4b93.patch ->
+ SeriousProton-2022.10.28-add-missing-cstdint-include.patch
+ https://github.com/daid/SeriousProton/commit/3bb7f1cfbd91a4520ff23af7d761e08b5ca7cf88.patch ->
+ SeriousProton-2022.10.28-lua-fix-underlinking.patch
+ https://github.com/daid/EmptyEpsilon/commit/5d7e7bba4daadeeb05897349d518a8d9568331cc.patch ->
+ EmptyEpsilon-2022.10.28-fix-underliking-stdcxx.patch
"
# EmptyEpsilon is mostly licensed under GPL, however the art ressources
@@ -40,6 +46,8 @@ S="${WORKDIR}/EmptyEpsilon-EE-${PV}"
PATCHES=(
"${FILESDIR}/${PN}-cmake-meshoptimizer.patch"
+ # https://github.com/daid/EmptyEpsilon/pull/1969
+ "${DISTDIR}/EmptyEpsilon-2022.10.28-fix-underliking-stdcxx.patch"
)
pkg_pretend() {
@@ -72,6 +80,10 @@ src_prepare() {
local serious_proton_patches=(
"${FILESDIR}/SeriousProton-cmake.patch"
+ # https://github.com/daid/SeriousProton/pull/236
+ "${DISTDIR}/SeriousProton-2022.10.28-add-missing-cstdint-include.patch"
+ # https://github.com/daid/SeriousProton/pull/237
+ "${DISTDIR}/SeriousProton-2022.10.28-lua-fix-underlinking.patch"
)
eapply --directory="${WORKDIR}/SeriousProton-EE-${PV}" \
"${serious_proton_patches[@]}"
diff --git a/games-simulation/EmptyEpsilon/Manifest b/games-simulation/EmptyEpsilon/Manifest
index eea304275a9a..67b3a84fb7f9 100644
--- a/games-simulation/EmptyEpsilon/Manifest
+++ b/games-simulation/EmptyEpsilon/Manifest
@@ -1,12 +1,12 @@
AUX EmptyEpsilon-cmake-meshoptimizer.patch 457 BLAKE2B fcef3984e5154ea1819109b89398be0c519f699296d7f64070060cbce888fa8f8c12aac77f9db14c607ef8f7499338e41ef84cb6c6778b2e5198f9e0d795ae77 SHA512 c171fb453ff71c5925508cf6eeee821dadfd95b38470596f5719de1f711eaba31a361289e5f3efe31bc83b778aa5850f1c3a1fa766fb1de98aa6e8ca8938b82e
AUX SeriousProton-Add-missing-include-memory-to-websocket.h.patch 706 BLAKE2B 12129f7eca18439840bbbf53968ec0f950158dd01659bf7923a126b1176678613c704e9b00f7817b281095d5ecf859d29832295ab19b8fc63526882f565aa31f SHA512 3be656fa7c883e91df93085d8b5cc296d4912723b785472c187abff3e51562d5f0b82a2fea6bcd47c58dc00294b9302cfb6a97256456e990f246ba60bad6f725
AUX SeriousProton-cmake.patch 450 BLAKE2B 1f1585eda5dcf7980d4439e1485edf4363dba5378c968f387c3b978eee9a9c5d7bdd406dcdc207dbe1e93f1efdf88285995cc3a5a414e1dc4566123e7685388f SHA512 bc09fa1047f1cc33c5d27ffd640d6e06623f83bb49263786bdab25e3fa353fbddef4d15203197ecf58eac696f92f27b47b9eae67a872a49bda2c11579741dbcd
-DIST EmptyEpsilon-2022.03.16.tar.gz 258014053 BLAKE2B d447518c6887b5969bce48abc042a259733a6845a49ba767b274d17c1b0e28a025443d073563e269365837191439f7963f3a3775c58b143e97cef7b7c0cef336 SHA512 63f351be1af792be0ce8b1171ea14dd9f3ab75825ca9df48f7a7bfbc3cedfe05183f59896a51cd4e1f4e977aa5c9386159716dcc206afd7a1adab1df7c35e062
+DIST EmptyEpsilon-2022.10.28-fix-underliking-stdcxx.patch 668 BLAKE2B 7338f41fa2bf3b95352ff70ce0440f501fc6c99778fdef9d2af3ceae7a7e141ae3e85d290a4c18b4f97f993533e40cc4e66d2715be6d78545ce9bbb413a4e357 SHA512 cfedba9ceca79511478180eefcc130a7a4a33ae2f0c2577b05df6acb24c261dfb03f914e1681bfb952efbc7ff27b729745afc5ef4f2fa2fbe6f1fdbb988600b4
DIST EmptyEpsilon-2022.10.28.tar.gz 258148673 BLAKE2B dcc2cdd6f02afef4fee00939145c4c98461ea5403ad45949ffc99758b0575f56504b610249231969f63751d8a2f746913a004d88d7287876a5b448a4b90d8162 SHA512 6af0522cb9f07f0b0cf3ac287ce57b156206b27b4d17de237acf50c46928782c49a4af397c9cad4be30603e0ee04bd6979404e11d0b2c5472cf0c278124df140
-DIST SeriousProton-2022.03.16.tar.gz 2671635 BLAKE2B 9fdb58d50e7f3522678efe14b753016c4d2e3341f2e3b78ede00815e4f6a6361eb635016c9cdf0ce235a0bb35fb813b61790a5b0d1522a1e8afe2f3594674341 SHA512 74a06c69a3f49789b35a6e5795a7b1de1b7e79d36c956a92e1383f9983489319060c62f3ee6349e26ac985a5121b4e60cf7a3546ec78b3a830e30c0c99ccd023
+DIST SeriousProton-2022.10.28-add-missing-cstdint-include.patch 850 BLAKE2B f193fb30b39e7b07caf0018fc4e32430ee451baaf63315110e204e7e6f3aff84448a3a5cc83b60e642c27cebb39f532065bd1126f5646ac70645c1c341c8e464 SHA512 3645efb49ea012a31da0414a454bfca46170dfdfd90db7af07481181d75b87c621e7d8ba2ee9752c49d978ab0e5080f01b81eeb07cf1ce68425066c8a4111c2b
+DIST SeriousProton-2022.10.28-lua-fix-underlinking.patch 736 BLAKE2B 50a0fa840c90056032100d19805eb26ba4b0135b77cd7a9bfea92201c0c4b88b0e8597f6cbf453ebb8ffae19e90ef691fb1e98a0219027bfd906eade92956abe SHA512 d7949e6d622d7470de0a1a68c1cecc5920d72b8e9f919c7f0c19be884a981b7e07c8ed2e0c2f51eb532ff46bcb43f40eb4db1ebde7a97f708809f54c2396cf15
DIST SeriousProton-2022.10.28.tar.gz 2668713 BLAKE2B 9f200881bfa812904cd37428eb2bb2f8e04c46a134e8b3fceb0e02e87fe4bd7e529e1fbaf18cb4e284ec7ee4d1c6e8606f35e7ec3e61efa66816a7b354d446b9 SHA512 7955ed78529c0f69d6fd3ef6fac5537009548cdfe1cf8e47dc1fac8919fc3532e03453869968369f027c40dd4da513cfd84e58ffedaddd4b9d9fe67d28406be7
DIST basis_universal_1_15_update2.tar.gz 13283133 BLAKE2B 5400d23f86dd581da1bc96c1b95eae58f3c97b5412ad1d09d7f4ffd2ae7cae6cb14330795380e253579cc17f1ee16c91555229268219c300905da1420c0d8717 SHA512 a898a057b57ac64f6c0bf5fce0b599e23421ccdd015ea7bb668bce8b9292ef55b098f3d05854a2fb5363959932b75cd0a842664ae7d4f71f3537dc11301c1b32
DIST meshoptimizer-0.16.tar.gz 342571 BLAKE2B 2b4e244ea3676f109c904261d47bd0e7b2ad440f23d65325d34281ed13ac09657116c96b5a56860a0107479773b58c21018c8825b314f87a05bce38341fd75c1 SHA512 cc6d28359fb99a615e1046a4af1b247cbc6ea0266d9e7f41ea0516c1fc09fa1e67376071daf138a126c77bca3baf9d565636ed0e3adf045f1a08498c38b7a7e7
-EBUILD EmptyEpsilon-2022.03.16.ebuild 2844 BLAKE2B 475c559eb8741d6aafaf315dd837ca71d3cd82990c149a018cb2107390aa5542b899dc8fc1a6a10844dc281ac53d6aae99e0856889963b9d4fe8f510553dae32 SHA512 038c54763a17e43c7ff334fe5de2e748609064729f0cb66dbc53d1cd95cf8c7906d32c5f7eff80c3f2aeffebdccd10a998d4fabf1d2b209854bc9ae1015b1aa5
-EBUILD EmptyEpsilon-2022.10.28.ebuild 2765 BLAKE2B fba0c42d0d180e2389a5fe787e4798421095c5be8f91c9121e31082976821cf90f241347d809167dc607aced60f463ccc39c81d9234ac40bba89daa962adae0e SHA512 a69cea4a5c56c5c7451414babfb083630cc6bcae2fb3d83a3dc54cfb3eab644fc850d4c0d7e0201b6f4ad272f70c21a0f4afbf16cb5b4c137242562408175aa8
+EBUILD EmptyEpsilon-2022.10.28.ebuild 3587 BLAKE2B c718acc282ade604d546d7ed9757afa8ac8090167c3a20a955d1db37d7c890be3d860b17ae0a2ea17d3e2f727516fff7b7dfbadd5cb53c5f5a6d4e76292954d8 SHA512 1e726c1770e97b918dbeb0eb2b9726a1d76a16647af594cd4fe3bcb036ad70db7c3129f5e26770b55916ef41e50a88a52e377f6f13b62ad6b411bd56f0f88650
MISC metadata.xml 329 BLAKE2B 8473231ca386ac0a49c270619d7dbe528f578e6dafda3aff92309e947fdae58e6a09b8895e9f051dcf4f70854351756188463e2a987b03939eb41d3cc9346893 SHA512 75c1304961cb113e7957b9f40e091f343af41f7ab74ce59ad20840a883179e8123cc571f6cf45f77ca15bebadecee5e0ed945dc7eae614770b1f943fc195e7b2