summaryrefslogtreecommitdiff
path: root/games-simulation/EmptyEpsilon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /games-simulation/EmptyEpsilon
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'games-simulation/EmptyEpsilon')
-rw-r--r--games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23.ebuild68
-rw-r--r--games-simulation/EmptyEpsilon/Manifest6
-rw-r--r--games-simulation/EmptyEpsilon/files/EmptyEpsilon-Make-CMake-call-find_package-glm.patch35
-rw-r--r--games-simulation/EmptyEpsilon/files/SeriousProton-Unbundle-json11.patch27
-rw-r--r--games-simulation/EmptyEpsilon/metadata.xml8
5 files changed, 144 insertions, 0 deletions
diff --git a/games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23.ebuild b/games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23.ebuild
new file mode 100644
index 000000000000..5d9e67d4a9fb
--- /dev/null
+++ b/games-simulation/EmptyEpsilon/EmptyEpsilon-2021.06.23.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="A spaceship bridge simulator game."
+HOMEPAGE="https://daid.github.io/EmptyEpsilon/"
+# This bundles SeriousProton as the build system does not support using
+# a separate SeriousProton instance (and currently EmptyEpsilon seems to
+# be the only consumer).
+SRC_URI="https://github.com/daid/EmptyEpsilon/archive/EE-${PV}.tar.gz -> EmptyEpsilon-${PV}.tar.gz
+ https://github.com/daid/SeriousProton/archive/EE-${PV}.tar.gz -> SeriousProton-${PV}.tar.gz"
+
+# EmptyEpsilon is mostly licensed under GPL, however the art ressources
+# use Creative Commons and the bundled SeriousProton is MIT-licensed.
+LICENSE="GPL-2 CC-BY-SA-3.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-cpp/json11-1.0.0
+ media-libs/libglvnd
+ media-libs/libsfml
+ >=media-libs/glm-0.9.9.8
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/EmptyEpsilon-EE-${PV}"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} == "binary" ]]; then
+ return
+ fi
+
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -lt 11 ]]; then
+ # ld: /usr/lib64/libsfml-audio.so: undefined reference to `std::__throw_bad_array_new_length()@GLIBCXX_3.a4.29'
+ eerror "${PN} requires GCC >= 11. Run gcc-config to switch your default compiler."
+ die "Need at least GCC >= 11"
+ fi
+ fi
+}
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-Make-CMake-call-find_package-glm.patch"
+ eapply --directory="${WORKDIR}/SeriousProton-EE-${PV}" \
+ "${FILESDIR}/SeriousProton-Unbundle-json11.patch"
+
+ eapply_user
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local version=( $(ver_rs 1- ' ') )
+ local mycmakeargs=(
+ -DSERIOUS_PROTON_DIR="${WORKDIR}/SeriousProton-EE-${PV}/"
+ -DOpenGL_GL_PREFERENCE=GLVND
+ -DCPACK_PACKAGE_VERSION="${PV}"
+ -DCPACK_PACKAGE_VERSION_MAJOR="${version[0]}"
+ -DCPACK_PACKAGE_VERSION_MINOR="${version[1]}"
+ -DCPACK_PACKAGE_VERSION_PATCH="${version[2]}"
+ )
+
+ cmake_src_configure
+}
diff --git a/games-simulation/EmptyEpsilon/Manifest b/games-simulation/EmptyEpsilon/Manifest
new file mode 100644
index 000000000000..1cd180e3724e
--- /dev/null
+++ b/games-simulation/EmptyEpsilon/Manifest
@@ -0,0 +1,6 @@
+AUX EmptyEpsilon-Make-CMake-call-find_package-glm.patch 1056 BLAKE2B 9522b7e2b45531ebd82e1f454a889ccd4c688adcbcdb753ca3c0c23ee2f0b94ed9537956bbbd8faca8305065017daf178278d5c14661d68de24d9c008339d6f2 SHA512 c6ccddf2a9f6fc7342428d5c197bec6fc01f24e3c9c9aa19bbccedba3c16bd825f59566fb0239b64bdd3914abfd584382742544f79c4266eef6e4ee7aabf3238
+AUX SeriousProton-Unbundle-json11.patch 722 BLAKE2B ab12cf044d38bc78eac3d4fdd7f3c9db062784177e848ca62135b356fec88be9876fa98f23d1195e3c3a2ef791166cb3c0fe220bce9c53a667b628a2e3602eb4 SHA512 da912f148738a409dd1eee4a8a926930ed31220c9b6477eb8a89da797dd659e2a576ca44875410cbc46c86f7d5b6e44037ed3f44c8d7ecd5a4680f12f626f013
+DIST EmptyEpsilon-2021.06.23.tar.gz 285211647 BLAKE2B 813b7e02ff7f046b7f28139063441eb421861b720c7b55d25930d3a418211fefdce7ac0e6ab705b4afe52df58f85a9298ff3e6be883a841e6eb9f7037eca297b SHA512 209ea68d99ef5ef53f1e3484d6471cafc01d4cb6505609a5b41d468387147127b4b4bbc20af75404d2cdef3d3cfb37bbb7f6fb3ae336d2f7e264e9c470ad7764
+DIST SeriousProton-2021.06.23.tar.gz 1181117 BLAKE2B 433280b7f6994bed0b86ffc4135a1e91bd9521c508b875332d17dc041da6b77a4260de784b6b75e79aab072d6bc68108a8b6b4949d674670f1d13ed1abe90d7e SHA512 4519801c30cd87436704023090ce39299573b02637a86b0d5c6ac0f4e99b4bddc6724b2b660edfd29d33a908b67268409a8c47dab7b5d59958a5abd52d5610bf
+EBUILD EmptyEpsilon-2021.06.23.ebuild 1957 BLAKE2B 9c88c669ee835bbf244392a85c334cac0cb9470605af2f196f9141476ebc6f7ca918a51025206b5b9bac3ee3ff93bb1e7250e1911bda3ccc213f1849fa6a17ee SHA512 bad61aca9a503fb24c47fdcdf7ce008e2c6ba6f92de4c8546dd1218e4991a365bf617db3f2bab9a0ebf366a8ef263cc91c7073705da9283c236701e8ce378de3
+MISC metadata.xml 246 BLAKE2B e270b04a529da44d267eaf5bfd160569fc99a3521dfc6495e0a4db19c98e5b9badf77774cc80c7be905f3e97b1c75784bc7b4cb6bfe659d726a47c7ae70e7bfb SHA512 7e2151bbca24beeefd585e18d6c1108442b2d9197679876bb180da3d4896602e83ea701432ff67fc61cccfa9bf642a01a62d87bacf32c55e0a54336c7c5a2c53
diff --git a/games-simulation/EmptyEpsilon/files/EmptyEpsilon-Make-CMake-call-find_package-glm.patch b/games-simulation/EmptyEpsilon/files/EmptyEpsilon-Make-CMake-call-find_package-glm.patch
new file mode 100644
index 000000000000..da52f0267f77
--- /dev/null
+++ b/games-simulation/EmptyEpsilon/files/EmptyEpsilon-Make-CMake-call-find_package-glm.patch
@@ -0,0 +1,35 @@
+From 7efb73d1a964f04646dba692323c1affcb25d16e Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flow@gentoo.org>
+Date: Fri, 8 Oct 2021 11:07:20 +0200
+Subject: [PATCH] Make CMake call find_package(glm)
+
+---
+ CMakeLists.txt | 12 +-----------
+ 1 file changed, 1 insertion(+), 11 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6fb5c88f6614..9d65d1ef2653 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -106,17 +106,7 @@ if(WITH_DISCORD)
+ endif()
+
+ # GLM
+-set(GLM_BASE_PATH "${EXTERNALS_DIR}")
+-
+-if(NOT EXISTS "${GLM_BASE_PATH}/glm/CMakeLists.txt")
+- set(GLM_ZIP "${DOWNLOADS_DIR}/glm.zip")
+- file(DOWNLOAD "https://github.com/g-truc/glm/releases/download/0.9.9.8/glm-0.9.9.8.zip" "${GLM_ZIP}" TIMEOUT 60 TLS_VERIFY ON)
+-
+- file(MAKE_DIRECTORY "${GLM_BASE_PATH}/glm")
+- execute_process(COMMAND ${CMAKE_COMMAND} -E tar -xf "${GLM_ZIP}" WORKING_DIRECTORY "${GLM_BASE_PATH}")
+-endif()
+-
+-add_subdirectory("${GLM_BASE_PATH}/glm" "${PROJECT_BINARY_DIR}/glm" EXCLUDE_FROM_ALL)
++find_package(glm)
+
+ set(SOURCES
+ src/main.cpp
+--
+2.32.0
+
diff --git a/games-simulation/EmptyEpsilon/files/SeriousProton-Unbundle-json11.patch b/games-simulation/EmptyEpsilon/files/SeriousProton-Unbundle-json11.patch
new file mode 100644
index 000000000000..deb44e9aee00
--- /dev/null
+++ b/games-simulation/EmptyEpsilon/files/SeriousProton-Unbundle-json11.patch
@@ -0,0 +1,27 @@
+From ae5ea143e6a9f57c797a96b9024c8acc60f05828 Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@gentoo.org>
+Date: Fri, 8 Oct 2021 13:26:27 +0200
+Subject: [PATCH] Unbundle json11
+
+---
+ CMakeLists.txt | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4b57a4f6631a..0a06c3186ff5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -86,10 +86,6 @@ add_subdirectory(src/lua)
+ add_subdirectory(src/GL)
+ add_subdirectory(src/libopus)
+
+-if(SERIOUSPROTON_WITH_JSON)
+- add_subdirectory(src/json11)
+-endif()
+-
+ #---------------------------------File lists-----------------------------------
+ set(source_files #All SeriousProton's objects to compile
+ src/clipboard.cpp
+--
+2.32.0
+
diff --git a/games-simulation/EmptyEpsilon/metadata.xml b/games-simulation/EmptyEpsilon/metadata.xml
new file mode 100644
index 000000000000..87a759d410cf
--- /dev/null
+++ b/games-simulation/EmptyEpsilon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>