summaryrefslogtreecommitdiff
path: root/games-server/steamcmd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /games-server/steamcmd
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'games-server/steamcmd')
-rw-r--r--games-server/steamcmd/Manifest1
-rw-r--r--games-server/steamcmd/steamcmd-1.0-r2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/games-server/steamcmd/Manifest b/games-server/steamcmd/Manifest
index 5cfc796bb2b1..6d8f3659c50b 100644
--- a/games-server/steamcmd/Manifest
+++ b/games-server/steamcmd/Manifest
@@ -3,4 +3,5 @@ AUX steamcmd.confd-r1 576 BLAKE2B 6e944d2a707c1428a73dccd51abbd07732d622707aad00
AUX steamcmd.initd-r1 791 BLAKE2B 9ba1002a7faed781bd24f1e0534ec09ba0036b1fc97be3ba4a57aadc764c50573059b5c4cbe60808ddaa7e3cf808a5c8b43ec2bc25a0fd3039d41fa902962725 SHA512 56f8fa87d3cfc0de635fb95516b0e8e6c471155e3f397b8ab40e877ce770ff3aabc2846156f98de9ba8810e71f18a3fb202f9c098efaa1b97ecdca11ff689bbe
DIST steamcmd-1.0.tar.gz 2428561 BLAKE2B c51dbb8c7731222eb748508b8a84a4cbda55168c85116078074bd0da85018a344ca088b7af41a07a96c15e64d0aeb28fb90cd85d99f444e9425f5a326c1823fe SHA512 b37debfa45e5578cc065924770258a026adad339aae86da1a66e71ac4ee80d2ddbca9060ca4c734affd2c6902635e7b32e2b3efe11bb600969654b3abeb3839e
EBUILD steamcmd-1.0-r1.ebuild 1182 BLAKE2B b6d110366c58552af2346ebdd73419e3ba969f22235309ddd90a7561c9a5b904707a0e8d1153694687bab4fe8f20cd77c0f21d45930e79ac1fd1aa609657a42e SHA512 fbd52e3548789fad51642ea0b7059bf130daa1c7009b773053aeac7c8fd7eafa2c273078ac992303da41f082b8fc38a32eb23fe480e528b4b019ced00ff4e7a2
+EBUILD steamcmd-1.0-r2.ebuild 1141 BLAKE2B aaae600f9a1b5eed4d9e854154eb67ce1fee129d5588a8d02bb2429fca2000cef1fc72db5a945acee4370e3f886f634351a3ef1fcc54b7d4c42b1657c631896f SHA512 334d68b9a17e3ea2ea2de7cf3ac43e912a4c37926d8cca31ef23760c5e360d757a0f92f8b24cbb1c1c496f17faf1a3ab6b2aaad0da0b44e44944c643ee85c246
MISC metadata.xml 754 BLAKE2B 0e5610ae928ebb8324f903b6a4429e53c503f604400f09cf40faf721c9187536e1b9412dcbbfa5b79d44ac6f2efa2bc87ba7dc5f54ccf87388691c287ab7478c SHA512 eac3fb10da1a2b27986c75465b5e7ff7e2c74ca09b396053715d9e403ad6bb190eb7747c65dee54b6555e4ae8a014574a26bd7eb10a047e00ee733a90b3b217a
diff --git a/games-server/steamcmd/steamcmd-1.0-r2.ebuild b/games-server/steamcmd/steamcmd-1.0-r2.ebuild
new file mode 100644
index 000000000000..3b5b42805394
--- /dev/null
+++ b/games-server/steamcmd/steamcmd-1.0-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 user
+
+DESCRIPTION="This is the command-line version of the Steam client for dedicated servers"
+HOMEPAGE="https://developer.valvesoftware.com/wiki/SteamCMD"
+SRC_URI="https://steamcdn-a.akamaihd.net/client/installer/steamcmd_linux.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+ Steam"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ acct-group/steamcmd
+ acct-user/steamcmd
+ app-misc/screen
+"
+
+RESTRICT="bindist mirror"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="
+ opt/steamcmd/linux32/libstdc++.so.6
+ opt/steamcmd/linux32/steamcmd
+"
+
+src_install() {
+ diropts -o steamcmd -g steamcmd
+ dodir /opt/steamcmd
+ keepdir /opt/steamcmd/{.steam,.steam/sdk32,linux32}
+
+ exeopts -o steamcmd -g steamcmd
+ exeinto /opt/steamcmd
+ doexe steamcmd.sh
+
+ exeopts -o steamcmd -g steamcmd
+ exeinto /opt/steamcmd/linux32
+ doexe linux32/steamcmd linux32/libstdc++.so.6
+
+ newinitd "${FILESDIR}"/steamcmd.initd-r1 steamcmd
+ newconfd "${FILESDIR}"/steamcmd.confd-r1 steamcmd
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}