summaryrefslogtreecommitdiff
path: root/games-rpg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /games-rpg
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/Manifest.gzbin8290 -> 8291 bytes
-rw-r--r--games-rpg/freedroidrpg/Manifest4
-rw-r--r--games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild97
-rw-r--r--games-rpg/freedroidrpg/metadata.xml62
4 files changed, 121 insertions, 42 deletions
diff --git a/games-rpg/Manifest.gz b/games-rpg/Manifest.gz
index 911500f3146f..7e311f3bd2a2 100644
--- a/games-rpg/Manifest.gz
+++ b/games-rpg/Manifest.gz
Binary files differ
diff --git a/games-rpg/freedroidrpg/Manifest b/games-rpg/freedroidrpg/Manifest
index 2e13858b90e8..29ff5904d3b3 100644
--- a/games-rpg/freedroidrpg/Manifest
+++ b/games-rpg/freedroidrpg/Manifest
@@ -1,3 +1,5 @@
DIST freedroidRPG-0.16.tar.gz 225570013 BLAKE2B ad87ad3d368c94eb1f3dae2d4c3df97b9bc88acccbec4cbcd31e42b411bb96506faac23f8de9b0317a1ab926b34bd01196adce617ab7b731354049d3fb010643 SHA512 039ee4bfcd58e29a3cfa26ae7f2bc8aed7c289119476bb8f8486006910cf6a2127ba49f7526fac887392ca9e5320fb1a59ba068834e162348905423908b0755a
+DIST freedroidRPG-1.0rc2.tar.gz 233852127 BLAKE2B c87c2314d17037873acf4fc24ce20790c9ec40c8f7b1ea27e6ab9c543abb671bc50b3ff5b86900f7111d1f1a899213dcb90529d2e39918801c9cc3a42585f02e SHA512 a79afdb089691dd59b0128f34f7068c69fac8c057a0485bca3275f4914b1c9c0f21cbb9102ecdc99911b70456c078dbdeb8981fd7714836cd9535677bcc4d1e7
EBUILD freedroidrpg-0.16-r1.ebuild 1781 BLAKE2B 4ab53881ba87e23fd60353a9f303eb321ca9cfddec398c5e43dd1c51d4939803c0ce60491389c62304efa7159ce2c7452d25de27241a9131275425741c8a255b SHA512 2f4df51a1208eb76f03d830d671f8433bdb2a0c03ed99c06fb1af4e1be8e6e4c09dd566f7bf6faddf6dbf81c1c6c20e80087fbd7cd2e3fe51fbacb0d02fa90ec
-MISC metadata.xml 2288 BLAKE2B e60e49e0140a270511938adc92ee1d0498590c0daff8fc26ab1451a29bb1ede358991da211f821b04d9432c6792335e18c328aeb8c6613b9b3a87954ba8b2c8d SHA512 196a3711abe685277462235c912a41b46dc8fa5122d611f4f864300262ae888611951451162db87e75eafa7720d662a1fc51e4441b0d9fb730109f6c2c4aadca
+EBUILD freedroidrpg-1.0_rc2.ebuild 2309 BLAKE2B d92f1b9409208a7aa1452ad88adfd7b2afb3922c7822b38cce65172960beb5600a550d43d5e3affd443fa3f0c72bac2b3a3b58d0888e5ac5e51ceeb246f7f333 SHA512 134ce58e536eb3beab0a0430343caeac56f0e9a2a8c2da79809e8dd4d442fe69ac926e0959e370b8ffdf709a668dfd53327dd0e5d30d441c5b0fc6b919017536
+MISC metadata.xml 1683 BLAKE2B ec2dd3f95adac5207c2c267c676487a9bce23014ae2fe5aec5c8ac29c06e943d61ebc9889a863e2045bfb9c31c871c77030567ef6759b8280f277718525bee8d SHA512 a65fc6904f206288a06e67956c56c7ff0d80ccd8bd634e6c085bbd8ed88977bec5ae5984b0e02acd1c89b403ab8bc211d697140d6f3d00a9205c1db37c2d5346
diff --git a/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild
new file mode 100644
index 000000000000..8906a2a1a387
--- /dev/null
+++ b/games-rpg/freedroidrpg/freedroidrpg-1.0_rc2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit autotools flag-o-matic desktop python-any-r1 xdg
+
+MY_PV=$(ver_rs 2 '')
+DESCRIPTION="A modification of the classical Freedroid engine into an RPG"
+HOMEPAGE="http://www.freedroid.org"
+SRC_URI="ftp://ftp.osuosl.org/pub/freedroid/freedroidRPG-$(ver_cut 1-2)/freedroidRPG-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug devtools nls opengl profile sanitize sound"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0
+ media-libs/libpng:0
+ media-libs/libsdl[opengl?,sound?,video]
+ media-libs/sdl-image[jpeg,png]
+ >=media-libs/sdl-gfx-2.0.21
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ sound? (
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/sdl-mixer[vorbis] )
+ devtools? ( media-libs/sdl-ttf )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ nls? ( sys-devel/gettext )
+ sanitize? ( || ( sys-devel/gcc[sanitize] sys-devel/clang-runtime[sanitize] ) )"
+
+S="${WORKDIR}/${PN}-${MY_PV^^}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^dist_doc_DATA/d' \
+ -e '/-pipe/d' \
+ -e '/^SUBDIRS/s/pkgs//' \
+ Makefile.am || die
+ python_fix_shebang src data/sound
+ eautoreconf
+}
+
+src_configure() {
+ # this can produce strange results due to 'imprecise' math computations
+ filter-flags -ffast-math
+
+ local myconf=(
+ --disable-fastmath
+ --with-embedded-lua
+ --localedir=/usr/share/locale
+ $(use_enable nls)
+ $(use_enable opengl)
+ $(use_enable sound)
+ $(use_enable debug)
+ $(use_with debug extra-warnings)
+ $(use_enable debug backtrace)
+ $(use_enable sanitize sanitize-address)
+ $(use_enable profile rtprof)
+ $(use_enable devtools dev-tools)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ local i
+
+ default
+ for i in 48 64 96 128
+ do
+ doicon -s ${i} pkgs/freedesktop/icons/hicolor/${i}x${i}/apps/"${PN}".png
+ done
+ doicon -s scalable pkgs/freedesktop/icons/hicolor/scalable/apps/freedroidRPG.svg
+ make_desktop_entry "${PN}" "Freedroid RPG" "${PN}"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ local v min="1.0_rc1"
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt "${min}"; then
+ echo
+ ewarn "${P} is not compatible with save games before ${min}."
+ ewarn "Please start a new character."
+ echo
+ fi
+ done
+}
diff --git a/games-rpg/freedroidrpg/metadata.xml b/games-rpg/freedroidrpg/metadata.xml
index d9e96aa7715a..01b748c23632 100644
--- a/games-rpg/freedroidrpg/metadata.xml
+++ b/games-rpg/freedroidrpg/metadata.xml
@@ -6,49 +6,29 @@
<name>Gentoo Games Project</name>
</maintainer>
<longdescription>
-Hello, and welcome to the Freedroid page.
+FreedroidRPG is an open source role playing game
-THE CLASSICAL FREEDROID: Freedroid is a clone of the classic game
-"Paradroid" on Commodore 64 with some improvements and extensions to
-the classic version.
+The game tells the story of a world destroyed by a conflict between robots and
+their human masters. Play as Tux in a quest to save the world from the
+murderous rebel bots who know no mercy. You get to choose which path you wish
+to follow, and freedom of choice is everywhere in the game.
-In this game, you control a robot, depicted by a small white ball with
-a few numbers within an interstellar spaceship consisting of several
-decks connected by elevators.
+FreedroidRPG features a real time combat system with melee and ranged weapons,
+fairly similar to the proprietary game Diablo. There is an innovative system of
+programs that can be run in order to take control of enemy robots, alter their
+behavior, or improve one's characteristics. You can use over 50 different kinds
+of items and fight countless enemies on your way to your destiny. An advanced
+dialog system provides story background and immersive role playing situations.
-The aim of the game is to destroy all enemy robots, depicted by small
-black balls with a few numbers, by either shooting them or seizing
-control over them by creating connections in a short subgame of
-electric circuits.
-
-Development of this game is now complete. The final version came out
-in august 2003 and runs on Linux, Mac OSX, Sharp Zaurus and even that
-strange Windows wannabe of an operating system. Thanks to all who
-helped.
-Minor fixes and maintainance will of course still continue though...
-
-FREEDROID RPG: The Freedroid RPG is an extension/modification of the
-classical freedroid engine into an RPG. The main differences to the
-classical version are as follows:
-* The Tux is the main character of the rpg. He is not displayed as a
- ball like in Freedroid but rather as an animated character, while
- other droids and humans in the game are still represented as the balls
- with some number or code in them.
-* Dialogs and chatting with friendly droids and humans:
- Multiple-choice menus and voice samples (with subtitles for those
- without sound).
-* Melee weapons, armour and other items to be equipped have been
- added.
-* An automap feature was added.
-* Saving and loading of games.
-* A shop to trade things.
-* Controls are different: Mouse can be used to do everything.
- Joystick is not supported for moving around any more.
-* The archive size (including sound samples) is about 10 times as big
- as for the classical version. I'd like to appologize to all 56K modem
- owners at this point.
+The game is complete, fully playable, and can provide about 10 hours of fun. It
+is still being actively developed, and help is welcome in many areas. People
+having - or trying to acquire - programming, map editing, or writing skills
+will find FreedroidRPG to be an exciting, fast-moving project in which they can
+fully express their creativity.
</longdescription>
- <upstream>
- <remote-id type="sourceforge">freedroid</remote-id>
- </upstream>
+<use>
+ <flag name="devtools">Compile the additional dev tools</flag>
+ <flag name="profile">Enable the integration of the ingame real-time profiler</flag>
+ <flag name="sanitize">Compile with address sanitizer</flag>
+</use>
</pkgmetadata>