summaryrefslogtreecommitdiff
path: root/games-rpg/zsdx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /games-rpg/zsdx
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'games-rpg/zsdx')
-rw-r--r--games-rpg/zsdx/Manifest4
-rw-r--r--games-rpg/zsdx/zsdx-1.9.0-r1.ebuild39
2 files changed, 20 insertions, 23 deletions
diff --git a/games-rpg/zsdx/Manifest b/games-rpg/zsdx/Manifest
index e486a3865c69..b0c2274e08a8 100644
--- a/games-rpg/zsdx/Manifest
+++ b/games-rpg/zsdx/Manifest
@@ -1,3 +1,3 @@
-DIST zsdx-1.9.0.tar.gz 20757184 BLAKE2B 392aa36cfddaa82367cd3aa6769ffeb95f5e7235b5574d2793af629f289da107a67b70bfc2ad7d86651d2145a3f956bc000102919ca65ee18a1d83eac282d119 SHA512 2fc540d19856734050674945dd4903f254b325cab08ae0199722ae014447523ad9e979b54ddfd59d5cbc290b783481c79d5e155115c90f24feab5587d52804ee
-EBUILD zsdx-1.9.0-r1.ebuild 1130 BLAKE2B 24034d6b972196710ca4d9921c941bc661e0c05ece6dc5680e181ef884d225c1c1694843131c9c2cd2c0ebc792052d2e4dcb96d828fca5d6296ceff3427a5115 SHA512 29d003036632b3ac85d49db00ba01667ec31e20400d99bb49a67c6bb0743edf9ccac64972556b0b492ce064216d6e47d64b9f3b68948a39d3c1fcbb21ad62735
+DIST zsdx-zsdx-1.9.0.tar.gz 20760682 BLAKE2B 7063b7bc34a03c5e1879eaae78d28dcf28ae9799eed2ef2b4422f3fad709234ae6ebb67f641d76df370b27b72eb6f9ed6d611b8bead37b87287637cb28b072cb SHA512 673a7db1dadfae09df23b189b9e18af1182cb731897e4067f47867387c04b21308991116c6f840cb228adee9c459565c2f5e6f1a01e885ea23c00347d4d64540
+EBUILD zsdx-1.9.0-r1.ebuild 1136 BLAKE2B d5f5350b45db9affff5c685f542a2686d89bb7508e55714a6741059a52922773f1ad8b0e664aff46abbd0e626f80744ce9b0febfa3b0e54801e0996bacc9b3c1 SHA512 93406617f8762a1a6a24a0331d61856451fc7fcf2fef2d33ad2e539529fabe9ecf5933ada5418ea72ff9e4625efecc807785729ec99663440ac632f6b769f34c
MISC metadata.xml 333 BLAKE2B 34c8b3d3b3ef4c78241d40bd05613959e3d541561f6973c47c57489b0eea0e84ef21909fcb21102bdb4b5eaf0b8051c075a9649fe0975ead3c4cd1ff4c1471f7 SHA512 8135204b08f68188a8dc178b3083600e01a860b043cbc26415a111f6b23030cc067754dff74d77ac476e757caece3d44688f12126e81c17eaff74e4840f59ec9
diff --git a/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild b/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild
index dc00fda49542..ac6267f86cb6 100644
--- a/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild
+++ b/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils eutils gnome2-utils
+EAPI=7
-DESCRIPTION="A free 2D Zelda fangame"
-HOMEPAGE="http://www.solarus-games.org/"
-SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}.tar.gz"
+CMAKE_MAKEFILE_GENERATOR=emake
+inherit cmake desktop xdg
+
+DESCRIPTION="Free 2D Zelda fangame"
+HOMEPAGE="https://www.solarus-games.org/"
+SRC_URI="https://gitlab.com/solarus-games/${PN}/-/archive/${PN}-${PV}/${PN}-${PN}-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-${PV}"
LICENSE="all-rights-reserved CC-BY-SA-3.0 GPL-3"
SLOT="0"
@@ -20,34 +23,28 @@ RDEPEND="
"
DEPEND="app-arch/zip"
+DOCS=( ChangeLog readme.txt )
+
+src_prepare() {
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DSOLARUS_INSTALL_DATAROOTDIR="/usr/share"
-DSOLARUS_INSTALL_BINDIR="/usr/bin"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newicon -s 48 build/icons/${PN}_icon_48.png ${PN}.png
newicon -s 256 build/icons/${PN}_icon_256.png ${PN}.png
# install proper wrapper script
- rm -f "${ED}"/usr/bin/${PN}
+ rm "${ED}"/usr/bin/${PN} || die
make_wrapper ${PN} "solarus \"/usr/share/solarus/${PN}\""
make_desktop_entry "${PN}" "Zelda: Mystery of Solarus DX"
}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}