summaryrefslogtreecommitdiff
path: root/games-rpg/zsdx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-rpg/zsdx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-rpg/zsdx')
-rw-r--r--games-rpg/zsdx/Manifest3
-rw-r--r--games-rpg/zsdx/metadata.xml11
-rw-r--r--games-rpg/zsdx/zsdx-1.9.0-r1.ebuild53
3 files changed, 67 insertions, 0 deletions
diff --git a/games-rpg/zsdx/Manifest b/games-rpg/zsdx/Manifest
new file mode 100644
index 000000000000..e486a3865c69
--- /dev/null
+++ b/games-rpg/zsdx/Manifest
@@ -0,0 +1,3 @@
+DIST zsdx-1.9.0.tar.gz 20757184 BLAKE2B 392aa36cfddaa82367cd3aa6769ffeb95f5e7235b5574d2793af629f289da107a67b70bfc2ad7d86651d2145a3f956bc000102919ca65ee18a1d83eac282d119 SHA512 2fc540d19856734050674945dd4903f254b325cab08ae0199722ae014447523ad9e979b54ddfd59d5cbc290b783481c79d5e155115c90f24feab5587d52804ee
+EBUILD zsdx-1.9.0-r1.ebuild 1130 BLAKE2B 24034d6b972196710ca4d9921c941bc661e0c05ece6dc5680e181ef884d225c1c1694843131c9c2cd2c0ebc792052d2e4dcb96d828fca5d6296ceff3427a5115 SHA512 29d003036632b3ac85d49db00ba01667ec31e20400d99bb49a67c6bb0743edf9ccac64972556b0b492ce064216d6e47d64b9f3b68948a39d3c1fcbb21ad62735
+MISC metadata.xml 333 BLAKE2B 34c8b3d3b3ef4c78241d40bd05613959e3d541561f6973c47c57489b0eea0e84ef21909fcb21102bdb4b5eaf0b8051c075a9649fe0975ead3c4cd1ff4c1471f7 SHA512 8135204b08f68188a8dc178b3083600e01a860b043cbc26415a111f6b23030cc067754dff74d77ac476e757caece3d44688f12126e81c17eaff74e4840f59ec9
diff --git a/games-rpg/zsdx/metadata.xml b/games-rpg/zsdx/metadata.xml
new file mode 100644
index 000000000000..733429dcbd22
--- /dev/null
+++ b/games-rpg/zsdx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">christopho/zsdx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild b/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild
new file mode 100644
index 000000000000..dc00fda49542
--- /dev/null
+++ b/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils eutils gnome2-utils
+
+DESCRIPTION="A free 2D Zelda fangame"
+HOMEPAGE="http://www.solarus-games.org/"
+SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="all-rights-reserved CC-BY-SA-3.0 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="
+ >=games-engines/solarus-1.3.0
+ <games-engines/solarus-1.4.0
+"
+DEPEND="app-arch/zip"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSOLARUS_INSTALL_DATAROOTDIR="/usr/share"
+ -DSOLARUS_INSTALL_BINDIR="/usr/bin"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon -s 48 build/icons/${PN}_icon_48.png ${PN}.png
+ newicon -s 256 build/icons/${PN}_icon_256.png ${PN}.png
+
+ # install proper wrapper script
+ rm -f "${ED}"/usr/bin/${PN}
+ make_wrapper ${PN} "solarus \"/usr/share/solarus/${PN}\""
+
+ make_desktop_entry "${PN}" "Zelda: Mystery of Solarus DX"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}