summaryrefslogtreecommitdiff
path: root/games-rpg/to-the-moon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /games-rpg/to-the-moon
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'games-rpg/to-the-moon')
-rw-r--r--games-rpg/to-the-moon/Manifest2
-rw-r--r--games-rpg/to-the-moon/to-the-moon-0-r1.ebuild53
2 files changed, 18 insertions, 37 deletions
diff --git a/games-rpg/to-the-moon/Manifest b/games-rpg/to-the-moon/Manifest
index c15d236e7cf1..39e8975f694d 100644
--- a/games-rpg/to-the-moon/Manifest
+++ b/games-rpg/to-the-moon/Manifest
@@ -1,3 +1,3 @@
DIST ToTheMoon_linux_1389114090.sh 75823678 BLAKE2B de63a8c5eff7d99f5af4fbc85c8e416c7bd7a07fad03dfb0424bf43f410bdbc9a0d064c8892dbb6c9fdc637391f2b2ef6ef40c72c501790ffec0aac8448add21 SHA512 bed844f143ef9c3ff8fe93da186422e84d259229874c331315d8f1c7538fd6c417d6ca1aeecbe6c2a664fad98aff51f4723227d0ef07612acf29f86313f9aa1a
-EBUILD to-the-moon-0-r1.ebuild 2423 BLAKE2B d9f921cfa744e4ad10134811a20b134aaead701367ba3747cdf2b50fe4010634ddef498271b1ef13343a4711080d34c668ba7e0f1393b382700d5b2245946e50 SHA512 5e5446a9abbbb7d2ee04f44f731bf4442e6d3d28d0ba6e6e126178e1ceb2fae36eb25362d1a4c0e313337676596a852ecd9eb892fcb6e6369f0439802c5b4849
+EBUILD to-the-moon-0-r1.ebuild 2084 BLAKE2B 3f054999698d3b4cbeb53bae17aeef92824bb90ece8085c3f8235602ca0a6d0729437284d78957f9834160ebac0827ea08ce3f144fbbbecf583695f5442c2dff SHA512 986e1b2b4c57fd65a7d71d3264f5c1a0e6346776fc48960c12a5fea3ce1eee8adf50ce66e8df460b72f6bf373676bbbd7ef981b5fe26570c6a09af0e5d4269ee
MISC metadata.xml 325 BLAKE2B 27d3f66c92edf0dda747247d5a31972620750facfbad0d6f82c51c5ca5a99327a0b3918264ab590da1e7250ee8aebb85393981049a33843883238734df348d31 SHA512 a8068b353b7597ae988ad3fd9855339beb981eb11a392483129346d2ee51d658934fb772e8b3f3062e1d14d553e73de9f6bc2f456b4bf5de15902257c22e69ce
diff --git a/games-rpg/to-the-moon/to-the-moon-0-r1.ebuild b/games-rpg/to-the-moon/to-the-moon-0-r1.ebuild
index 619cdd026667..a5cc9e2b6f8b 100644
--- a/games-rpg/to-the-moon/to-the-moon-0-r1.ebuild
+++ b/games-rpg/to-the-moon/to-the-moon-0-r1.ebuild
@@ -3,27 +3,25 @@
EAPI=7
-inherit desktop gnome2-utils unpacker wrapper
+inherit desktop unpacker wrapper
+
+MY_PN="ToTheMoon"
-MY_PN=ToTheMoon
DESCRIPTION="Two doctors traversing the memories of a dying man to fulfill his last wish"
HOMEPAGE="http://freebirdgames.com/games/to-the-moon"
SRC_URI="${MY_PN}_linux_1389114090.sh"
-S="${WORKDIR}"/data
+S="${WORKDIR}/data"
LICENSE="all-rights-reserved bundled-libs? ( LGPL-2 LGPL-2.1 ZLIB )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bundled-libs"
+RESTRICT="bindist fetch"
-RESTRICT="fetch bindist splitdebug"
-
-QA_PREBUILT="opt/${PN}/${MY_PN}.bin*"
-if [[ ${ARCH} == "amd64" ]] ; then
- QA_PREBUILT="${QA_PREBUILT} opt/${PN}/lib64/*"
-else
- QA_PREBUILT="${QA_PREBUILT} opt/${PN}/lib/*"
-fi
+QA_PREBUILT="
+ opt/${PN}/${MY_PN}.bin*
+ opt/${PN}/lib/*
+ opt/${PN}/lib64/*"
# TODO: unbundling sdl-sound breaks the game
RDEPEND="
@@ -37,17 +35,11 @@ RDEPEND="
media-libs/sdl2-ttf
)
"
-DEPEND="
- sys-apps/coreutils
- sys-apps/grep
-"
pkg_nofetch() {
- einfo
einfo "Please buy & download ${SRC_URI} from:"
einfo " ${HOMEPAGE}"
einfo "and move/link it to your DISTDIR directory."
- einfo
}
src_unpack() {
@@ -64,35 +56,24 @@ src_unpack() {
src_install() {
local dir=/opt/${PN}
- local libsuffix=$(usex amd64 "64" "")
- local arch=$(usex amd64 "x86_64" "x86")
+ local libsuffix=$(usex amd64 64 '')
+ local arch=$(usex amd64 x86_64 x86)
- insinto "${dir}"
+ insinto ${dir}
doins -r noarch/{Audio,Data,Fonts,Graphics,Game.ini,mkxp.conf,ToTheMoon.png}
- exeinto "${dir}"
+ exeinto ${dir}
doexe ${arch}/${MY_PN}.bin.${arch}
- exeinto "${dir}/lib${libsuffix}"
+ exeinto ${dir}/lib${libsuffix}
if use bundled-libs ; then
doexe ${arch}/lib${libsuffix}/*
else
doexe ${arch}/lib${libsuffix}/libSDL_sound-1.0.so.1
fi
- make_wrapper ${PN} "./${MY_PN}.bin.${arch}" "${dir}" "${dir}/lib${libsuffix}"
- make_desktop_entry ${PN} "To the Moon"
- newicon -s 32 noarch/${MY_PN}.png ${PN}.png
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
+ make_wrapper ${PN} ./${MY_PN}.bin.${arch} ${dir}{,/lib${libsuffix}}
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
+ newicon noarch/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} "To the Moon"
}